+ Responder ao Tópico



  1. Ola amigos
    Sou meio leigo em scripts e vi recentemente um para deslogar um segundo usuario que tenta usar a mesma senha do primeiro usuario em pppoe usando user-manager conforme link abaixo.

    http://wiki.mikrotik.com/wiki/How_to...ed_with_Radius

    Estou tentando implementar esse scritp para o hotspot e user-manager, pois em minha rede tem clientes usando a mesmo login, mas to tendo muita dificuldade, em fazer esse script teria alguem pra me dar um luz,
    deem uma olhada .
    valew gaelra...



    :local userX;
    :local userY;
    :local i;
    :local u;
    :local clogged 0;
    :local addr [ :resolve "www.maxfava.com" ];
    :local addr2 [ :resolve "www.maxfava.com" ];

    :foreach i in=[/ip hotspot active find] do={
    :set userX [/ip hotspot active get $i users];
    :set clogged 0;

    :foreach u in=[/ip hotspot active find users=$userX ] do={
    :set clogged (clogged +1);

    :if (clogged>1) do={
    :set userY [/ip hotspot active get $u users];
    :set addr [/ip hotspot active get $u user];
    :set addr2 [/ip hotspot active get $i user];

    :if ($addr != addr2) do={
    :log info "MPPP: FIRST ACTIVE <<$userX>> FROM IP $addr2";
    :log info "MPPP: THE $clogged° <<$userY>> CALLING FROM IP $addr NOW DISCONNECTED";
    /ip hotspot active remove $u;

    }

    }
    }
    }

  2. ehhh... lah no serviço.. ppoe-server.. q vc criou.. tem a opção one session per host...

    serah q resolve? uma sessão por makina...

    gracias






Tópicos Similares

  1. Ajuda em Script
    Por fabiocp1984 no fórum Redes
    Respostas: 4
    Último Post: 28-09-2009, 14:25
  2. Ajuda em script mikrotik
    Por rojao123 no fórum Redes
    Respostas: 4
    Último Post: 08-05-2009, 23:08
  3. usuario expirando - user manager
    Por alencar2 no fórum Redes
    Respostas: 5
    Último Post: 21-01-2009, 08:57
  4. Ajuda em servidor pppoe
    Por djchico no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-09-2005, 09:18
  5. ajuda em script shell
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-02-2003, 13:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L