+ Responder ao Tópico



  1. #1

    Talking Bloquear download somente de 1 IP

    Tenho uma lan house...

    Uso servidor MK com DHCP, Cache e Divisão de Banda.

    Como faço para o IP 192.168.0.10 nao aceitar fazer downloads ou somente poder fazer downloads de até 1 mb.

    mas a navegação fica normal, quero restrigir somente Downloads

  2. #2



  3. #3

    Unhappy

    To precisando muito disso...

    Alguem mais pode me ajudar, pois nao conseguir com essa ajuda ai de cima...

    Obrigado!

  4. #4

    Wink

    Citação Postado originalmente por webier Ver Post
    Tenho uma lan house...

    Uso servidor MK com DHCP, Cache e Divisão de Banda.

    Como faço para o IP 192.168.0.10 nao aceitar fazer downloads ou somente poder fazer downloads de até 1 mb.

    mas a navegação fica normal, quero restrigir somente Downloads

    Amigo, bom dia.

    Veja se isto te ajuda:

    Acesse o menu IP, FIREWALL
    Na aba "FILTER RULES", crie uma nova regra.

    Configure assim:
    • CHAIN = FORWARD
    • SRC. ADDRESS = ENDEREÇO DO CLIENTE A QUAL APLICARÁ O LIMITE.
    • PROTOCOL = 6 (TCP)
    Agora abra a aba "ADVANCED"

    "TCP FLAGS", escolha a opção "SYN" (este comando é responsável pelo recebimento da requisição de conexão do cliente e também pelo aviso de que a porta está ou não disponível para acesso)

    Abra a aba "EXTRA"

    Em "CONNECTION LIMIT" / "LIMIT", defina o número de conexões máximas para este cliente ou o tamanho disponível para uso de downloads.

    No campo "NETMASK", defina a máscara 32 (32 significa que a regra será aplicada apenas a este IP).

    Agora abra a aba "ACTION"

    EM "ACTION", escolha a opção "DROP".

    A regra será liberada para uma quantidade específica de conexões simultâneas para o cliente abusivo ou uma máquina, bloqueando requisições de conecções acima do limite.

    Pode configurar da forma que quiser.

    Divirta-se.

    Um abraço.

    Espero que tenha ajudado.



  5. #5

    Talking

    coloquei em "CONNECTION LIMIT" / "LIMIT" = 500

    queria limitar em 500kb o tamanho maior do arquivo que pode ser baixado na maquina 192.168.0.10

    coloquei para baixar um arquivo de 104mb... ele aceitou baixar... deixei ir até 2mb e cancelei

    Como faço para limitar em 500kb?

  6. #6

    Padrão

    Citação Postado originalmente por webier Ver Post
    coloquei em "CONNECTION LIMIT" / "LIMIT" = 500

    queria limitar em 500kb o tamanho maior do arquivo que pode ser baixado na maquina 192.168.0.10

    coloquei para baixar um arquivo de 104mb... ele aceitou baixar... deixei ir até 2mb e cancelei

    Como faço para limitar em 500kb?
    amigo esse tipo de controle tambem estou a procura



  7. #7

    Padrão

    Para controlar o download de apenas um ip, use o mangle com marcação específica no ip (src-address) e depois faça o controle no queue tree.

  8. #8

    Talking

    Citação Postado originalmente por Raniel Ver Post
    Para controlar o download de apenas um ip, use o mangle com marcação específica no ip (src-address) e depois faça o controle no queue tree.
    teria como vc ensinar passo-a-passo?

    Pois sou iniciante em MK.


    Att.
    Webier



  9. #9

    Padrão

    Olá amigo,
    O que tem que fazer basicamente é isto:
    1º crie uma ou várias address list
    Código :
    /ip firewall address-list add list=G-254k comment="grupo de 254k" disabled=yes
    2º Crie duas regras de mangle para o grupo G-254k
    Código :
    /ip firewall mangle add chain=output action=mark-connection new-connection-mark=g-2545-conn passthrough=yes src-port=3128 protocol=tcp content="X-Cache: HIT" src-address-list=G-254k comment="marcar conexao para o G-254k"
    Código :
    /ip firewall mangle add chain=output action=mark-packet new-packet-mark=g-254k-packet passthrough=no connection-mark=g-2545-conn comment="marcar pacotes para G-254k"
    3º Criar uma regra de queue tree para controlar a velocidade do grupo
    Código :
    /queue tree add name="G-254k" parent=global-out packet-mark=g-254k-packet limit-at=128000 queue=default priority=8 max-limit=254000 burst-limit=0 burst-threshold=0 burst-time=0s

    Agora você pode colocar apenas um ip ou vários para este grupo:
    Código :
    /ip firewall address-list add address=192.168.1.5 list=G-254k disabled=no comment="controlar fulano"

    Aqui é uma forma de fazer o tipo de controle desejado.

  10. #10

    Padrão

    Citação Postado originalmente por webier Ver Post
    Tenho uma lan house...

    Uso servidor MK com DHCP, Cache e Divisão de Banda.

    Como faço para o IP 192.168.0.10 nao aceitar fazer downloads ou somente poder fazer downloads de até 1 mb.

    mas a navegação fica normal, quero restrigir somente Downloads

    Amigo, "no stress"

    Coisa simples desta, com dicas tào complicas.... Dá vontade de chorar...

    Limitando o tamanho de download (dropando ou aceitando) - CATVBRASIL