Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Acessar Mikrotiks dentro da rede via internet!!!

    Ola a todos, tenho um servidor mikrotik controlando tudo, e um pc-ap com mikrotik também so como bridge.

    A minha dúvida é, como fazer para acessar esse pc-ap via internet (eu acesso meu servidor remotamente).

    Pensei em fazer um nat para uma porta especifica, mas como fazer isso??

    por exemplo:

    PTP
    |SERVIDOR| <----------> |PC AP|
    > ACESSO O SERVIDOR COM UM CHANGE IP.;.. COMO REDIRECIONAR PARA ACESSAR MEU PC AP?

    grato desde já,


    Tiago Melo Oliveira

  2. #2
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão eu tbm

    eu tbm queria sabe como fazer isso... eu tava pensando em fazer uma rota estatica sei la algo do tipo...



  3. #3

    Padrão

    Olá amigo tmelooliveira, isso ai é simples.... ative o servidor PPTP do seu mikrotik principal, cadastre um login e uma senha pra vc e o um profile pro servidor pptp, dai você conecta por essa conexão pptp (que pode usar vpn ou não, fica ao seu criterio) e vc vai estar dentro da sua rede como se estivesse na rede local (e na verdade vc está na rede local, ), dai é só digitar no winbox o ip da rede local do seu pc-ap e acessar ele diretamente.... simples não .... espero ter ajudado, até mais.

  4. #4

    Padrão

    Obrigado amigo, so me esclareça uma coisa, como vou fazer para conectar esse server pptp via internet??

    grato...

    Exemplo: estou de ferias e quero acessar todas as bridges por traz do meu pc-ap..




    Grato desde já.. Tiago



  5. #5

    Padrão

    Citação Postado originalmente por tmelooliveira Ver Post
    Obrigado amigo, so me esclareça uma coisa, como vou fazer para conectar esse server pptp via internet??

    grato...

    Exemplo: estou de ferias e quero acessar todas as bridges por traz do meu pc-ap..




    Grato desde já.. Tiago
    Mais simples ainda... estou supondo que você usa o windows xp...
    entra nas conexões de rede, clica em criar uma nova conexão, depois em conectar-me a uma rede no meu local de trabalho, depois conexão VPN, nome da conexão, endereço do ser server mikrotik principal (o ip valido) e pronto.... é só colocar a senha e o user que vc cadastrou no MK pra essa conexão.... até.

  6. #6

    Padrão Para quem procura uma solução completa!!

    Ola amigos, com a ajuda do The Hawk e do Google, consegui fazer o que queria..

    Segue abaixo os codigos para colocar no Mikrotik!!

    Depois faça o passo que o The Hawk colocou ai em cima ^.

    / interface ethernet
    set ether1 name="ether1"

    / interface bridge
    add name="lan" arp=proxy-arp

    / interface bridge port
    add interface=ether1 bridge=lan

    / ip address
    add address=192.168.0.1/24 interface=lan

    / ip dns
    allow-remote-requests=yes

    / ip firewall service-port
    set gre disabled=no
    set pptp disabled=no

    / ip pool
    add name="pptp" ranges=192.168.0.200-192.168.0.229

    / ppp profile
    add name="pptp-in" local-address=192.168.0.1 remote-address=pptp use-encryption=required only-one=yes change-tcp-mss=yes dns-server=192.168.0.1

    / interface pptp-server server
    set enabled=yes max-mtu=1460 max-mru=1460 authentication=chap,mschap1,mschap2 default-profile=pptp-in

    / ppp secret
    add name="user-1" service=pptp password="******" profile=pptp-in
    add name="user-2" service=pptp password="******" profile=pptp-in
    # ...

    Depois é so configurar a conexão como o the hawk falou no XP!!

    Fonte - Wiki Mikrotik


    Grato!!

    Tiago



  7. #7

    Padrão

    Olá tmelooliveira, era exatamente isso ai que eu estava falando, só não tinha passado as configurações.... só não entendi pra que essa bridge ai no meio? e nem pra que esse proxy-arp... não precisa de nenhum dos 2, basta criar o servidor pptp, senha, usuario e pool de ips... e pronto.... espero ter ajudado, até mais.

  8. #8



  9. #9

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Olá tmelooliveira, era exatamente isso ai que eu estava falando, só não tinha passado as configurações.... só não entendi pra que essa bridge ai no meio? e nem pra que esse proxy-arp... não precisa de nenhum dos 2, basta criar o servidor pptp, senha, usuario e pool de ips... e pronto.... espero ter ajudado, até mais.
    ola amigo, e fiz no meu serve como o colega tmelooliveira fez, mas quando por algum motivo o mikrotik e reniciado por falta de energia ou queda do meu velox, o mikrotik nao consegue fazer a discagem, tem como voce fazer um passo a passo igual o dele so que da forma que nao venha ocorrer esse erro?

  10. #10

    Padrão

    eu fiz o teste e consegui fazer a conexao vpn, mas o que fazer quando o ip mudar? ja que eu uso ip publico, esta seria a melhor forma de eu acompanhar o meu serve via internet? ou tem uma mais simples e melhor? aguardo a resposta anterior e a esta.



  11. #11

    Padrão

    Citação Postado originalmente por kfdigital Ver Post
    ola amigo, e fiz no meu serve como o colega tmelooliveira fez, mas quando por algum motivo o mikrotik e reniciado por falta de energia ou queda do meu velox, o mikrotik nao consegue fazer a discagem, tem como voce fazer um passo a passo igual o dele so que da forma que nao venha ocorrer esse erro?
    Olá amigo, como é configurado o seu modem? Router ou Bridge? Aguardo retorno.

  12. #12

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Olá amigo, como é configurado o seu modem? Router ou Bridge? Aguardo retorno.
    ele esta configurado em brige.



  13. #13

    Padrão

    Primeiro adicione um pool pra ser servidor PPTP(VPN)

    Código :
    ip pool add name=pool-pptp ranges=172.18.254.2-172.16.254.10


    Depois crie um profile para ele

    Código :
    ppp profile add name=Servidor-PPTP local-address=172.16.254.1 only-one=yes remote-address=pool-pptp use-encryption=yes dns-server=172.16.254.1

    Depois habilita o servidor PPTP

    Código :
    interface pptp-server server set enabled=yes default-profile=Servidor-PPTP

    e por ultimo colocar um usuario e uma senha (vai ser usado pra conectar por pptp)

    Código :
    ppp secret add name=seunome password=suasenha profile=Servidor-PPTP service=pptp

    Se você quiser pegar internet tambem tem que fazer um masquedade pra faixa do pptp, dessa forma:

    Código :
    ip firewall nat add src-address=172.16.254.0/24 chain=dstnat action=masquerade

    Quanto a questão da desconexão do pppoe, o servidor pptp funciona normal em conjunto com o pppoe-client, na sua interface pppoe-client escolha a interface correta
    que está conectada ao seu modem e marque as opções "add default route" e "use peer dns".... como seu ip é dinamico vc tem fazer tambem a configuração do DDNS,
    como descrito abaixo:

    primeiro faça um cadastro nesse site: Free Dynamic DNS / Free Domain Names

    depois adicione o script abaixo no seu mikrotik:

    Código :
    :log info "DDNS: Begin"
     
    :global ddns-user "USUARIO"
    :global ddns-pass "SENHA"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"
     
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
     
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
     
    :if ([ :typeof $ddns-ip ] = nil ) do={
     
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
     
    } else={
     
    :if ($ddns-ip != $ddns-lastip) do={
     
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
     
    } else={
     
    :log info "DDNS: No change"
     
    }
     
    }
     
    :log info "DDNS: End"

    Agora só falta criar o agendamento:

    Código :
    add name="ChangeDns" on-event=DDNS start-date=jan/01/1970 \
    start-time=00:00:00 interval=1h comment="DNS DIMAMICO \
    " disabled=no

    Dai vc fica acessando o MK pelo nome do dns que vc criou e o pptp server vai rodar tranquilo, até, espero ter ajudado.

  14. #14

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Primeiro adicione um pool pra ser servidor PPTP(VPN)

    Código :
    ip pool add name=pool-pptp ranges=172.18.254.2-172.16.254.10


    Depois crie um profile para ele

    Código :
    ppp profile add name=Servidor-PPTP local-address=172.16.254.1 only-one=yes remote-address=pool-pptp use-encryption=yes dns-server=172.16.254.1

    Depois habilita o servidor PPTP

    Código :
    interface pptp-server server set enabled=yes default-profile=Servidor-PPTP

    e por ultimo colocar um usuario e uma senha (vai ser usado pra conectar por pptp)

    Código :
    ppp secret add name=seunome password=suasenha profile=Servidor-PPTP service=pptp

    Se você quiser pegar internet tambem tem que fazer um masquedade pra faixa do pptp, dessa forma:

    Código :
    ip firewall nat add src-address=172.16.254.0/24 chain=dstnat action=masquerade

    Quanto a questão da desconexão do pppoe, o servidor pptp funciona normal em conjunto com o pppoe-client, na sua interface pppoe-client escolha a interface correta
    que está conectada ao seu modem e marque as opções "add default route" e "use peer dns".... como seu ip é dinamico vc tem fazer tambem a configuração do DDNS,
    como descrito abaixo:

    primeiro faça um cadastro nesse site: Free Dynamic DNS / Free Domain Names

    depois adicione o script abaixo no seu mikrotik:

    Código :
    :log info "DDNS: Begin"
     
    :global ddns-user "USUARIO"
    :global ddns-pass "SENHA"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"
     
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
     
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
     
    :if ([ :typeof $ddns-ip ] = nil ) do={
     
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
     
    } else={
     
    :if ($ddns-ip != $ddns-lastip) do={
     
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
     
    } else={
     
    :log info "DDNS: No change"
     
    }
     
    }
     
    :log info "DDNS: End"

    Agora só falta criar o agendamento:

    Código :
    add name="ChangeDns" on-event=DDNS start-date=jan/01/1970 \
    start-time=00:00:00 interval=1h comment="DNS DIMAMICO \
    " disabled=no

    Dai vc fica acessando o MK pelo nome do dns que vc criou e o pptp server vai rodar tranquilo, até, espero ter ajudado.
    valew twank, vou tenta fazer dessa forma, acredito que dessa vez vai dar certo, pois nao tinha colocado ddns e tava diferente, depois post aqui o resultado. ate.



  15. #15

    Padrão

    Como o amigo The Hawk disse, quem naum tem ip fixo, tem que acessar por um site que faz o direcionamento de dns...

    Dynamic DNS >> www.changeip.org > How-To
    No-IP - Dynamic DNS, Static DNS for Your Dynamic IP

    faz as config que eu the hawk posto que não tem erro!!!

    Abraço a todos!!

  16. #16

    Padrão

    fiz a conta no din ddns tudo certo mas na hora de roda o script, ele nao conta o escrip quando mando ele roda? pode ta faltando mais agulma coisa que tem que colocar no ddns? por favor me ajudem!



  17. #17

    Padrão

    ai galera consegui!!! faltou um pouco de atençao nos minimos detalhes do script mais deu tudo certo, obrigado pela atençao de todos.

  18. #18

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Olá tmelooliveira, era exatamente isso ai que eu estava falando, só não tinha passado as configurações.... só não entendi pra que essa bridge ai no meio? e nem pra que esse proxy-arp... não precisa de nenhum dos 2, basta criar o servidor pptp, senha, usuario e pool de ips... e pronto.... espero ter ajudado, até mais.
    Olá mano, valeu pelo post, aproveitei e fiz aqui na minha rede, consegui fazer a conexão VPN, já tinha cadastro no dyndns, ja acessava normalmente minha base remotamente (192.168.1.1), então pensei em fazer o VPN pq tenho um PC-AP (192.168.1.2) por traz desse servidor e um repetidor em bridge+WDS (192.168.1.3), eu estando fora da minha rede na internet com qualquer pc eu crio a conexão VPN e disco, conecto normalmente, abro o winbox e digito o ip do servidor (192.168.1.1) e acesso meu servidor normalmente, mas os outros dois MKs por tras ñ consigo, teria q fazer alguma coisa a mais para funcionar além dessas configurações q passou? Valeu!



  19. #19

    Padrão

    Citação Postado originalmente por faieppi Ver Post
    Olá mano, valeu pelo post, aproveitei e fiz aqui na minha rede, consegui fazer a conexão VPN, já tinha cadastro no dyndns, ja acessava normalmente minha base remotamente (192.168.1.1), então pensei em fazer o VPN pq tenho um PC-AP (192.168.1.2) por traz desse servidor e um repetidor em bridge+WDS (192.168.1.3), eu estando fora da minha rede na internet com qualquer pc eu crio a conexão VPN e disco, conecto normalmente, abro o winbox e digito o ip do servidor (192.168.1.1) e acesso meu servidor normalmente, mas os outros dois MKs por tras ñ consigo, teria q fazer alguma coisa a mais para funcionar além dessas configurações q passou? Valeu!
    Olá.... os gateways dos 2 equipamentos estão configurados corretamente? Pra acessa-los usando VPN toda a configuração de rede tem que estar ok... você fez o NAT para a faixa de ips da VPN? Até.

  20. #20

    Padrão

    Caro tmelooliveira,

    Essas configurações vc fez no servidor ou no AP ?

    Estou com o mesmo problema que vc. Tenho acesso via VPN, pingo todas as estações, mas o IP da minha RB eu não consigo pingar. Será que é o modo do ARP da interface, o meu está como ARP=Enable.