Resolvido, testei hoje e ta rodando 100%

/ ip firewall nat add chain=srcnat connection-mark=conn1 action=masquerade out-interface=ether2 comment="" disabled=no