Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Salve galera do under...

    Estou com um problema sério..

    Tenho dois links ligados em um mk server.
    Um desses utilizo somente para empresas e o outro para clientes residencias.
    O problema é que em período noturno, por um motivo desconhecido o link residencial perde a qualidade enquanto o link das empresas permanece perfeito.
    O que eu gostaria de fazer é o seguinte. As empresas só trabalham até as 18 horas a cada dia.
    Coloquei dois gateways em route e adicionei dois ips (em de cada link) em address. Só deixo um dos ips habilitados, o outro desabilito. Quando quero trocar de link desabilito um habilito o outro, assim assumindo o segundo link.
    O que pensei: Fazer um scripst para que todo dia as 18:00 horas desabilite o link1 e habilite o link2. Só isso..
    Ai fiz as regras.. digitando elas no terminal, funciona normal. Porém quando adiciono elas em system script elas não são executadas..

    Alguém sabe o porque? Ou tem a solução?

    Agradeço já quem ajudar a solucionar esse problema..

  2. Citação Postado originalmente por Nazzi Ver Post
    Salve galera do under...

    Estou com um problema sério..

    Tenho dois links ligados em um mk server.
    Um desses utilizo somente para empresas e o outro para clientes residencias.
    O problema é que em período noturno, por um motivo desconhecido o link residencial perde a qualidade enquanto o link das empresas permanece perfeito.
    O que eu gostaria de fazer é o seguinte. As empresas só trabalham até as 18 horas a cada dia.
    Coloquei dois gateways em route e adicionei dois ips (em de cada link) em address. Só deixo um dos ips habilitados, o outro desabilito. Quando quero trocar de link desabilito um habilito o outro, assim assumindo o segundo link.
    O que pensei: Fazer um scripst para que todo dia as 18:00 horas desabilite o link1 e habilite o link2. Só isso..
    Ai fiz as regras.. digitando elas no terminal, funciona normal. Porém quando adiciono elas em system script elas não são executadas..

    Alguém sabe o porque? Ou tem a solução?

    Agradeço já quem ajudar a solucionar esse problema..
    verefique os logs!
    passe o script aqui pra nos!



  3. Amigo,

    Poste o Script que vc criou aqui no fórum, assim poderemos ajudá-lo.

  4. / system script
    add name="Habilita_Link1_A" source="/ip address disable 93" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="Habilita_Link1_B" source="/ip address enable 98" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="Desabilita_Link2_A" source="/ip address disable 98" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="Desabilita_Link2_B" source="/ip address enable 93" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    Onde:
    93 é o número da regra de ip do linkB
    98 é o número da regra de ip do linkA



  5. Nazzi, cada ip seu, ou seja, cada link tem um gateway diferente? Certo?

    Se tiver vc faz assim que é bem mais funcional:


    Crie um Schedule chamado: Link_liga
    /ip route set [/ip route find gateway=gateway do link que será ligado/desligado] disabled=no
    Coloque para executar 6hs da manha

    Crie um Schedule chamado: Link_desl
    /ip route set [/ip route find gateway=gateway do link que será ligado/desligado] disabled=yes
    Coloque para executar 18hs da tarde

    O que acontecerá: As 18hs o link problemático irá ser desligado, e como com certeza vc tem uma Rota de saída de todos "0.0.0.0/0" saindo para o gateway do segundo link "comercial", todos os seus clientes usarão o link comercial durante a noite.

    As 6hs da manhã o link residencial, ou seja, sua Rota, será reativada voltando tudo ao normal durante o dia.

    Ok?

    Espero ter ajudado.

    Abraço.






Tópicos Similares

  1. Problemas com script no Crontab
    Por gilmarcabral no fórum Servidores de Rede
    Respostas: 3
    Último Post: 09-05-2006, 13:25
  2. Problemas com script de logon
    Por grmuniz no fórum Servidores de Rede
    Respostas: 5
    Último Post: 29-08-2005, 08:03
  3. Problema com script (IP x MAC + Controle de banda)
    Por sarna no fórum Servidores de Rede
    Respostas: 10
    Último Post: 06-05-2005, 18:34
  4. Problemas com script
    Por no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 09-07-2004, 16:31
  5. Problema com Script
    Por Gabriel_Junior no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 12-01-2003, 23:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L