+ Responder ao Tópico



  1. Muito bom dia aos presentes,

    Tenho uma estrutura não comercial, porem super organizada e me deparei com o seguinte problema.
    Dos meu 4 amigos dois fazem uso de um circuito fechado de câmeras, e ambos usam domínio dinâmico, cada um tem o soft DDNS instalado em seu computador, a reclamação é que quando eles abrem o domínio é exibido o site padrão do MK.
    Tentei vários comandos no Fireware para associar cada porta a seu distinto ip interno e não tive nenhum sucesso.

    Minha estrutura é simples, > Modem ADSL Bride > Mikrotik > DHCP > Maquinas listadas a baixo.

    192.196.254.1 - eu
    192.196.254.2 - amigo
    192.196.254.3 - amigo
    192.196.254.4 – Câmera Porta :90
    192.196.254.5 – Câmera Porta :1999

    Gostaria de abrir no browser www.loja1.ddns.com.br:90 e desse acesso às câmeras 192.168.254.4 e www.loja2.no-ip.com.br:1999 e desse acesso às câmeras 192.168.254.5

    Senhores, aceito qualquer sugestão ou ate mesmo alterações, eu preciso mesmo é acerta isso para os colegas aqui.

    A todos, os meus agradecimentos

  2. Citação Postado originalmente por eScRaVo Ver Post
    Muito bom dia aos presentes,

    Tenho uma estrutura não comercial, porem super organizada e me deparei com o seguinte problema.
    Dos meu 4 amigos dois fazem uso de um circuito fechado de câmeras, e ambos usam domínio dinâmico, cada um tem o soft DDNS instalado em seu computador, a reclamação é que quando eles abrem o domínio é exibido o site padrão do MK.
    Tentei vários comandos no Fireware para associar cada porta a seu distinto ip interno e não tive nenhum sucesso.

    Minha estrutura é simples, > Modem ADSL Bride > Mikrotik > DHCP > Maquinas listadas a baixo.

    192.196.254.1 - eu
    192.196.254.2 - amigo
    192.196.254.3 - amigo
    192.196.254.4 – Câmera Porta :90
    192.196.254.5 – Câmera Porta :1999

    Gostaria de abrir no browser www.loja1.ddns.com.br:90 e desse acesso às câmeras 192.168.254.4 e www.loja2.no-ip.com.br:1999 e desse acesso às câmeras 192.168.254.5

    Senhores, aceito qualquer sugestão ou ate mesmo alterações, eu preciso mesmo é acerta isso para os colegas aqui.

    A todos, os meus agradecimentos

    Olá amigo,

    Vamos começar o trabalho!

    Vá em changeip.com > crie uma conta com seu nome de usuario e senha e depois crie um dominio, tipo: cameras.dns-dns.com

    Agora abra seu winbox e vá em

    System > Script >

    add name= changeip

    Policy=reboot, write, test, read, policy, password

    Source=
    :global ddnsuser "seu usuario em changeip"
    :global ddnspass "sua senha em changeip"
    :global ddnshost "seu dominio criado, se for minha sujestao ficará: cameras.dns-dns.com"
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] = nothing ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("CHANGEIP: NENHUM IP PRESENTE PARA SER ENVIADO NA INTERFACE" . $ddnsinterface . ", VERIFIQUE POR FAVOR!")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "CHANGEIP: IP ATUALIZADO COM SUCESSO!"
    :log info [ : put [/tool dns-update name=$ddnshost address=[: pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    }
    }


    Agora vá em

    System > Scheduler >

    add name=executa changeip
    Start date=Jan/15/2009
    Start time=23:00:00
    Interval=00:01:00
    On Event= /system script run changeip

    Ok, já está criado o seu domínio! Sempre que seu IP for alterado ele irá ser autenticado para ser acessado sempre através do domínio criado no changeip. Suponhamos que este domínio seja o que eu te sujerí, cameras.dns-dns.com . Vamos ao proximo passo:

    Se vc acessar cameras.dns-dns.com abrirá a pagina do Mikrotik.

    Antes de Seguir os próximos passos, retire o SERVER de DHCP e coloque ips fixos nos seus amigos:

    AMIGO DA PORTA 90 : 192.168.254.4
    AMIGO DA PORTA 1999: 192.168.254.5

    Então agora iremos criar os redirecionamentos para as cameras de seus amigos:

    Vá em

    IP > FIREWALL > NAT >

    add chain=dstnat Protocol=tcp Dst-port=2034 Action=Dst-nat To-address=192.196.254.4 To-ports=90 Coment="Acessar cameras do amigo 01 na porta 90"

    add chain=dstnat Protocol=tcp Dst-port=2035 Action=Dst-nat To-address=192.196.254.5
    To-ports=1999 Coment="Acessar cameras do amigo 02 na porta 1999"

    Pronto, já estão criados os redirecionamentos!

    Agora é fazer os testes, para acessar as cameras do amigo do ip 192.168.254.4 digite no navegador ou no sistema de acesso às cameras o "ip fixo" (rsrsrs) domínio fixo do amigo que será:
    http:// cameras.dns-dns.com:2034

    e para acessar as cameras do amigo do ip 192.168.254.5 digite no navegador ou no sistema de acesso às cameras o domínio fixo do amigo que será:
    http:// cameras.dns-dns.com:2035

    No mais, grande abraço!!!!

    Não esqueça de fechar o seu Tópico e de apertar o botãozinho "Agradecer" !!!!!! rsrsrsrsrs
    Última edição por marioth; 15-01-2009 às 23:00.



  3. marioth vc é nota 10, valeu, seu comentário não foi uma dica e sim uma aula.....
    Obrigado mesmo.... um cordial abraço.

    Espero que esse material ajude mais pessoas assim como me ajudou...

  4. Obrigado amigo!

    Ajude então a divulgar este material...

    Abraço!



  5. Rapaz gostei muito desse material tbem... bem completo com todos os detalhes... continue assim






Tópicos Similares

  1. Circuito de Câmeras! Acesso pela internet!
    Por lokdiogo no fórum Redes
    Respostas: 12
    Último Post: 13-10-2011, 23:24
  2. Respostas: 8
    Último Post: 18-09-2010, 21:01
  3. Dica - Script para DNS Dinamico (DynDNS)
    Por gsiena no fórum Redes
    Respostas: 0
    Último Post: 14-09-2009, 19:34
  4. scripte html para circuito de cameras
    Por LeoJfa no fórum Servidores de Rede
    Respostas: 3
    Último Post: 15-07-2005, 23:22
  5. Solução para DNS Dinamico
    Por marcfee no fórum Servidores de Rede
    Respostas: 10
    Último Post: 23-10-2004, 09:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L