+ Responder ao Tópico



  1. #1

    Padrão Falha no mikrotik

    Pessoal, bom dia,

    Consegui montar o meu serv mikrotik+hotspot porém a pouco percebi uma falha, que creio eu que o pessoal que mexe com mikrotik a mais tempo que eu já deva ter percebido a mais tempo tambem porém procurei aqui no forum e em outros foruns da net, uma solução e não achei, e peço ajuda a todos para solucionar o problema que eu vou descrever,

    bem usou:

    Mikrotik 2.9
    Hotspot
    DHC Serv
    Controel por ip e MAC tambem

    pois bem, fiz o segiunte teste, loguei um cliente na rede, peguei o mac dele e clonei em outro pc, o outro navegou normal, sem exigir autenticação nem nada, navegou normal, e o DHCP deu o mesmo ip aos dois computadores, como se fossem um só,

    taiai meu problema, e acredito que não só meu,, iai pessoal alguem me recomenda alguma coisa??

    desde já agradeço

  2. #2

    Padrão

    Se estiver fazendo o uso do Server Hotspot, tera uma opção chamada Addresses Peer Mac, seleciana e seta "1", e faz o teste novamente.



  3. #3

    Padrão

    Você pode fazer verificação pelo nome do host, no servidor dhcp também. Tem um post aqui no forum, do qual não me lembro o nome, que relata este script para controle de host.


  4. #4

    Padrão

    mas isso eh uma falha do hotspot.. na verdade do TCP/IP .. eh uma falha.. que nao eh do mikrotik !!

    :P

    ja com pppoe voce evita isso, pppoe controle a sessão com tuneis.. ou seja.. cara pode clonar o mac.. saber ususario e senha.. vai conectar somente se nao tiver ninguem online.. ai da pra vc corrigir as coisas... (trocar senha do usuario.. etc etc)

    ja esse problema ai, uma pessoal com um scanner de rede consegue pegar os macs da rede.. ai .. nao tem o que fazer.. se mudar o mac.. ele consegue outro.. cliente autenticou.. o cara navega junto :P



  5. #5

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    mas isso eh uma falha do hotspot.. na verdade do TCP/IP .. eh uma falha.. que nao eh do mikrotik !!

    :P

    ja com pppoe voce evita isso, pppoe controle a sessão com tuneis.. ou seja.. cara pode clonar o mac.. saber ususario e senha.. vai conectar somente se nao tiver ninguem online.. ai da pra vc corrigir as coisas... (trocar senha do usuario.. etc etc)

    ja esse problema ai, uma pessoal com um scanner de rede consegue pegar os macs da rede.. ai .. nao tem o que fazer.. se mudar o mac.. ele consegue outro.. cliente autenticou.. o cara navega junto :P
    Na verdade mesmo gostaria de uma solução para continuar utilizando hotspot, até tentei as dicas do Raniel e leomj porém sem exito

    se alguem tiver outra dica agradeço porfavor!

  6. #6

    Padrão

    Já fez um script para verificar o nome do host(nome do computador)? Com isto o servidor dhcp não enviará o ip para um host diferente ou removerá o host diferente.



  7. #7

    Padrão

    nao tem mta (ou nenhuma) solução nao.. :P

  8. #8

    Padrão

    Raniel,

    eu achei esse script, é esse? coloquei esse mais num deu certo não!

    # use global hacklist variable
    #:log info ($hacklist)
    :foreach host in $hacklist do={
    :foreach i in= [/ip dhcp-server lease find host-name $host] do={
    :local ipnum [/ip dhcp-server lease get $i address]
    :local unum [/ip hotspot active find address $ipnum]
    :if ([:len $unum] >0) do {
    :local usr [/ip hotspot active get $unum user]
    :log warning ($host . " " . $ipnum . " " . $usr)
    #next line kick them out right now, could also check pppoe
    /ip hotspot active remove $unum
    #other stuff can do now with the identified IP and USER
    }
    }
    }



  9. #9

  10. #10

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    É este aqui

    Raniel foi esse mesmo que eu abri, porém num entendo ingles, até tentei utilizar um servidor, pra ver se era necessario adptar ao meu server ou só copiar, então só copiei e colei la mesmo, porém não adiantou!

    se você puder me da uma ajuda eu te agradeço...



  11. #11

    Padrão

    Vamos lá meu caro,
    Deve-se atentar para usar a versão < 3. Caso queira usar ver. > 3 terás que alterar a maneira das variáveis.

    A primeira coisa que o nosso amigo menciona é executar um script(A) a cada minuto:
    Citação Postado originalmente por SCRIPT A
    :local hosts [/ip dhcp-server lease find]
    :local pcname "X"
    :local pcnum 0
    :global hacklist ""
    :foreach h in $hosts do={
    :local host [/ip dhcp-server lease get $h host-name]
    :if ([:len $host] >0) do {
    :set pcname ($pcname . "," . $host)
    :set pcnum ($pcnum + 1)
    }
    }
    :foreach h in $pcname do={
    :local hh 0
    :if (!([:find $hacklist $h]>=0)) do={
    :foreach k in $pcname do={ :if ($k=$h) do={:set hh ($hh + 1) } }
    :if ($hh>2) do={
    :if ([:len $hacklist] >0) do {:set hacklist ($hacklist . "," . $h)} else={:set hacklist $h}
    }
    }
    }
    # monitor results in logfile once an hour
    :local timer [ick [/system clock get time] 3 5]
    :if (($switch > 0) || ($timer >= "58")) do={
    :log warning ("New Hacklist: " . $hacklist)
    }
    Aqui ele criou uma variável global (hacklist) e outras locais pegar o hostname (nome do pc na rede) que fará uma verificação. A verificação diz que se existir mais de 2 computador ($hh>2) com o mesmo nome, que o mikrotik irá setar a variável hacklist gerando um log.


    Citação Postado originalmente por SCRIPT B
    :foreach host in $hacklist do={
    :foreach i in= [/ip dhcp-server lease find host-name $host] do={
    :local ipnum [/ip dhcp-server lease get $i address]
    :local unum [/ip hotspot active find address $ipnum]
    :if ([:len $unum] >0) do {
    :local usr [/ip hotspot active get $unum user]
    :log warning ($host . " " . $ipnum . " " . $usr)
    #next line kick them out right now, could also check pppoe
    /ip hotspot active remove $unum
    #other stuff can do now with the identified IP and USER
    }
    }
    }
    Este script será executado a cada 20 segundos(pode ser o tempo que quiser). Ele irá remover a entradas da hacklist que estiverem ativas no hotspot.


    Se você não tiver muitos clientes e um pouco de paciência, pode criar uma variável local com o nome dos pcs na sua rede e fazer uma verificação. Caso os hostnames do dhcp-server seje diferente das variáveis locais, ele irá remover.

  12. #12

    Padrão

    nada amigo, coloquei os dois scripts e nada!

    se tiver alguma outra solução porfavor me diz ai...


    obrigado