Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Question Mk 3.19 + squid2.7STABLE nao esta marcando pacote ZPH

    Meu servidor não esta entregando a full, no squid o ZPH esta setado como abaixo

    Código :
    zph_mode tos
    zph_local 0x02
    zph_sibling 0x02
    zph_parent 0
    zph_opition 136
    no mangle ele nao esta marcando pacote quando eu informo o DSCP (TOS)= 16, ele deixa de demarcar os pacotes e com isso ele nao entrega a full

    segue a baixo a regra mangle

    Código :
    /ip firewall mangle
    add action=mark-connection chain=postrouting comment="" disabled=no [B]dscp=16[/B] \
        new-connection-mark=n-cache passthrough=yes protocol=tcp src-port=6851
    add action=mark-connection chain=postrouting comment="" disabled=no dscp=!16 \
        new-connection-mark=s-cache passthrough=yes protocol=tcp src-port=6851
    add action=mark-packet chain=postrouting comment="Libera cache full" \
        connection-mark=n-cache disabled=no new-packet-mark=Cache-Packet \
        passthrough=no
    regra do queuetree
    Código :
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4000000 name=CACHE-FULL \
        packet-mark=Cache-Packet parent=global-out priority=8 queue=cache
    se alguem poder me ajudar agradeço, pois nao sei mais o que fazer....

  2. #2

    Padrão

    Marque o dscp=12 meu caro.



  3. #3

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Marque o dscp=12 meu caro.


    bom agora no momento estou reinstalando o meu Debian, quando terminar, vou testar
    ai passo o resultado.

    mas poderia me dizer da onde vem o resultado =12, pois não estou entendendo essa parte da regra.

    desde já obrigado

  4. #4

    Padrão

    Isto é resultado das versões do kernel do mikrotik, pois as marcações de pacotes no squid tem o mesmo valor.


    Código :
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off



  5. #5

    Talking

    Citação Postado originalmente por Raniel Ver Post
    Isto é resultado das versões do kernel do mikrotik, pois as marcações de pacotes no squid tem o mesmo valor.


    Código :
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off


    Raniel>> Primeiro deixe me dizer o que andei fazendo nessa noitada, reinstalei o debian e peguei o squid 2.6 +ZPH para testar e tambem usei o mikrotik 2.9, bom depois de meche aqui e meche ali, nao é que funcionou( Claro que o valor nao era 12, e sim 48), bom ai pensei esta a hora de voltar para o lula 2.7 e o MK 3.19 coloquei o valor que voce tinha me dito e funcionou que é uma belezura.. bom ainda nao entendi como se chega ao numero.. mas ta valendo ja....

    muitissimo obrigado...

  6. #6

    Padrão

    Dá uma olhada no squid.conf na sessão do zph que deve ter algo.
    E sobre o calculo do dscp:



  7. #7

    Padrão

    Amigo por favor se der me ajude, estou tentando aprender a instalar o squid 2.7 no debian como vc fez pos quero fazer o cache full da forma q vc fez com ZPH mas nao sei nem instalar o squid 2.7 vc por favor poderia me dar uma luz de como instala-lo, qual comando? vlw irmao qualquer ajuda é bem vinda. t+

  8. #8

    Padrão

    Também estou querendo implementar estou testando a versao 2.6 do squid mas nao estou tendo um resultado eficiente.
    se puder ajudar agradeço
    []'s



  9. #9

    Padrão

    olá gostaria de saber se uso esse mesmo procedimento pra meu caso, pois uso o linux como gateway,proxy,dhcp server e autenticação! Uso o mikrotik só pra controlar a banda mesmo!

    desde já valews

  10. #10

    Padrão

    Olá amigo,
    Para fazer isto, você deve fazer marcações do DSCP(TOS) e usar a queue para liberar a velocidade, aqui tem uma parte onde marca o tos:
    Linux: MikroTik + Squid 2.6 com cache full [Artigo]



  11. #11

    Padrão

    Citação Postado originalmente por Rafael1929 Ver Post
    Amigo por favor se der me ajude, estou tentando aprender a instalar o squid 2.7 no debian como vc fez pos quero fazer o cache full da forma q vc fez com ZPH mas nao sei nem instalar o squid 2.7 vc por favor poderia me dar uma luz de como instala-lo, qual comando? vlw irmao qualquer ajuda é bem vinda. t+
    sudo apt-get install squid

  12. #12



  13. #13

    Padrão

    Você deve marcar o 12 sem o ! para ter os valores dos hits.

  14. #14

    Padrão

    Estou usando o SQUID 2.7 em parent proxy com o mikrotik 3.10 coloquei as regras para marcação de acordo com as regras que estão na primeira página. Só que meu cache não vai a full.

    eu coloquei valor de TOS=12, no ip>web-proxy no campo "CACHE HIT DSCP (TOS)" eu tenho que colocar o valor 12 também?

    no squid.conf eu não estou entendendo direito como aplicar as regras do ZPH.


    Agradeço antecipadamente a todos que puderem me ajudar.

    Muito obrigado pela atenção.



  15. #15

    Padrão

    Citação Postado originalmente por cordeirog3 Ver Post
    Estou usando o SQUID 2.7 em parent proxy com o mikrotik 3.10 coloquei as regras para marcação de acordo com as regras que estão na primeira página. Só que meu cache não vai a full.

    eu coloquei valor de TOS=12, no ip>web-proxy no campo "CACHE HIT DSCP (TOS)" eu tenho que colocar o valor 12 também?

    no squid.conf eu não estou entendendo direito como aplicar as regras do ZPH.


    Agradeço antecipadamente a todos que puderem me ajudar.

    Muito obrigado pela atenção.

    cara não é em ip/webproxy e ém ip/firewall/mangle vc marca os pacotes no mangle e depois em queue vc controla a banda dos pacotes marcados

  16. #16

    Padrão

    Citação Postado originalmente por cordeirog3 Ver Post
    Estou usando o SQUID 2.7 em parent proxy com o mikrotik 3.10 coloquei as regras para marcação de acordo com as regras que estão na primeira página. Só que meu cache não vai a full.

    eu coloquei valor de TOS=12, no ip>web-proxy no campo "CACHE HIT DSCP (TOS)" eu tenho que colocar o valor 12 também?

    no squid.conf eu não estou entendendo direito como aplicar as regras do ZPH.


    Agradeço antecipadamente a todos que puderem me ajudar.

    Muito obrigado pela atenção.
    Nas configurações do web-proxy, o valor do TOS tem que ser 4. Já no mangle, sim, tem que ser 12.



  17. #17

    Padrão

    Muito obrigado raniel pela sua reposta

    Eu não estou consequindo fazer a marcação dos pacotes, eu estou usando o squid 2.7 que já vem com o ZPH

    squid.conf

    Código :
    zph_mode tos
    zph_local 0x30
    zph_parent 0 
    zph_option 136

    Estou usando o mikrotik versão 3.10, e usando o debian como parent proxy (será que por usar parent proxy eu tenho que mudar alguma coisa?)

    IP FIREWALL NAT
    Código :
     ;;; Redirecionamento Para o Proxy
    chain=dstnat action=dst-nat to-addresses=192.168.0.1 to-ports=3128 src-address=192.168.0.0/24 dst-port=80 protocol=tcp

    IP FIREWALL MANGLE

    Código :
     ;;; MARCA COM E SEM TOS
     chain=postrouting action=mark-connection new-connection-mark=n-cache passthrough=yes src-port=3128 protocol=tcp dscp=12 
     
    chain=postrouting action=mark-connection new-connection-mark=s-cache passthrough=yes src-port=3128 protocol=tcp dscp=!12 
     
    ;;; Libera Cache Full
    chain=postrouting action=mark-packet new-packet-mark=Cache-Packet passthrough=no connection-mark=n-cache

    Bom aparetemente está tudo OK, porém não estou conseguindo achar a fonte do problema.

    Se alguém pude me dar alguma ajuda, fico muito grato.

    e desde de já agradeço a atenção de todos.

    Muito Obrigado

  18. #18

    Smile

    Citação Postado originalmente por cordeirog3 Ver Post
    Muito obrigado raniel pela sua reposta

    Eu não estou consequindo fazer a marcação dos pacotes, eu estou usando o squid 2.7 que já vem com o ZPH

    squid.conf

    Código :
    zph_mode tos
    zph_local 0x30
    zph_parent 0 
    zph_option 136
    Estou usando o mikrotik versão 3.10, e usando o debian como parent proxy (será que por usar parent proxy eu tenho que mudar alguma coisa?)

    IP FIREWALL NAT
    Código :
     ;;; Redirecionamento Para o Proxy
    chain=dstnat action=dst-nat to-addresses=192.168.0.1 to-ports=3128 src-address=192.168.0.0/24 dst-port=80 protocol=tcp
    IP FIREWALL MANGLE

    Código :
     ;;; MARCA COM E SEM TOS
     chain=postrouting action=mark-connection new-connection-mark=n-cache passthrough=yes src-port=3128 protocol=tcp dscp=12 
     
    chain=postrouting action=mark-connection new-connection-mark=s-cache passthrough=yes src-port=3128 protocol=tcp dscp=!12 
     
    ;;; Libera Cache Full
    chain=postrouting action=mark-packet new-packet-mark=Cache-Packet passthrough=no connection-mark=n-cache
    Bom aparetemente está tudo OK, porém não estou conseguindo achar a fonte do problema.

    Se alguém pude me dar alguma ajuda, fico muito grato.

    e desde de já agradeço a atenção de todos.

    Muito Obrigado
    0x0C = 12

    0x04 = 4

    portanto: 0x30 não é 12 nem 4.

    0x30 = 48

    Calculadora Online - Conversão de Hexadecimal

    Abs
    Última edição por darklinux3; 15-06-2009 às 20:53.



  19. #19

    Padrão

    Mas para versão 3 do mikrotik este valor já muda, pois 48:4=12.

  20. #20

    Padrão

    consegui fazer as marcações e liberar o cache-full

    muito obrigado a todos