Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal bom dia! Estou precisando fazer um NAT de modo que cada classe de IPs inválidos saia para Internet com um IP válido diferente. Por Ex.
    172.0.0.0/24 saindo por 200.X.X.10
    192.0.0.0/24 saindo por 200.X.X.11

    Não é saída por mais de um link, e sim no mesmo link por vários ip's.

    Grato!!

  2. .
    Última edição por j34nsch; 28-01-2009 às 08:21.



  3. Citação Postado originalmente por diegochd Ver Post
    Pessoal bom dia! Estou precisando fazer um NAT de modo que cada classe de IPs inválidos saia para Internet com um IP válido diferente. Por Ex.
    172.0.0.0/24 saindo por 200.X.X.10
    192.0.0.0/24 saindo por 200.X.X.11

    Não é saída por mais de um link, e sim no mesmo link por vários ip's.

    Grato!!
    migo dá uma olhada nesse tópico
    cliente hotspot com ip fixo (valido) - Under-Linux.org


    agora vamos lá na regras que eu postei no tópico acima tinha a seguinte regra

    / ip firewall nat
    add chain=dstnat dst-address=210.276.103.10 protocol=tcp dst-port=0-65535 \
    action=dst-nat to-addresses=192.168.0.100 to-ports=0-65535 \
    comment="Direcionando IP" disabled=no

    add chain=srcnat src-address=192.168.0.100 protocol=tcp src-port=0-65535 \
    action=src-nat to-addresses=210.276.103.10 to-ports=0-65535 comment="" \
    disabled=no

    é só vc substituir o ip 210.276.103.10 pelo seu ip valido exemplo 200.x.x.10 e o ip 192.168.0.100 pelo range exemplo 172.0.0.0/24


    espero ter ajudado

  4. opa, Jean, VAleu pela ajuda mais não funcionou, acho que é porque tenho 2 ips da mesma classe na mesmo ether.

    /ip firewall nat
    add action=src-nat chain=srcnat comment="" disabled=no protocol=tcp \
    src-address=172.0.0.0/24 src-port=0-65535 to-addresses=200.xx.xx.16 \
    to-ports=0-65535
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=\
    200.xx.xx.16 dst-port=0-65535 protocol=tcp to-addresses=172.0.0.0/24 \
    to-ports=0-65535

    /ip address
    add address=200.xx.xx.54/26 broadcast=200.xx.xx.63 comment="" disabled=no \
    interface=ether3 network=200.xx.xx.0
    add address=172.0.0.1/24 broadcast=172.0.0.255 comment="" disabled=no \
    interface=wlan1 network=172.0.0.0
    add address=200.xx.xx.16/26 broadcast=200.xx.xx.63 comment="" disabled=no \
    interface=ether3 network=200.xx.xx.0

    Será isso?

    Valeu!
    Última edição por diegochd; 28-01-2009 às 09:58.



  5. Citação Postado originalmente por diegochd Ver Post
    opa, Jean, VAleu pela ajuda mais não funcionou, acho que é porque tenho 2 ips da mesma classe na mesmo ether.

    /ip firewall nat
    add action=src-nat chain=srcnat comment="" disabled=no protocol=tcp \
    src-address=172.0.0.0/24 src-port=0-65535 to-addresses=200.xx.xx.16 \
    to-ports=0-65535
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=\
    200.xx.xx.16 dst-port=0-65535 protocol=tcp to-addresses=172.0.0.0/24 \
    to-ports=0-65535

    /ip address
    add address=200.xx.xx.54/26 broadcast=200.xx.xx.63 comment="" disabled=no \
    interface=ether3 network=200.xx.xx.0
    add address=172.0.0.1/24 broadcast=172.0.0.255 comment="" disabled=no \
    interface=wlan1 network=172.0.0.0
    add address=200.xx.xx.16/26 broadcast=200.xx.xx.63 comment="" disabled=no \
    interface=ether3 network=200.xx.xx.0

    Será isso?

    Valeu!

    Seguinte amigo, eu uso algo semelhante aqui.
    Oque vc deve fazer é criar um unico NAT. voce controla quem sai por qual link marcando as rotas e criando rotas especificas pra cada caso.

    #criando o nat para todos
    /ip firewall nat add chain=dstnat action=masquerade

    #agora vamos marcar as rotas:
    /ip firewall mangle add chain=prerouting src-address=172.0.0.0/8 action=mark-routing
    new-routing-mark=link1 passthrough=no

    /ip firewall mangle add chain=prerouting src-address=192.0.0.0/8 action=mark-routing
    new-routing-mark=link2 passthrough=no

    Feito isso, temos todos as conexoes que chegam pela rede 192 marcados para link2 e todos as conexoes que chegam pela rede 172 para link1.

    agora oque temos que fazer é adicionar uma rota para cada um dos links

    /ip route
    add routing-mark=link1 gateway=ip do gateway do link1

    add routing-mark=link2 gateway=ip do gateway do link2

    pronto.
    agora vc separou as conexoes e cada uma esta saindo por um gateway!

    qualquer duvida liga aki q eu te ajudo !!!...
    (49) 8416 5562






Tópicos Similares

  1. Por qual IP o cliente esta saindo!!!
    Por FMANDU no fórum Redes
    Respostas: 2
    Último Post: 22-12-2015, 15:17
  2. Range de IP saindo por determinada ether
    Por netpower no fórum Redes
    Respostas: 1
    Último Post: 28-06-2013, 22:23
  3. Respostas: 5
    Último Post: 08-07-2012, 22:56
  4. NAT MASQUERADE por faixa de ip
    Por wasley no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-08-2010, 08:14
  5. clientes saindo por ips validos diferentes.
    Por ThyagoComputer no fórum Redes
    Respostas: 2
    Último Post: 13-03-2009, 10:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L