+ Responder ao Tópico



  1. #1

    Padrão Duvida squid.conf

    Bom dia..

    Meu servidor é uma 2 quad 3.0 ..
    4gb memoria.
    eth0 / eth1 gigabit.
    possuo uma LP de 16mbits.

    Quando fico monitorando o trafego no iptraf ... não vejo muita diferença da entrada da eth0 (LP 16mbit) com a eth1 ( rede local ).

    Fiz um comparativo em um periodo de 10 minutos, a porcentagem da eth1 para a eth0 foi muito poco, não deu nem 7% de trafego utilizado do cache.

    Irei postar o squid.conf, para que tenham uma ideia se estou fazendo certo as configurações ou estou errando em alguma parte.

    Obrigado desde já ....


    Segue meu squid.conf

    http_port 8080 transparent
    icp_port 0

    hierarchy_stoplist cgi-bin ?
    acl video_cache dstdomain .youtube.com video.google.com .llnwd.net .dailymotion.com .googlevideo.com
    acl google_earth dstdomain kh.google.com
    acl QUERY urlpath_regex cgi-bin \?
    acl flashvideo urlpath_regex .swf .flv .avi .mov
    no_cache allow video_cache
    no_cache allow google_earth
    no_cache allow flashvideo

    cache_mem 2048 MB
    maximum_object_size_in_memory 2 MB
    maximum_object_size 99 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95

    cache_dir aufs /var/cache/squid 30000 32 256

    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log

    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    acl all src 0.0.0.0/0.0.0.0
    acl internet src 192.168.100.0/24
    acl intranetac src 10.0.0.0/8
    acl intranetb src 130.0.0.0/24

    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563 82
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    http_access allow localhost
    http_access allow internet
    http_access allow intranetac
    http_access allow intranetb
    http_access deny all


    cache_effective_user squid
    cache_effective_group squid

    visible_hostname localhost

  2. #2
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão

    Boa tarde.

    amigo, informa com mais clareza qual o problema que está acontecendo com o teu servidor. Pelo o que vi, no seu arquivo de configuração não fazes cache de nenhum vídeo do youtube, muito menos arquivos com extensão .swf .flv .avi .mov. Então acredito que seja também um dos motivos de não utilizar tanto o cache quando fizestes o diagnóstico do tráfego. Acho que precisas modificar o teu arquivo squid.conf. estou enviando um arquivo com extensão *.doc sobre as modificações do arquivo *.conf. realize os testes e informe os resultados.


    Atenciosamente,
    Arquivos Anexos Arquivos Anexos



  3. #3

    Padrão

    Posso modificar essas configurações e restart meu squid apenas ? ou preciso rodar o squid -z para criar os diretorios denovo ??


    Obrigado .

  4. #4
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão

    Bom dia amigo.

    Acredito que seria bom realizar um limpeza no seu cache, depois criar os diretórios do squid e aí depois de configurá-lo, iniciá-lo.


    Atenciosamente,



  5. #5

    Smile Hardware utilizado ?

    Mdantas

    Gostaria de saber do que vc usa no se server pra este squid.conf que vc postou, placa mãe, memoria, processador, hd etc

    abraços

  6. #6
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão

    Citação Postado originalmente por jeanfrank Ver Post
    Mdantas

    Gostaria de saber do que vc usa no se server pra este squid.conf que vc postou, placa mãe, memoria, processador, hd etc

    abraços

    Jean bom dia.

    O squid.conf que está anexado aí no post é o arquivo do rapaz que me pediu para realizar alterações pois estava com problemas com o mesmo. Agora em relação ao hardware do meu servidor webproxy aqui, eu utilizado a seguinte configuração:

    Processador : atlhon XP 1.1 GHZ
    Memória Ram : 1 GB
    Placa mãe : Placa Pcchips
    Disco rígido: IDE barracuda seagate 7.200 rpm 40 GB

    Uma configuração baixa em relação aos equipamentos de hoje, porém atendo 50 clientes com este servidor no meu provedor sem problema algum. Estou com ele ligado 24 horas por dia, e já se passaram dois anos. Porém estou atualizando para uma configuração de um servidor mais robusto.


    Atenciosamente,



  7. #7

    Padrão

    Ok. irei rodar o processo 5 da manha, e retorno sobre os resultados

  8. #8

    Padrão

    Segue a configuração da maquina

    Cache de Processador (L2): 6MB
    Qtde de Processador Suportado: 1
    Memória Padrão: 4.0GB
    Memória Máxima: 8GB
    Controladora: SAS / SATA
    Mídia Óptica: DVD-Rom
    2 Placa de Rede (Mbps): 10/100/1000
    Clock do Processador (GH (GHz): 2,5
    Disco Rígido Padrão: 250GB
    Interface de Disco: SATA / SAS Hot-Swap LFF

    O teste ainda não fui.. recebi permissao de mudar o squid.conf só hojé a noite.. logo na sexta de manha eu posto os resultados..


    Obs( meu proxy segura 600 pc )
    Att.



  9. #9

    Padrão

    Com sua conf. ficou otimo o proxy meu amigo

    olha só o meu iptraf !!!

    Obrigado

    eth0 - lk 18mbit
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         proxy_up.JPG
Visualizações:	74
Tamanho: 	27,3 KB
ID:      	3586