+ Responder ao Tópico



  1. tenho aqui um script para redirecionar :

    iptables -t nat -A PREROUTING -d 10.X.X.X -p tcp -m tcp --dport 3389 -j DNAT --to 10.X.X.X

    porem só funciona msmo, se eu mascarar assim...

    iptables -t nat -A POSTROUTING -s 10.X.X.X/24 -o eth0 -j MASQUERADE
    por que?

    eu to testando em laboratório primeiro...
    esta regra funcionaria se eu fosse usar endereços externos?
    num conheço o iptables muito a fuuuuuuundo...

  2. Bom dia amigo,

    Primeiro gostaria de respostas para algumas perguntas:
    - Quantas placas de rede tem esse seu servidor?
    - Voce disse que so consegue acessar se voce mascarar... Mas voce esta tentando acessar de uma rede externa ou na mesma rede?



  3. mano...
    seguinte:
    no laboratório eu tenho uma só!
    porem onde irei implantar tem 2. a interna e a externa ( daaaa ) rsrsrs...

    inicialmente, como estou testando em laboratório estou testando na mesma rede, porem preciso implemtar para acessar de fora.

    obrigado por em quanto!

    ah tava aqui testando e percebi que funciona quando eu uso DROP depois de mascarar.

    iptables -t nat -A POSTROUTING -s 10.X.X.X/24 -o eth0 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s 10.X.X.X/24 -o eth0 -j DROP
    Última edição por Lincoln; 11-02-2009 às 09:00.

  4. Consegui resolver e entender o problema através desta dica aqui!

    Linux: Redirecionamento de portas com Iptables [Dica]

    pra quem estiver no mesmo perrengue!!!!







Tópicos Similares

  1. ssh so funciona em rede interna
    Por ncajr no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-12-2005, 14:46
  2. Internet só funciona quando para o iptables
    Por Bruno Antelo no fórum Servidores de Rede
    Respostas: 3
    Último Post: 03-02-2005, 22:32
  3. Apache só funciona com IP
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-09-2003, 15:30
  4. só funciona interno
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 04-06-2003, 17:46
  5. porque não funciona???
    Por beastie no fórum Servidores de Rede
    Respostas: 4
    Último Post: 28-02-2003, 12:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L