Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão script

    pessoal, boa noite!


    Alguém poderia me quebrar um galho e me passar por favor um script para habilitar uma regra do address-list?

    O scheduler eu desenrrolo, mas do script estou apanhando

  2. #2

    Padrão

    Se ate la pelas 11:00hs ninguem postar um modelo de script, vou restaurar um backup do me MK, onde fiz isso, mais so q foi com a regra de redirecionamento para o proxy, so me lembro q eu ativava e destivava pelo comente da regra, eu ate achei o script em um arquivo do bloco de notas, mais parece q esta faltando alguma coisa...



  3. #3

  4. #4

    Smile scripts...

    AI VELHO VE SE TE ATENDE ESTE

    #Define Local Var and load data
    #routing table size
    :local routeSize [/ip route pr count-only];
    #if the list exists get the size
    :local listSize [/ip firewall address-list pr count-only where list=LocalNet];
    #loop variables
    :local i 0;
    :local j 0;
    #IP logic check
    :local checkIP 0;
    #route ip address
    :local ipAddress;
    #loop to check the entire routing table
    :for i from=0 to=$routeSize step=1 do={
    #get the IP address of the route
    :set ipAddress [/ip route get $i dst-address]
    #check if the IP is already listed in the address list
    :set checkIP [/ip firewall address-list pr count-only where address=$ipAddress];
    #if it is the default gateway don't add it
    :if ($ipAddress=0.0.0.0/0) do={:set checkIP 2}
    #If the IP is not in the list add it
    :if ($checkIP = 0) do={
    /ip firewall address-list add list=LocalIPs address=$ipAddress;}

    VALEU



  5. #5

    Padrão

    Rapaz...a intenção foi boa, mas preciso só de um script para habilitar uma regra do address-list, esse script todo seria pra que ?????

  6. #6
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Rapaz...a intenção foi boa, mas preciso só de um script para habilitar uma regra do address-list, esse script todo seria pra que ?????
    ola Roberto,

    eu uso assim:

    vai em ip --> firewall --> address list
    e add o IP que vc quer fazer a regra..

    para ativar a regra:

    agora vai em system --> script

    1 -click e (+) de um nome qualquer (ex: ativa-ip)
    2 -em policy deixe tudo marcado
    3 -em source coloque essa regra:

    /ip firewall address enable [/ip firewall address find address="200.200.200.200"]

    (obs. 200.200.200.200 = o IP que quer fazer a regra; que esta cadastrado em address list)

    para desativar a regra :

    repita toda a regra acima mudando o nome (desativa-ip) e isso:

    /ip firewall address disable [/ip firewall address find address="200.200.200.200"]

    (observe que troquei o "enable" pelo "disable")