Olá Pessoal, por favor Preciso de uma Ajuda urgente.

Meu problema e o seguinte.

Tenhu a Seguinte configuração,

Atual
LAN - 10.0.0.x
WAN - 200.126.X.X

O servidor ta rodando File, com cache full, host post, protecao para p2p, etc.
to querendo adicinoar uma adsl. que no caso vai ficar assim.

LAN - 10.0.0.x
WAN - 200.126.X.X
WAN2 - 192.168.3.x

bom fix as configurações segundo o citado a baixo, mais não obtive muito sucesso, bom o primeiro emplo de load, eu fiz e ate que funciono aparentemente, mais ao navegar depois de entrar em umas duas páginas ele trava e não vai mais, tipow como se ele durasse alguns instantes e caise,
bom nao sei se é por cause de estar usando web proxy cache full. suspeitei ser isso, ou naum sei se o modem da wan2 esta em router em vez de bridge, mais e que no meu caso naum posso atrelar o modem da wan2 no servidor.

bom nos outros dois casos o que separa a rede por grupos, e o outro o qual naum entendi direito, bom os dois aparentemento funsionaram tb, mais aparece a tela do squid dizendo que nao foi possivel localizar a página no proxy e naum a aprece a tela do hostpost para logar. Diferente do primeiro caso acima que chego a logar no host post e ate navegar mais trava, nesse caso nem aparece a tela para o login do host post e da o erro de squid.

sei que estou perto de resolver esses problemas mais não sei o que estou errando na configuração, por isso pesso a ajuda de todos.

por favor se alguem se dispuser a resolver, eu ate pago pelo serviço tenhu urgencia em sanar esse problema.

Desde ja agradesso e deixo a disposição o meu msn para contato e so me add, e se alguem puder posso ate criar um acesso remoto para quem quiser ver as configurações e me ajudar.

meu msn wzlanhouse@hotmail.com


galera tenho um ano de Experiencia com o mikrotik
vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas

LOAD BALANCE 1

e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!

exemplo:

Interfaces

Rede ip - 192.168.0.1/24
Link1 ip - 10.10.10.1/24
Link2 ip - 20.20.20.1/24

regras:

/ip firewall mangle
add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
1863 new-routing-mark=msn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment="" disabled=no \
new-packet-mark=msn passthrough=yes routing-mark=extra

add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
443 new-routing-mark=https passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment="" disabled=no \
new-packet-mark=https passthrough=yes routing-mark=extra

/ip route
add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
10
add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
10


LOAD BALANCE 2

Esse vc separa por grupos de usuarios da sua rede.

Exemplo:

Interface

Rede ip - 192.168.0.1/24
Link1 ip - 10.10.10.1/24
Link2 ip - 20.20.20.1/24

regras:


/ip firewall mangle
add action=mark-routing chain=prerouting comment="GrupA" \
disabled=no new-routing-mark=GrupA passthrough=no src-address=\
192.168.0.2-192.168.0.128
add action=mark-routing chain=prerouting comment="GrupB" \
disabled=no new-routing-mark=GrupB passthrough=no src-address=\
192.168.0.129-192.168.0.254

/ip route
add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10

galera agora vou colocar uns sripts para se for o caso de algum link cair:

Regras:

/system script
add name=link1-on policy=\
ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
"/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
add name=link1-off policy=\
ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
"/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
add name=link2-on policy=\
ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
"/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
add name=link2-off policy=\
ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
"/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"

/tool netwatch
add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
10.10.10.1 interval=5m timeout=1s up-script=link1-on
add comment="Rota - Grupo B" disabled=no down-script=link2-off \
host=20.20.20.1 interval=5m timeout=1s up-script=link2-on


exemplo 2

Rede ip - 192.168.0.1/24
Link1 ip - 10.10.10.1/24
Link2 ip - 20.20.20.1/24
Link3 ip - 30.30.30.1/24
Link4 ip - 40.40.40.1/24

Regras

/ip firewall mangle
add action=mark-routing chain=prerouting comment="GrupA" \
disabled=no new-routing-mark=GrupA passthrough=no src-address=\
192.168.0.2-192.168.0.64
add action=mark-routing chain=prerouting comment="GrupB" \
disabled=no new-routing-mark=GrupB passthrough=no src-address=\
192.168.0.65-192.168.0.128
add action=mark-routing chain=prerouting comment="GrupC" \
disabled=no new-routing-mark=GrupC passthrough=no src-address=\
192.168.0.129-192.168.0.192
add action=mark-routing chain=prerouting comment="GrupD" \
disabled=no new-routing-mark=GrupD passthrough=no src-address=\
192.168.0.193-192.168.0.254

/ip route
add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
30.30.30.1 routing-mark=GrupC scope=255 target-scope=10
add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
40.40.40.1 routing-mark=GrupoD scope=255 target-scope=10

LOAD BALANCE 3

esse um load que o mikrotik distribui por pacotes de conexão ja e mais um pouca complicada de se explicar mas vamos lá.

Mikrotik Versão 2.9

exemplo:

Rede ip - 192.168.0.1/24
Link1 ip - 10.10.10.1/24
Link2 ip - 20.20.20.1/24

Regras

/ ip firewall mangle
add chain=prerouting in-interface= Rede connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no

add chain=prerouting in-interface= Rede connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no

add chain=prerouting in-interface= Rede connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no

add chain=prerouting in-interface= Rede connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no


/ ip firewall nat
add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.10.10.1 to-ports=0-65535 comment="Balanceamento de carga" disabled=no

add chain=srcnat connection-mark=even action=src-nat to-addresses=20.20.20.1 to-ports=0-65535 comment="" disabled=no

/ ip route
add dst-address=0.0.0.0/0 gateway=10.10.10.1 scope=255 target-scope=10 routing-mark=odd comment="Gateway link1" disabled=no

add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 routing-mark=even comment="Gateway link2" disabled=no

add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 comment="principal" disabled=yes

Espero que ajude muita gente, qualquer duvida e so postar obrigado