Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola
    Amigos....

    tenho uma rede com 20 pc e um servidor configurado com ubuntu (desktop).

    Istalei o squid com a esperança q a internet parasse de cair.. ou ficasse um pouco menos pesada.
    são 20 makinas para internet de 1Mb.

    abaixo segue o meu squid.conf
    =======================*******======================
    http_port 3128 transparent
    visible_hostname freedom

    cache_mem 64 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 700 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    cache_dir ufs /var/spool/squid 2048 16 256
    cache_access_log /var/log/squid/access.log
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 21 80 443 563 70 210 280 488 59 777 901 1025-65535
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports


    logfile_rotate 6

    acl redelocal src 192.168.0.0/24
    http_access allow localhost
    http_access allow redelocal
    http_access deny all

    ===========================***********===================

    mas quando rodo o comando "tail -f /var/log/messages /var/log/squid/access.log"

    ele responde com a seguinte menssagem

    > /var/log/messages <==
    Feb 11 17:11:29 Freedom kernel: [ 60.117325] lo: Disabled Privacy Extensions
    Feb 11 17:11:35 Freedom pulseaudio[4931]: ltdl-bind-now.c: Failed to find original dlopen loader.
    Feb 11 17:11:35 Freedom pulseaudio[4933]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operação não permitida
    Feb 11 17:11:35 Freedom pulseaudio[4933]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operação não permitida
    Feb 11 17:17:09 Freedom squid[4530]: Squid Parent: child process 4532 exited with status 0
    Feb 11 17:17:12 Freedom squid[5519]: Squid Parent: child process 5522 started
    Feb 11 17:21:38 Freedom squid[5519]: Squid Parent: child process 5522 exited with status 0
    Feb 11 17:21:40 Freedom squid[5858]: Squid Parent: child process 5861 started
    Feb 11 17:34:38 Freedom squid[5858]: Squid Parent: child process 5861 exited with status 0
    Feb 11 17:34:40 Freedom squid[6169]: Squid Parent: child process 6172 started

    ==> /var/log/squid/access.log <==

    ==> /var/log/messages <==
    Feb 11 17:50:55 Freedom -- MARK --


    onde está o meu erro?!
    alguem pode me ajudar?

    agradeço

  2. este é o seu squid.conf completo ???
    pois esta faltando algumas coisas ai como a src da sua redelocal ???
    vc criou os diretorios de cache e de log deu permissão de escrita neles ????



  3. Amigos, boa noite. Sou iniciante no squid e gostaria da ajuda de vocês para que eu possa continuar meus estudos. O cenário é o seguinte:

    1 Pc com duas placas de rede
    - eth0: ligado a intenert (modem adsl roteado)
    - eth1: Rede local com ip fixo 192.168.1.1

    o arquivo /etc/network/interfaces é esse:

    # The loopback network interface
    auto lo eth0 eth1
    iface lo inet loopback

    # The primary network interface

    iface eth0 inet static
    address 192.168.1.1
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255

    iface eth1 inet dhcp

    o roteamento esta sendo feito por esse script colocado no /etc/rc.local

    #!/bin/sh
    modprobe iptable_nat
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1400:1536 -j TCPMSS --clamp-mss-to-pmtu
    iptables -A INPUT -s 192.168.1.1/255.255.255.0 -j ACCEPT
    #iptables -A INPUT -p icmp --icmp-type echo-request -j DROP
    #echo 1 > /proc/sys/net/ipv4/conf/default/rp_filter
    # iptables -A INPUT -m state --state INVALID -j DROP
    # iptables -A INPUT -i lo -j ACCEPT
    # iptables -A INPUT -p tcp --dport 22 -j ACCEPT
    # iptables -A INPUT -p tcp --dport 24800 -j ACCEPT
    # iptables -A INPUT -p tcp --syn -j DROP

    ------
    o arquivo de configuração do squid ou squid.conf esta assim:

    http_port 3128
    visible_hostname Emerson
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 21 80 443 563 70 210 280 488 59 777 901 1025-65535
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl redelocal src 192.168.1.0/24
    http_access allow localhost
    http_access allow redelocal

    http_access deny all
    http_access allow all

    fiz o redirecionamento assim: a iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    assim que eu executo esse comando os micros da rede param de acessar a internet. Fui tentar colocar o proxy mas não acessa. Eu coloquei em http:// 192.168.1.1 (ip da eth1 rede interna) e porta 3128.

    o que pode estar errado? agradeço a atenção de todos.

    abraços

  4. Citação Postado originalmente por playboy Ver Post
    Amigos, boa noite. Sou iniciante no squid e gostaria da ajuda de vocês para que eu possa continuar meus estudos. O cenário é o seguinte:

    1 Pc com duas placas de rede
    - eth0: ligado a intenert (modem adsl roteado)
    - eth1: Rede local com ip fixo 192.168.1.1

    o arquivo /etc/network/interfaces é esse:

    # The loopback network interface
    auto lo eth0 eth1
    iface lo inet loopback

    # The primary network interface

    iface eth0 inet static
    address 192.168.1.1
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255

    iface eth1 inet dhcp

    o roteamento esta sendo feito por esse script colocado no /etc/rc.local

    #!/bin/sh
    modprobe iptable_nat
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1400:1536 -j TCPMSS --clamp-mss-to-pmtu
    iptables -A INPUT -s 192.168.1.1/255.255.255.0 -j ACCEPT
    #iptables -A INPUT -p icmp --icmp-type echo-request -j DROP
    #echo 1 > /proc/sys/net/ipv4/conf/default/rp_filter
    # iptables -A INPUT -m state --state INVALID -j DROP
    # iptables -A INPUT -i lo -j ACCEPT
    # iptables -A INPUT -p tcp --dport 22 -j ACCEPT
    # iptables -A INPUT -p tcp --dport 24800 -j ACCEPT
    # iptables -A INPUT -p tcp --syn -j DROP

    ------
    o arquivo de configuração do squid ou squid.conf esta assim:

    http_port 3128
    visible_hostname Emerson
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 21 80 443 563 70 210 280 488 59 777 901 1025-65535
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl redelocal src 192.168.1.0/24
    http_access allow localhost
    http_access allow redelocal

    http_access deny all
    http_access allow all

    fiz o redirecionamento assim: a iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    assim que eu executo esse comando os micros da rede param de acessar a internet. Fui tentar colocar o proxy mas não acessa. Eu coloquei em http:// 192.168.1.1 (ip da eth1 rede interna) e porta 3128.

    o que pode estar errado? agradeço a atenção de todos.

    abraços
    vamus la primeiramente seu proxy esta transparente entao naum precisa de colocar o proxy no navegador

    sendo falta um masquerade da eth1 ex:
    iptables -t nat -A POSTROUTING -s 192.168.1.0/24 -j MASQUERADE

    terceiro sua regra de iptables ta bloqueando tudo

    e liberando somente source da rede 192.168.1.0/24 precisa tb de destino ( -d)
    prota do dns etc

    reveja sei firewall



  5. Citação Postado originalmente por Benatto Ver Post
    este é o seu squid.conf completo ???
    pois esta faltando algumas coisas ai como a src da sua redelocal ???
    vc criou os diretorios de cache e de log deu permissão de escrita neles ????

    como faço isso?!






Tópicos Similares

  1. meu orinoco ap2000 nao funciona !!! help-me
    Por PERDIGAWEB no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-09-2007, 09:04
  2. Samba não funciona - help me
    Por no fórum Servidores de Rede
    Respostas: 7
    Último Post: 26-06-2003, 14:40
  3. netfilter2html nao funciona help
    Por rlucatto no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-05-2003, 16:38
  4. Impressora não funciona help me!!!
    Por maacnet no fórum Servidores de Rede
    Respostas: 10
    Último Post: 06-01-2003, 19:54
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L