Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. nstalei o bind e do servidor pingo em hosts como uol.com.br e em ips mas nas máquinas clientes não consigo pingar em hosts então queria saber o que está faltando pois só consigo pingar das máquinas clientes em hosts quando coloco o como DNS alternativo o IP do provedor mas queria somente o DNS local...nessa máquna rodo iptables + squid.
    Lembrando que navego e pingo externamente em IPS nas máquina clientes normal só com o DNS do linux e deixei o firewall delas desativado ms só consigo pingar em hosts.
    servidor debian lenny.
    Última edição por lfernandosg; 14-02-2009 às 12:26.

  2. pingar a partir do servidor não é vantagem alguma, pode ser que o seu /etc/resolv.conf esteja apontando para um OUTRO server que não o seu.

    vamos tentar aos bocadinhos:
    a) está no ar? CONFIRA:
    a-1) netstat -nlpt (como root) deve mostrar a porta 53 e QUEM a ocupa (ouve)
    a-2) dig @localhost uol.com.br soa
    a-3) telnet localhost 53

    bem.. se passar incólume pelos 3 (ou, pelo menos 2) desses testes, vamos partir para as máquinas clientes

    a partir de um cliente qualquer:

    1) telnet ip_seu_servidor 53

    se houver resposta, tá tudo em paz, funcionando. Mas seus clientes não navegam, então:

    a)verifique se essas máquinas indicam o SEU servidor como sendo o dns-server delas
    b) não há um b), afinal vc conseguiu o telnet então só resta fixar-se nos clientes.

    2) não havendo resposta ao telnet, então o seu servidor está bloqueando - verifique suas regras de iptables

    3) não há um três. É que gosto de coisas impares mesmo.



  3. vamos la:

    a-1) netstat -nlpt (como root) deve mostrar a porta 53 e QUEM a ocupa (ouve)
    R-
    debian:/home/novaf# netstat -nlpt
    Conexões Internet Ativas (sem os servidores)
    Proto Recv-Q Send-Q Endereço Local Endereço Remoto Estado PID/Program name
    tcp 0 0 10.0.1.254:53 0.0.0.0:* OUÃA 1897/named
    tcp 0 0 IP VALIDO EMBRATEL:53 0.0.0.0:* OUÃA 1897/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* OUÃA 1897/named
    tcp 0 0 0.0.0.0:22 0.0.0.0:* OUÃA 1926/sshd
    tcp 0 0 10.0.1.254:3128 0.0.0.0:* OUÃA 2194/(squid)
    tcp 0 0 127.0.0.1:953 0.0.0.0:* OUÃA 1897/named
    tcp6 0 0 :::80 :::* OUÃA 2234/apache2
    tcp6 0 0 :::53 :::* OUÃA 1897/named
    tcp6 0 0 :::22 :::* OUÃA 1926/sshd
    tcp6 0 0 ::1:953 :::* OUÃA 1897/named

    a-2) dig @localhost uol.com.br soa

    R-
    debian:/home/novaf# dig @localhost uol.com.br soa

    ; <<>> DiG 9.5.1-P1 <<>> @localhost uol.com.br soa
    ; (2 servers found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33018
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;uol.com.br. IN SOA

    ;; ANSWER SECTION:
    uol.com.br. 3600 IN SOA eliot.uol.com.br. root.uol.com.br. 2009021302 7200 3600 432000 3600

    ;; AUTHORITY SECTION:
    uol.com.br. 3490 IN NS borges.uol.com.br.
    uol.com.br. 3490 IN NS eliot.uol.com.br.

    ;; Query time: 87 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Feb 15 08:15:24 2009
    ;; MSG SIZE rcvd: 110


    a-3) telnet localhost 53
    R- debian:/home/novaf# telnet localhost 53
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.



    bem.. se passar incólume pelos 3 (ou, pelo menos 2) desses testes, vamos partir para as máquinas clientes

    a partir de um cliente qualquer:

    1) telnet ip_seu_servidor 53
    R-vou testar amanhã e te passo pois fiz os testes do servidor via SSH

    se houver resposta, tá tudo em paz, funcionando. Mas seus clientes não navegam, então:

    R-Os clientes navegam normal só que só pingam nos ips externos mas não nos hosts ja o servidor pinga em tudo nomal e dentro do resolv.con tem so o proprio ip dele.

    a)verifique se essas máquinas indicam o SEU servidor como sendo o dns-server delas

    R-SIM
    b) não há um b), afinal vc conseguiu o telnet então só resta fixar-se nos clientes.

    2) não havendo resposta ao telnet, então o seu servidor está bloqueando - verifique suas regras de iptables
    R-
    OBS.: meu iptables para DNS está assim:
    iptables -A INPUT --src $IP_INTERNO -i $IF_INTERNO --dst $IP_INTERNO -p tcp --dport 53 -j ACCEPT # DNS server
    iptables -A INPUT --src $IP_INTERNO -i $IF_INTERNO --dst $IP_INTERNO -p udp --dport 53 -j ACCEPT # DNS server
    iptables -A INPUT --src $IP_INTERNO -i $IF_INTERNO --dst $IP_EXTERNO -p udp --dport 53 -j ACCEPT # DNS server

    uso essas mesas regras na empresa onde trabalho com bind instalado e funciona normal é isso que não entendo.
    Última edição por lfernandosg; 15-02-2009 às 07:20.

  4. Ja pensou q no cliente pode ter firewall ativado??

    Tenta só desativar firewall do cliente msm akele do windows XP e tenta pingar pra v oq dá



  5. já está desabilitado estou testando com minha máquina...como disse consigo pingar normal dentro da empresa que tenho as mesas regras de firewall + squid da minha máquina.


    entrei nestante no TS de minha empresa e deixei com DNS só o ip do linux tirando os Ips dos ads e consigo pingar normal tanto nos ips quanto nos hosts externos....






Tópicos Similares

  1. Respostas: 5
    Último Post: 27-11-2012, 23:32
  2. caixa hermética em baixo e nao em cima
    Por ruanserver no fórum Redes
    Respostas: 12
    Último Post: 02-11-2012, 20:19
  3. Respostas: 9
    Último Post: 08-05-2012, 09:41
  4. Respostas: 14
    Último Post: 23-02-2011, 22:26
  5. VM com Debian - Navega na internet, mas não pinga ip e nem domínio externo
    Por siqueirastos no fórum Sistemas Operacionais
    Respostas: 4
    Último Post: 21-05-2010, 12:28

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L