Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Proxy Paralelo com Debian / squid

    Estou usando a v. 3.2 com proxy cache habilitado, e firewall redirecionando a porta 80 para 3126 do proxy-cache do mikrotik e usando parent proxy para redirecionar para a 3128 do squid no debian. tudo funcionando blz, porém percebi um alto consumo de memoria no mikrotik, tipo em mais ou menos 6 horas vão-se mais de 1 gb da memória livre, pq se estou redirecioando tudo para o debian, se limpo o cache mikrotik continuo baixando arquivos cacheados no squid a 3.3 mb/s na rede.
    Pq este consumo de memória no mikrotik, algo errado ?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         conf. mikrotik.JPG
Visualizações:	522
Tamanho: 	98,3 KB
ID:      	3588  

  2. #2

    Padrão

    Pessoal, adianto que não me aguentei, to usando um cartão ide de 1 gb no meu servidor com a ver. 2.9.51, com as mesmas configurações e claro, com o parent proxy redirecionando a porta 80 para o debian, vamos ver como ele se sai, e se a memória do mikrotik vai continuar caindo, novidades posto aki, obrigado...



  3. #3
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    Reveja as regras do firewall, presta atenção. Bloqueie a porta do squid para uso de fora da sua rede. Na maioria das vezes com proxy, é o pessoal espancando o seu proxy. Espero ter ajudado.

  4. #4

    Padrão

    Citação Postado originalmente por interhome Ver Post
    Reveja as regras do firewall, presta atenção. Bloqueie a porta do squid para uso de fora da sua rede. Na maioria das vezes com proxy, é o pessoal espancando o seu proxy. Espero ter ajudado.
    infelismente não resolveu, continua comendo banda do mikrotik, tem alguma regra que eu possa usar que funcione o proxy squid debian com o proxy-cache do mikrotik desativado?



  5. #5
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    / ip firewall nat
    add chain=dstnat src-address=Faixa de ip dos seus clientes protocol=tcp dst-port=80 action=dst-nat to-addresses=ip do debian to-ports=3128 \
    comment="NAT - Proxy" disabled=no

    Mas dessa forma desative a regra de drop da porta 3128 do seu firewall. Tudo funcionando agente monta ela denovo.

    Desabilite o proxy e o web-proxy do mk.
    Última edição por interhome; 15-02-2009 às 22:08.

  6. #6

    Padrão

    Citação Postado originalmente por interhome Ver Post
    / ip firewall nat
    add chain=dstnat src-address=Faixa de ip dos seus clientes protocol=tcp dst-port=80 action=dst-nat to-addresses=ip do debian to-ports=3128 \
    comment="NAT - Proxy" disabled=no

    Mas dessa forma desative a regra de drop da porta 3128 do seu firewall. Tudo funcionando agente monta ela denovo.

    Desabilite o proxy e o web-proxy do mk.
    Existe alguma exigencia para que essa regra funcione, o squid ta ativo, ja confirmei a porta e o ip, mais quando ativo as regra não navega.