Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão Mikrotik - PCQ

    Mikrotik - PCQ

    PCQ (Per Connection Queue) é uma fila que pode ser usada para uniformizar dinamicamente ou moldar o tráfego para vários usuários, usando pouca administração. É possível dividir os cenários PCQ em três grandes grupos: Igualdade de largura de banda para um determinado número de usuários; Alguma largura de banda distribuída com igualdade entre os usuários; Largura de banda desconhecida distribuída com igualdade entre os usuários.
    Igualdade de largura de banda para um determinado número de usuários.

    http://lfaria.files.wordpress.com/2008/01/pcq.png
    Existem duas formas de fazer isso: usando mangle e queue tree, ou, usando simple queue.

    1. Marque todos os pacotes com packet-mark all:

    /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no

    2. Configurar dois queue types PCQ - um para download e outro para upload. Dst-address é classificador do tráfego de download do usuário, src-address para o tráfego de upload:

    /queue type add name=”PCQ_download” kind=pcq pcq-rate=64000 pcq-classifier=dst-address
    /queue type add name=”PCQ_upload” kind=pcq pcq-rate=32000 pcq-classifier=src-address

    3. Finalmente, duas queue rules são necessárias, uma para download e um para upload:

    /queue tree add parent=global-in queue=PCQ_download packet-mark=all
    /queue tree add parent=global-out queue=PCQ_upload packet-mark=all

    Se você não gosta de usar mangle ou queue tree, você pode ignorar esta etapa 1, mantendo as etapas 2 e 3 e passaria a criar uma simple queue como mostrado aqui:

    /queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

  2. #2



  3. #3
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    uma duvida posso usar normalmente com o hotspot?
    Tenho cliente com velocidade diferente.

  4. #4

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    uma duvida posso usar normalmente com o hotspot?
    Tenho cliente com velocidade diferente.
    O PCQ ele vai tenta equalizar ao maximo a velocidade do cliente ou seja se você tem 1mb e 50 cliente online ele vai tenta deixa dividido por igual para todos que estiverem em uso.

    Não importa quanto o cliente terá, nesse exemplo o Magal fez uma rede toda então toda a rede vai ser dividida por igual.



  5. #5

    Padrão

    Citação Postado originalmente por alcimarbezerra Ver Post
    O PCQ ele vai tenta equalizar ao maximo a velocidade do cliente ou seja se você tem 1mb e 50 cliente online ele vai tenta deixa dividido por igual para todos que estiverem em uso.

    Não importa quanto o cliente terá, nesse exemplo o Magal fez uma rede toda então toda a rede vai ser dividida por igual.

    Isso server por exemplo, para usar em varios clientes? Com mascara /32
    ou seja

    tenho 1mb, e 50 clientes online...
    varios queue simple /32 usando PCQ, ele iria deixar todos por igual? pra um não usar mais e outro menos?

  6. #6



  7. #7

    Padrão

    Citação Postado originalmente por iuredaluz Ver Post
    Isso server por exemplo, para usar em varios clientes? Com mascara /32
    ou seja

    tenho 1mb, e 50 clientes online...
    varios queue simple /32 usando PCQ, ele iria deixar todos por igual? pra um não usar mais e outro menos?
    Você pode criar vários pcq's para seus clientes.

  8. #8
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Você pode criar vários pcq's para seus clientes.

    Como ficaria PCQ para cada profile no hotspot?

    Porque tenho cliente de 300k, 150k, 100k e 90k.



  9. #9

    Padrão

    Você colocaria um pcq para cada profile. Cada um com um valor determinado por você que será divido pelos clientes do grupo, no caso.

  10. #10
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    muito boa ideai, ja tinha pensado em fazer assim mas nao tive tempo.
    economizei muito tempo com a sujestao, PARABENS



  11. #11

    Padrão

    Meus parabéns,
    A duvida agora é saber como ativar isso somente nos finais de semana, e voltar ao normal na segunda-feira.

  12. #12

    Padrão

    Script + scheduler, isto faz o que necessita.



  13. #13

    Question

    Citação Postado originalmente por Raniel Ver Post
    Script + scheduler, isto faz o que necessita.
    Tá, o problema é que eu sou underlinux baby no assunto, se puder ajudar em como fazer o script eu agradeceria!

  14. #14

    Padrão

    O que você tem que fazer?
    2 scripts (um para ativar e o outro para desativar) e 2 scheduler para executar no tempo programado.
    Última edição por Raniel; 01-03-2009 às 01:05.



  15. #15

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    O que você tem que fazer?
    2 scripts (um para ativar e o outro para desativar) e 2 scheduler para executar no tempo programado.
    hehe, deixa pra lá...
    Algum dia eu descubro como fazer esses scripts.

  16. #16

    Padrão

    Basta pesquisar.... Mas fala ae do que necessita que faremos um exemplo para te.



  17. #17
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    Aqui tem mais sobre o PCQ: PCQ parâmetros e exemplos
    Última edição por Magal; 29-03-2009 às 22:40.

  18. #18

    Padrão

    muito boa a regra...soh uma duvida...
    como eu usaria para um perfil de 128k no hotspot?



  19. #19

    Padrão

    Citação Postado originalmente por Mikrotinho Ver Post
    Meus parabéns,
    A duvida agora é saber como ativar isso somente nos finais de semana, e voltar ao normal na segunda-feira.
    amigo para vc basta criai apenas um scrip e um sheduler com a data em q o scrip devera ser executado por exemplo todos os sabados a partir da meia noite, para o scrip tente aprimorar esse ai abaixo q roda no meu servidor

    queue tree disable [/queue tree find packet-mark=all]
    :delay 14400
    queue tree enable [/queue tree find packet-mark=all]

    amigo so mude o packet-mark= colocando ali sua marcação do PCQ, em delay coloque o tempo em que o PCQ devera ser ativado novamente, por exemplo na segunda-feira, o tempo devera ser em segundos. por exemplo se vc quiser desativar o PCQ no sabado programa la no sheduler a data. Para desativar na segunda calcule em segundos por exemplo 2 dias são 172800 segundos que deverão ser colocados la em delay. Espero que consiga amigo!

  20. #20