Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão Squid-Cache paralelo ao MK duvida(essa é nova)

    Bom dia a todos,

    estou com um problema e nao sei como resolver...estou fazendo cache paralelo com squid, até ai td ok o squid esta configurado e rodando... segui a orientacao desses dois materiais que sao excelentes materiais, Linux: MikroTik + Squid 2.6 com cache full [Artigo], Detalhando proxy paralelo com o linux.

    Porem no meu servidor ocorre que tenho duas interfaces chegando clientes, e a minha saida para internet nao possui IP FIXO, no caso a saida é uma interface PPPOE-CLIENT, dai que vem o problema algumas regras nao consigo fazer corretamente, pq conforme o material vc tem q inserir o ip da interface de saida pra internet, mas a minha interface é dinamica... é agora??? :S

    ai algumas paginas nao navegam... o firewall do mikrotik barra... fiko outra hora abri hora nao abri ou abre mto lento... fikou bem estranho.... estou usando a versao 2.9.27 do MK e a versão 2.6 do squid no slackware12

    espero que alguem possa me ajudar

    no mais é issoae
    abraços

  2. #2

    Padrão

    Citação Postado originalmente por stevens144 Ver Post
    Bom dia a todos,

    estou com um problema e nao sei como resolver...estou fazendo cache paralelo com squid, até ai td ok o squid esta configurado e rodando... segui a orientacao desses dois materiais que sao excelentes materiais, Linux: MikroTik + Squid 2.6 com cache full [Artigo], Detalhando proxy paralelo com o linux.

    Porem no meu servidor ocorre que tenho duas interfaces chegando clientes, e a minha saida para internet nao possui IP FIXO, no caso a saida é uma interface PPPOE-CLIENT, dai que vem o problema algumas regras nao consigo fazer corretamente, pq conforme o material vc tem q inserir o ip da interface de saida pra internet, mas a minha interface é dinamica... é agora??? :S

    ai algumas paginas nao navegam... o firewall do mikrotik barra... fiko outra hora abri hora nao abri ou abre mto lento... fikou bem estranho.... estou usando a versao 2.9.27 do MK e a versão 2.6 do squid no slackware12

    espero que alguem possa me ajudar

    no mais é issoae
    abraços
    Olá Amigo,

    Não li o artigo citado acima, mais eu uso cache em paralelo com o mk, só que eu uso o BrazilFw, para quem não tem muito conhecimento em linux, ele é excelente, fora que ele usa um kernel 2.4.xque é super leve, e o mesmo é compilado com somente os recursos necessarios para sua função.
    Agora colocar qualquer dist. com kernel 2.6.x com interface gráfica, alem de dar muito mais trabalho vc vai precisar uma máquina robusta para ter o mesmo desempenho que um kernel 2.4.x

    Amigo, entre no site BrazilFW Firewall and Router baixe o instalador, instale em uma máquininha qualquer, que tenha duas interfaces de rede de preferecia 3com ou realtek 8139c, apos instalado instale a addon squid, ative ele de acordo com suas preferencias, e pronto, vc está com um servidor parrudo com uma excelente dist.

    Um abraço



  3. #3
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    o duro que o problema nao é em si no squid... e sim nas conf do mk... na questao de nat e tals :S

  4. #4
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    No seu firewall deve ter uma regra de bloqueio da porta do squid, que tem que existir se não vão estourar seu cache. Porem deve se deixar passar o trafego da rede que esta o proxy. E mesmo cuidado deve ter com o DNS.



  5. #5
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    InterHome
    eu criei um novo mk e tirei todas as regras do firewall.,.. mas mesmo assim n navega
    agora estou com o mk 3.15 e esta dando o erro Gateway Timeout
    e nao navega

  6. #6
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    da uma olhada nas regras veja se encontra algum erro

    /etc/squid/squid.conf

    #DIRETORIO CACHE NO HD
    cache_dir ufs /var/spool/squid/cache 48 16 256


    # Localização do log de acessos do Squid

    #cache_replacement_policy heap LFUDA
    #memory_replacement_policy heap GDSF

    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log
    #emulate_httpd_log on


    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 10 20% 2280



    acl all src 0.0.0.0/0.0.0.0
    cache_store_log /var/log/squid/store.log
    #emulate_httpd_log on


    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 10 20% 2280



    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 80 # http
    acl Safe_ports port 210 # wais
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 443 # https
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 544 # filemake
    acl Safe_ports port 631 # cups
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl Safe_ports port 1025-65535 # unregistered ports
    acl SSL_ports port 443 # https
    acl SSL_ports port 465 # YAHOO - SMTP (SSL)
    acl SSL_ports port 563 # snews
    acl SSL_ports port 873 # rsync
    acl SSL_ports port 995 # YAHOO - POP3 (SSL)
    acl purge method PURGE
    acl FTP proto FTP
    acl CONNECT method CONNECT



    #LIBERACOES PADROES
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access allow CONNECT FTP
    http_access deny CONNECT !SSL_ports



    ## LISTAS DE CONTROLE DE ACESSOS
    #acl rede-interna src 192.168.0.0/24

    ## Libera para a rede local e bloqueia acesso externo

    http_access allow all
    #http_access deny !rede-interna
    #http_access allow rede-interna
    #http_access deny all
    #cache_effective_user radical
    #cache_effective_group radical


    error_directory /usr/share/squid/errors/Portuguese
    o /etc/rc.local


    #!/bin/sh -e
    modprobe iptable_nat
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A PREROUTING -i eth0 -p tcp -m tcp --dport 80 -j REDIRECT --to
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    echo "Proxy Transparente ativado"
    Criando Diretorios
    [email protected]:/# squid -z
    2009/03/05 00:24:55| Creating Swap Directories
    [email protected]:/#

    Configuração no MK

    NAT

    [[email protected]] > ip firewall nat pr
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=dstnat action=redirect to-ports=3128 protocol=tcp in-interface=Rede
    dst-port=80

    1 ;;; Masquerade para rede mikrotik-cliente
    chain=srcnat action=masquerade src-address=192.168.1.0/24

    2 ;;; Masquerade para a rede mikrotik-linux
    chain=srcnat action=masquerade src-address=192.168.0.0/24
    Web-Proxy

    [[email protected]] > ip proxy print
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 192.168.0.1
    parent-proxy-port: 3128
    cache-administrator: "webmaster"
    max-cache-size: none
    cache-on-disk: no
    max-client-connections: 1000
    max-server-connections: 1000
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    cache-drive: primary-master

    espero que alguem possa me ajudar chegar ate aqui foi dificil... acho q agora falta pouco
    hehe
    obrigada