Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal, bem, estou com um pequeno probleminha e gostaria de dividir com vocês para quem sabe encotrarmos a solução para isso ...

    O problema é o seguinte, configuro o meu samba com LDAP certinho, tudo funciona certinho, usuários, grupos, permissões, pastas, etc. Só que acontece um problema chato ...

    Quando o usuário se loga, o script do grupo ( %G.bat ) não é chamado, checando o log do samba em nível 3, me é retornado que o arquivo não foi encontrado. Mas como se está tudo exatamente no lugar que configurei o samba, ( /var/lib/samba/netlogon ), com as devidas permissões e tudo mais. E mesmo assim não consegue rodar o script ( detalhe que se rodar manualmente pelo compartilhamento funciona sem problemas ).

    Bem se alguém puder me ajudar agradeço.

    Até mais.

    Uso CENTOS 5.2 nesse servidor de testes.

    meu Smb.conf :

    [global]
    # Nome da Maquina
    netbios name = samba
    netbios aliases = samba
    # Nome do Dominio
    workgroup = TESTES
    server string = Servidor de Testes
    # Hosts que possuem acesso liberado a base de dados
    hosts allow = 192.168.0. 127.0.0.
    interfaces = eth1 lo
    bind interfaces only = yes
    remote announce = [192.168.0.1]

    # Opcoes de Log
    log level = 3
    log file = /var/log/samba/%m.log
    max log size = 500
    syslog = 1
    debug timestamp = yes

    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    name resolve order = wins host bcast
    winbind use default domain = yes
    # Permite aos Administradores colocarem Máquinas no Domínio
    enable privileges = yes
    # Nivel de Seguranca
    security = user
    # Opcao para Encriptar as senhas
    encrypt passwords = yes
    guest ok = yes
    guest account = nobody
    admin users = root
    local master = yes
    os level = 65

    time server = yes
    domain master = yes
    preferred master = yes
    domain logons = yes
    preserve case = yes
    short preserve case = yes
    # Permite ou nega a identificacao de maiusculas e minusculas
    case sensitive = no
    # Mapeamento do Home do Usuario
    #logon home = \\%N\%U
    #logon drive = H:
    # Script a ser executado no Login do usuario
    logon script = %G.bat
    logon path = \\%L\Profiles\%U
    wins support = yes
    wins proxy = no
    # Verificar essa opcao caso haja defeito na conexao cliente/servidor
    dns proxy = no
    veto files = /explorer.*exe/*.VOB/*.mp3/*.mpg/*.mpeg/*.avi/*.wma/*.wav/*.wmv/*.iso/copy.exe/host.exe/autorun.inf/*.{*}/

    # Opcoes de Melhoria de Desempenho - Bruno - 23/09/2008
    read raw = yes
    write raw = yes
    oplocks = yes
    max xmit = 65535
    dead time = 15
    getwd cache = yes

    # Mostra os Caracteres acentuados corretamente
    #unix charset = iso8859-1
    #display charset = cp850
    display charset = UTF-8

    # Configurações do LDAP
    # =======================
    # Administrador do LDAP
    ldap admin dn = cn=root,dc=saude,dc=al,dc=gov,dc=br
    # Sufixo do LDAP
    ldap suffix = dc=saude,dc=al,dc=gov,dc=br
    passdb backend = ldapsam:ldap://127.0.0.1
    # Usa ou não SSL
    ldap ssl = no
    ldap user suffix = ou=Pessoas
    ldap group suffix = ou=Grupos
    ldap machine suffix = ou=Computadores
    ldap idmap suffix = ou=sambaDomainName=SES
    ldap delete dn = yes
    # Opcao para sincronizar as senhas do LDAP
    ldap passwd sync = yes
    #force user = %U:
    winbind separator = /
    winbind cache time = 10
    winbind enum users = yes
    winbind enum groups = yes
    obey pam restrictions = no
    winbind nested groups = yes
    idmap backend = ldap:ldap://127.0.0.1
    idmap uid = 500-15000
    idmap gid = 500-15000
    template shell = /bin/false

    # Scripts para a manipulacao de usuarios, grupos, etc.
    add user script = /usr/sbin/smbldap-useradd -m "%u"
    add machine script = /usr/sbin/smbldap-useradd -w "%u"
    rename user script = /usr/sbin/smbldap-usermod -r '%unew' '%uold'
    add group script = /usr/sbin/smbldap-groupadd -p "%g"
    add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
    delete user script = /usr/sbin/smbldap-userdel "%u"
    delete group script = /usr/sbin/smbldap-groupdel "%g"
    delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
    set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"

    # Troca de senha:
    passwd program = /usr/sbin/smbldap-passwd "%u"
    passwd chat = *New*password* %n *Retype*new*password* %n *passwd:*all*authentication*tokens*updated*successfully*

    #============================ Definições de Compartilhamento ==============================

    [netlogon]
    comment = Servico de logon de rede
    path = /var/lib/samba/netlogon
    guest ok = yes
    browseable = no
    writable = no
    write list = @suporte

    [Profiles]
    create mask = 0600
    csc policy = disable
    directory mask = 0700
    path = /setores/profiles
    browseable = no
    writable = yes

    [publico]
    comment = Diretorio público SESAU
    path = /tmp
    directory mode = 0777
    create mode = 0777
    read only = no
    public = yes
    writable = yes
    browseable = yes

    [suporte]
    comment = suporte
    path = /setores/suporte
    directory mode = 0755
    create mode = 0755
    read only = no
    public = no
    write list = @suporte
    browseable = no

  2. Amigo,

    Dei um look no seu SMB.CONF
    eu acho, que pode ser /var/lib/samba/netlogon

    O diretório /VAR é protegido do sistema, aponta o /samba/netlogon
    fora do VAR sacou...pode até colocar /home/samba/netlogon e sistema
    de ta entendendo que pode ser uma tentativa de invasão e corta a execução do script....
    e outra verifica os LOGS do Samba e Massagens.... sacou

    Não esqueça de usar o CHMOD 777 -R /home/samba/netlogon para colocar o diretório
    em UGO=WXR, altere também no SMB.CONF o novo caminho...Boa Sorte



  3. infelizmente n é isso, já tinha feito testes assim, movi os diretórios pro home, dei permissões de todos os tipos ( 700, 755, 777 e nada ), estou começando a desconfiar da release do samba para o centos já que as mesmas configurações funcionam no fedora ...

  4. brother

    pq vc usa %G.bat ?


    %G = grupo primario do usuario...
    e por que não ...

    %U = usuario

    1 ) substitua o %G.bat
    pou um_nome_qualquer.bat
    veja se funciona primeiro...
    tenta ai cara...
    posta ai depois se deu certo
    acho que é isso!



  5. Bem, no meu caso usei o Redhat, que por sinal e o mesmo
    Kernell do Fedora... e agora e da mesma empresa, bem, comigo
    deu certo.. realmente pode ser o sistema, ja tive esses problema
    o que me salvou foi o Fedora e Debian...

    Boa Sorte...






Tópicos Similares

  1. cliente samba não executa script de logon
    Por buribai no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-11-2006, 12:54
  2. Script de Logon nao funciona em estações 98
    Por fredera no fórum Servidores de Rede
    Respostas: 7
    Último Post: 22-03-2005, 08:50
  3. Problemas na com script de logon por usuário
    Por d00m no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-07-2004, 10:20
  4. Script de logon.
    Por andunno no fórum Servidores de Rede
    Respostas: 3
    Último Post: 07-06-2004, 17:04
  5. script de logon
    Por 1c3m4n no fórum Servidores de Rede
    Respostas: 8
    Último Post: 05-11-2002, 18:34

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L