Página 1 de 5 12345 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Limitando o tamanho de download (dropando ou aceitando) - CATVBRASIL

    Bom, sei que estou meio sumido, devido problemas particulares, mas como sempre estou por ae, prestando aquele excelente suporte, treinamentos e etc...

    Segue uma dica para aqueles usuários que desejam controlar ou dropar arquivos de acordo com o tamanho.

    função: CONNECTION BYTES

    Funciona assim:

    0 (zero no início) = apartir de (0-500000 = apartir de 0k até 500k)
    0 (zero no final) = infinito (500000-0 = apartir de 500k para cima)

    Vamos supor que desejamos aceitar conexões com no máximo 500k, ficaria assim:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 connection-bytes=0-500000 \
    action=accept comment="" disabled=no

    Vamos supor que desejamos rejeitar todas as outras conexões acima de 500k, ficaria assim:

    Versão 2.9.xx:

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-4294967295 \
    action=drop comment="" disabled=no

    Versão 3.xx

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-0 \
    action=drop comment="" disabled=no


    Vamos supor agora que desejamos rejeitar apenas conexões acima de 500k para um usuário ou um grupo de usuários, ficaria assim:

    Versão 2.9.xx:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-4294967295 src-address-list=no_download \
    action=drop comment="" disabled=no

    /ip firewall address-list
    add list=no_download address=10.0.0.1 comment="" disabled=no


    Versão 3.xx:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-0 src-address-list=no_download \
    action=drop comment="" disabled=no

    /ip firewall address-list
    add list=no_download address=10.0.0.1 comment="" disabled=no

    Lembrando que essa mesma dica, você pode fazer outras coisas interessantes, como, marcar conexões de acordo com o tamanho e colocar em uma QOS com prioridades e bandas e disciplinas diferentes, entre outras coisas que a imaginação mandar!!


    Fica essa dica simples, porém que parece muito complexa para muitos aqui (tenho acompanhado os tópicos!!). Qualquer dúvida estamos por ae...

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    e ai David? levou uma sumida grande.... hehehehe

    qq coisa estamos na area tb.



  3. #3

    Padrão

    Citação Postado originalmente por sergio Ver Post
    e ai David? levou uma sumida grande.... hehehehe

    qq coisa estamos na area tb.
    Valeu Sergio!!! Obrigado pelo apoio!!

    PS: te mandei em msn privada...

  4. #4



  5. #5

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Bom, sei que estou meio sumido, devido problemas particulares, mas como sempre estou por ae, prestando aquele excelente suporte, treinamentos e etc...

    Segue uma dica para aqueles usuários que desejam controlar ou dropar arquivos de acordo com o tamanho.

    função: CONNECTION BYTES

    Funciona assim:

    0 (zero no início) = apartir de (0-500000 = apartir de 0k até 500k)
    0 (zero no final) = infinito (500000-0 = apartir de 500k para cima)

    Vamos supor que desejamos aceitar conexões com no máximo 500k, ficaria assim:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 connection-bytes=0-500000 \
    action=accept comment="" disabled=no

    Vamos supor que desejamos rejeitar todas as outras conexões acima de 500k, ficaria assim:

    Versão 2.9.xx:

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-4294967295 \
    action=drop comment="" disabled=no

    Versão 3.xx

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-0 \
    action=drop comment="" disabled=no


    Vamos supor agora que desejamos rejeitar apenas conexões acima de 500k para um usuário ou um grupo de usuários, ficaria assim:

    Versão 2.9.xx:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-4294967295 src-address-list=no_download \
    action=drop comment="" disabled=no

    /ip firewall address-list
    add list=no_download address=10.0.0.1 comment="" disabled=no


    Versão 3.xx:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-0 src-address-list=no_download \
    action=drop comment="" disabled=no

    /ip firewall address-list
    add list=no_download address=10.0.0.1 comment="" disabled=no

    Lembrando que essa mesma dica, você pode fazer outras coisas interessantes, como, marcar conexões de acordo com o tamanho e colocar em uma QOS com prioridades e bandas e disciplinas diferentes, entre outras coisas que a imaginação mandar!!


    Fica essa dica simples, porém que parece muito complexa para muitos aqui (tenho acompanhado os tópicos!!). Qualquer dúvida estamos por ae...


    Obrigado amigo, valeu mesmo por nos ajudar em nossa duvidas "corriqueira", uma solução bem simple e eu aki quebrando a cabeça, valeu mesmo

  6. #6

    Padrão

    Catv, se em lugar de bloquear acima de determinado tamanho, quizer limitar a velocidade de download de arquivos maiores não baseado no tempo como o burst faz, mas sim pelo tamanho do arquivo, o caminho seria parecido com este?

    Por ex. arquivos até 1000k teria uma velocidade privilegiada. Dai até 5000k uma velocidade menor e acima disso uma velocidade menor ainda.



  7. #7

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    Catv, se em lugar de bloquear acima de determinado tamanho, quizer limitar a velocidade de download de arquivos maiores não baseado no tempo como o burst faz, mas sim pelo tamanho do arquivo, o caminho seria parecido com este?

    Por ex. arquivos até 1000k teria uma velocidade privilegiada. Dai até 5000k uma velocidade menor e acima disso uma velocidade menor ainda.
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Pack full" connection-bytes=0-500000 disabled=no dst-port=80 new-connection-mark=PackFull passthrough=\
    yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no new-connection-mark=PackFull passthrough=yes protocol=tcp \
    src-port=80
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no new-connection-mark=PackFull passthrough=yes protocol=tcp \
    src-port=53
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no new-connection-mark=PackFull passthrough=yes protocol=udp \
    src-port=53
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no dst-port=53 new-connection-mark=PackFull passthrough=yes \
    protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no dst-port=53 new-connection-mark=PackFull passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=PackFull disabled=no new-packet-mark=PackFullMARK passthrough=yes
    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface="ether1 - Nano Branco" \
    limit-at=0/0 max-limit=10000000/10000000 name=PACKFULL packet-marks=PackFullMARK parent=none priority=8 queue=default-small/default-small total-queue=\
    default-small
    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    Última edição por j34nsch; 10-03-2009 às 10:25.

  8. #8

    Padrão

    David "Shrek" CATV,
    sumido mesmo heim...

    Só uma dúvida. Dessa forma que você colocou, suponto dropar os download maiores, os pacotes pra chegar a um tamanho que definiu, por exemplo 1M, o arquivo vai ser baixado até 1023K e somente depois ser dropado correto?

    []'s



  9. #9

    Padrão

    Citação Postado originalmente por brenovale Ver Post
    David "Shrek" CATV,
    sumido mesmo heim...

    Só uma dúvida. Dessa forma que você colocou, suponto dropar os download maiores, os pacotes pra chegar a um tamanho que definiu, por exemplo 1M, o arquivo vai ser baixado até 1023K e somente depois ser dropado correto?

    []'s
    Sim, ele começa a dropar após o valor que você especificar. Se especificar para dropar aparti de 1mb, e o cliente baixar um arquivo de 10mb, ele conseguirá baixar até 1mb (aproximadamente), sendo dropado e download cancelado.

  10. #10

    Padrão

    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encia das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tade o https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1000000-0, ai vc vai liberar os pacotes maiores que 100k

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    Muito bom!

    Só lembrando:

    1 = 1 byte
    10 = 10 bytes
    100 = 100 bytes
    1000 = 1k
    10000 = 10k
    100000 = 100k
    1000000 = 1MB
    10000000 = 10MB
    100000000 = 100MB


    Simples, mas as vezes o pessoal se confunde.



  11. #11

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Muito bom!

    Só lembrando:

    1 = 1 byte
    10 = 10 bytes
    100 = 100 bytes
    1000 = 1k
    10000 = 10k
    100000 = 100k
    1000000 = 1MB
    10000000 = 10MB
    100000000 = 100MB


    Simples, mas as vezes o pessoal se confunde.

    valeu pelo toque, são muitos zeros rsrsrs, as vezes agente se atrapalha

    já ta corrigido

    T+
    Última edição por j34nsch; 10-03-2009 às 10:26.

  12. #12

    Padrão

    Citação Postado originalmente por j34nsch Ver Post

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    Ajudo sim.
    É isso mesmo, deixar o assinante feliz.
    Já notei que a maioria só ocupa a banda para navegação "normal".
    Estou planejando uma cartilha para o assinante, onde alguns pontos serão considerados a respeito de banda. Principalmente ver se consigo educar o povo no envio e recepção de imagens no MSN. Tem gente que coloca as fotos com toda a qualidade possivel, achando que assim vai ser visto melhor.
    Quando ele estiver consciente disso ele mesmo vai propagar a idéia para os seus adicionados, pois assim ele recebe também mais ligeiro, ficando dentro deste limite de maior velocidade.
    Valeu mesmo.



  13. #13

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    Ajudo sim.
    É isso mesmo, deixar o assinante feliz.
    Já notei que a maioria só ocupa a banda para navegação "normal".
    Estou planejando uma cartilha para o assinante, onde alguns pontos serão considerados a respeito de banda. Principalmente ver se consigo educar o povo no envio e recepção de imagens no MSN. Tem gente que coloca as fotos com toda a qualidade possivel, achando que assim vai ser visto melhor.
    Quando ele estiver consciente disso ele mesmo vai propagar a idéia para os seus adicionados, pois assim ele recebe também mais ligeiro, ficando dentro deste limite de maior velocidade.
    Valeu mesmo.

    amigo legal sua ideia vamos desenvolver isso no forum, todos temos uma ideia e podendo até virar um WIKI, assim informamos o pessoal que navega na internet e tb nossos clientes, gostei mesmo T+

  14. #14

    Padrão

    amigos estou colocando aki uma imagem com o sistema fazendo a liberação em 500k, ao contrario do que eu pensava não aumentou somente em 10% do consumo do link, a velocidade dos cliente ficou muito boa e o volume total de download no queues ele chega a ficar em 5º lugar do meu queues, ficou muito bom, alguem mais experimentou?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         img_liberado_conexao.jpg
Visualizações:	669
Tamanho: 	230,7 KB
ID:      	3746  



  15. #15

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    Ajudo sim.
    É isso mesmo, deixar o assinante feliz.
    Já notei que a maioria só ocupa a banda para navegação "normal".
    Estou planejando uma cartilha para o assinante, onde alguns pontos serão considerados a respeito de banda. Principalmente ver se consigo educar o povo no envio e recepção de imagens no MSN. Tem gente que coloca as fotos com toda a qualidade possivel, achando que assim vai ser visto melhor.
    Quando ele estiver consciente disso ele mesmo vai propagar a idéia para os seus adicionados, pois assim ele recebe também mais ligeiro, ficando dentro deste limite de maior velocidade.
    Valeu mesmo.
    Tem gente que tira foto em 2560x1920 sei la... e quer upar rapido no orkut, não consegue e fica falando que a net tá uma [email protected]

  16. #16

    Padrão

    É... a coisa fluiu melhor do que parecia.. rsss



  17. #17

    Padrão

    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    Vou testar asssim como sugeriu.

    Mas se quizer criar além desta, uma terceira opção de banda, como sugeri para o Catv, seria só repetir a regra com os valores de k alterados?

    Assim: limito em 1.000.000 bytes com uma velocidade bem alta, e dái em vêz de baixar para a velocidade contratada, dá mais um fôlego para o download até 5.000.000 bytes com uma velocidade intermediária.

  18. #18
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    Apareceu a Margarida. rsrsrs

    Bom a sua volta!!!



  19. #19

    Padrão

    Isso ai meu garoto...Estava fazendo falta aqui!!!

  20. #20

    Padrão

    gostaria de saber como fica o cliente que quiser baixar um arquivo de 10 megas ou mesmo mais, quer dizerque ele nao ira conseguir certo, ou mesmo fazer um upgrade do windows como ficaria isso, gostaria de entender melhor desculpa nao entender mas e perguntando que se aprende.