+ Responder ao Tópico



  1. Estou com um problema na execução de scripts pelo mikrotik. Crio um novo script e consigo salva-lo normalmente. Porém o script não inicia, o contador fica parado em 0 e nunca sai9 mesmo quando eu mando um RUN nele. Ja tentei criar outros script como de bakup e etc... mas faz a mesma coisa: o script nunca inicia.

  2. Mostra o script fica mais facil para ajuda-lo. Talvez seja necessário alguma correção.



  3. MK 2.9.27

    O script tá assim:

    :log info "DDNS: Begin"
    :global ddns-user "*****"
    :global ddns-pass "******"
    :global ddns-host "******"
    :global ddns-interface "VELOX"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    Qualquer outro script tb dá o mesmo erro. O contador não sai do zero.

  4. Eu usava a versao 2.9.27 cracked e os scripts não funcionavam ae troquei pela versao 2.9.51 e registrada, ficou tudo perfeito.



  5. A minha versão 2.9.27 é registrada (do cliente na verdade). Tenho essa mesma versão tb registrada em outro servidor e funciona normalmente.






Tópicos Similares

  1. Erros no script de Firewall depois da migracao
    Por phacam no fórum Servidores de Rede
    Respostas: 6
    Último Post: 19-05-2005, 16:57
  2. erro no script
    Por WhiteTiger no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 13-05-2005, 11:06
  3. Erro estranho no script de backup
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 22-02-2005, 08:49
  4. Erro no script Firewall
    Por danielvbhp no fórum Servidores de Rede
    Respostas: 5
    Último Post: 01-02-2004, 09:33
  5. Erro de parâmetro no Script logon.bat
    Por ATNunes no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-12-2002, 10:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L