+ Responder ao Tópico



  1. Pessoal,

    Boa noite. Eu estou já há algumas noites sem dormir direito por causa de uma conexão VPN que eu não estou conseguindo fazer.

    Estou tentando conectar um watchguard edge em um strongswan.

    É possível fazer conexão VPN entre os dois?

    Não estou muito familiarizada com VPN e, mesmo lendo vários howtos e manuais eu estou apanhando bastante.

    O maior problema de todos é que eu não posso mudar as configs do watchguard edge, pois está em outro estado... então eu tenho que usar as configs que me passaram e configurar o strongswan aqui.

    Estas são as configurações que me passaram:

    Phase 1 Settings
    ----------------
    Mode: Agressive Mode
    Authentication Algorithm: SHA1-HMAC
    Encryption Algorithm: DES-CBC
    Diffie-Helman Group: 1

    Phase 2 Settings
    ----------------
    Authentication Algorithm: SHA1-HMAC
    Encryption Algorithm: DES-CBC
    Enable PFS

    As minhas dúvidas são:

    keyexchange=ikev1
    esp= ? (não sei o que usar)
    pfs=yes
    pfsgroup= ? (não sei o que usar)
    compress=no
    authby=secret
    ike= ? (não sei o que usar)

    No ipsec.secrets eu já coloquei os dois hosts e a PSK.

    Por favor, qualquer ajuda é bem vinda!

    Em tempo... se alguém puder, também, me indicar uma literatura que explique bem isso tudo (e-book, link, howto, psicografia) que me ajude a entender, eu agradeço!

    Beijos!
    Tica

  2. Última edição por Magal; 17-03-2009 às 00:21.



  3. Oi Magal,

    Bom dia!!!!!

    Esqueci de colocar as configs que eu estou testando na "conn teste".

    Eu já li bastante coisa do site do strongswan nas últimas semanas... é a segunda vez que eu tento fazer VPN... na primeira vez eu desencanei porque o adm do outro escritório deixou escapar que não queria ajudar "usuária" de linux... hehehe

    Olha só a conn teste (só mudei os endereços IP válidos, ok?)

    conn teste
    keyexchange=ikev1
    ike=3des-sha-modp1024
    ikelifetime=43200s
    esp=3des-sha1
    pfs=yes
    pfsgroup=modp1024
    compress=no
    authby=secret
    left=200.200.200.200
    leftsubnet=10.1.1.0/24
    leftfirewall=yes
    lefthostaccess=yes
    right=201.201.201.201
    rightsubnet=192.168.0.0/24
    auto=start

    Os parametros ide, esp, pfs e pfsgroup estão de acordo com as configs que me passaram?

    Phase 1 Settings
    ----------------
    Mode: Agressive Mode
    Authentication Algorithm: SHA1-HMAC
    Encryption Algorithm: DES-CBC
    Diffie-Helman Group: 1

    Phase 2 Settings
    ----------------
    Authentication Algorithm: SHA1-HMAC
    Encryption Algorithm: DES-CBC
    Enable PFS

    Brigadinha e beijos!






Tópicos Similares

  1. Vendo servidor Dell Power Edge T100 com Myauth instalado
    Por fabcia no fórum Servidores de Rede
    Respostas: 4
    Último Post: 08-11-2011, 08:50
  2. Duas dúvidas com StrongSwan
    Por ticagugino no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-09-2009, 03:29
  3. Dell Power Edge 1900...
    Por terencerocha no fórum Sistemas Operacionais
    Respostas: 6
    Último Post: 02-04-2008, 09:33
  4. vpn client fedora 7 para vpn server watchguard
    Por doug_chagas no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-06-2007, 08:57
  5. Debian Sarge 3.1 r3 + Servidor Dell Power Edge 1900! Nao instala!
    Por tokio18 no fórum Sistemas Operacionais
    Respostas: 5
    Último Post: 19-02-2007, 16:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L