+ Responder ao Tópico



  1. Bom pessoal,
    Existe uma dúvida quanto criar planos de acesso no mikrotik relacionado a horário e dias. Vamos fazer um sistema de planos usando o hotspot.

    Obs.: Creio que o seu servidor esteja devidamente configurado e funcionando.

    O cenário atual é:
    Temos um plano que o usuário só tem acesso das 12 às 00hs.

    Criem uma pagina(planoblock.html) para avisá-lo que o plano está fora do horário, para quando ele for acessar antes das 12hs e depois das 00hs.

    Profiles users
    Criem um profile com a velocidade e as atribuições do plano.
    Código :
    /ip hotspot user profile add name="unblock" keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=no

    Criem um profile para bloqueá-lo:
    Código :
    /ip hotspot user profile add name="block" session-timeout=15s idle-timeout=15s keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=planoblock.html advertise-interval=1s advertise-timeout=never

    Scripts
    Criem o script que vai bloqueá-lo:
    Código :
    /system script add name="block_usuario" policy=ftp,reboot,read,write,policy,test,winbox,password source=/ip hotspot user set "usuario" profile=block;

    Criem o scritp para desconectá-lo, caso esteja conectado:
    Código :
    /system script add name="remove_active" policy=ftp,reboot,read,write,policy,test,winbox,password source= /ip hotspot active remove [/ip hotspot active find user="usuario"];

    Criem o script para desbloqueá-lo:
    Código :
    /system script add name="unblock_usuario" policy=ftp,reboot,read,write,policy,test,winbox,password source=/ip hotspot user set "usuario" profile=unblock;

    Schedulers
    Criem o scheduler para bloqueá-lo as 00hs:
    Código :
    /system scheduler add name="block-00hs" on-event=block_usuario start-date=jan/01/1970 start-time=00:00:01 interval=1d

    Criem um para desconectá-lo:
    Código :
    /system scheduler add name="remove-00hs" on-event=unblock_usuario start-date=jan/01/1970 start-time=00:00:05 interval=1d

    Criem um para desbloqueá-lo:
    Código :
    /system scheduler add name="unblock-12hs" on-event=unblock_usuario start-date=jan/01/1970 start-time=12:00:01 interval=1d

    Bom pessoal, fizemos aqui um plano de 12hs. A partir disso é possível criar vários e vários profiles.
    Qualquer erro de digitação ou outro informe. Dúvidas, sugestões e críticas serão bem-vindas.

  2. mas onde tem "usuario", seria o nome do login do cliente né, então cada usuario teria que ter os script e scheduler, e no final de semana teria que fazer outro script para o mesmo fim?
    Última edição por multlink; 20-03-2009 às 07:31.



  3. Isto mesmo.

  4. complicadinho eim rs



  5. Estou usando aqui esse script...e está funcionando, obrigado irmao.






Tópicos Similares

  1. Respostas: 4
    Último Post: 26-02-2015, 06:41
  2. Problemas com backup no mikrotik usando wine
    Por Luarline no fórum Redes
    Respostas: 8
    Último Post: 04-01-2011, 09:31
  3. Duvidas para Criar Rotas no Mikrotik
    Por Jonatanmcc no fórum Redes
    Respostas: 4
    Último Post: 25-04-2008, 05:21
  4. Como Criar Leases no Mikrotik?
    Por Trabach no fórum Redes
    Respostas: 0
    Último Post: 04-12-2007, 14:23
  5. Criar proxy no mikrotik
    Por lusuave no fórum Redes
    Respostas: 10
    Último Post: 09-08-2007, 23:56

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L