+ Responder ao Tópico



  1. #1

    Padrão Formas de interromper downloads de clientes em horarios de pico.

    Bom pessoal,

    Gostaria da ajuda de voces para resolver um problema que venho enfrentando aqui.
    Tenho um pequeno provedor em que o Link é via Satelite e com velocidades baixas de Down e Up. Para evitar que a rede pára quando um cliente faz um download eu simplesmente desabilito o web proxy e no mesmo instante habilito novamente. O resultado é que o download que o cliente estava fazendo é interrompido e assim evito que ele continue com aquele download momentaneamente.

    Obs.: Já uso o controle de banda, mas quando o cliente atinge seu limite de download o restante dos clientes ficam sem internet. Isso só acontece quando ele esta baixando um arquivo mas quando está abrido paginas ou vendo algum video nao atrapalha em nada, pode chegar em seus limites de downloads sem problemas É um problema que os Links via satelites teem com o uso do Mikrotik.

    O que gostaria mesmo era de uma regra para habilitar e desabilitar o web proxy a cada 30 minutos por exemplo, ou seja, qualquer outra regra que dá este corte na internet rapidamente. Isso nos horarios de pico. Com isso, os clientes teriam dificuldades em fazerem downloads.

    Com uma regra deste tipo resolveria parte de meus problemas com este sofrido Link que possuo.

    Caso alguem tenha uma outra sugestao semelhante a esta ficarei muito agradecido se puderem postar aqui neste topico.

    Obrigado !!

  2. #2

    Thumbs up Link Via Satelite

    ROberto, Bom dia! Camarada, tbm uso link via satelite e não tenho esse tipo de problemas, será q não tem algo errado com suas configurações no MK??

    Mas tenta isso ae:

    system script
    add name="tree_on" source="/queue tree { enable \[find name=PROXY\] \
    }" policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="tree_off" source="/queue tree { disable \[find \
    name=PROXY\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword

    queue tree
    add name=PROXY parent=global-out packet-mark=semlimite limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=yes

    system scheduler
    add name="Habilita_tree" on-event=tree_on start-date=dec/14/2007 \
    start-time=00:00:00 interval=4m comment="" disabled=no
    add name="JDesbilita_tree" on-event=tree_off start-date=dec/14/2007 \
    start-time=00:00:00 interval=39s comment="" disabled=no

    So não esqueça de adequar a sua configuração!!

    Flw



  3. #3
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Já deu uma olhada neste post do Catv, seria uma forma interessante pra você, em horario de pico limitar o tamanho do arquivo de download..

    Limitando o tamanho de download (dropando ou aceitando) - CATVBRASIL-


    Citação Postado originalmente por ROBERTO123 Ver Post
    Bom pessoal,

    Gostaria da ajuda de voces para resolver um problema que venho enfrentando aqui.
    Tenho um pequeno provedor em que o Link é via Satelite e com velocidades baixas de Down e Up. Para evitar que a rede pára quando um cliente faz um download eu simplesmente desabilito o web proxy e no mesmo instante habilito novamente. O resultado é que o download que o cliente estava fazendo é interrompido e assim evito que ele continue com aquele download momentaneamente.

    Obs.: Já uso o controle de banda, mas quando o cliente atinge seu limite de download o restante dos clientes ficam sem internet. Isso só acontece quando ele esta baixando um arquivo mas quando está abrido paginas ou vendo algum video nao atrapalha em nada, pode chegar em seus limites de downloads sem problemas É um problema que os Links via satelites teem com o uso do Mikrotik.

    O que gostaria mesmo era de uma regra para habilitar e desabilitar o web proxy a cada 30 minutos por exemplo, ou seja, qualquer outra regra que dá este corte na internet rapidamente. Isso nos horarios de pico. Com isso, os clientes teriam dificuldades em fazerem downloads.

    Com uma regra deste tipo resolveria parte de meus problemas com este sofrido Link que possuo.

    Caso alguem tenha uma outra sugestao semelhante a esta ficarei muito agradecido se puderem postar aqui neste topico.

    Obrigado !!

  4. #4

    Padrão

    Citação Postado originalmente por Sloth Ver Post
    ROberto, Bom dia! Camarada, tbm uso link via satelite e não tenho esse tipo de problemas, será q não tem algo errado com suas configurações no MK??

    Mas tenta isso ae:

    system script
    add name="tree_on" source="/queue tree { enable \[find name=PROXY\] \
    }" policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="tree_off" source="/queue tree { disable \[find \
    name=PROXY\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword

    queue tree
    add name=PROXY parent=global-out packet-mark=semlimite limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=yes

    system scheduler
    add name="Habilita_tree" on-event=tree_on start-date=dec/14/2007 \
    start-time=00:00:00 interval=4m comment="" disabled=no
    add name="JDesbilita_tree" on-event=tree_off start-date=dec/14/2007 \
    start-time=00:00:00 interval=39s comment="" disabled=no

    So não esqueça de adequar a sua configuração!!

    Flw
    Olá Sloth,

    Agradeco pela resposta..

    Se puder me explicar melhor o que realmente significa estas regras que tem em seu servidor ficaria muito grato pois poderia está ai a solucao para meu problema. Esta regra na Queue tree por exemplo nao possuo....

    Obrigado amigo !



  5. #5

    Padrão

    Citação Postado originalmente por ddllss Ver Post
    Já deu uma olhada neste post do Catv, seria uma forma interessante pra você, em horario de pico limitar o tamanho do arquivo de download..

    Limitando o tamanho de download (dropando ou aceitando) - CATVBRASIL-
    Olá ddllss,

    Já olhei este post do CATVBrasil, segui todos os passos mas nao consegui fazer funcionar. Criava as regras mas estas nao obedeciam os limites criados por mim.

    Muito Grato !

  6. #6

    Thumbs up Regras

    Bom dia!! Olha só, acredito q seu problema possa ser CONGESTIONAMENTO da sua rede ou DEFICIENCIA de equipamento, essas regras servem para descongestionar sua rede qdo usado com WEBPROXY. Vamos supor q vc tem um cliente fazendo download, baixando na velocidade contratada, em um exemplo de 10K/s, se o arquivo for de 35 megas, o tempo q ele estiver baixando causara um trafego constante no servidor, nos ap´s, no swicht, etc..., imagine uns dez clientes fazendo o memso download, que pode acontecer no caso de antivirus, com essa regra ele vai disponibilzar o download com uma banda superior pra poder enxugar a rede entregando o arquivo o mais rapido possivel deixando assim o trafego nomal na rede.

    Mas olha, existe regras melhores aqui no forum de gente q realmente sabe a fundo o MK.

    Espero ter ajudado.

    Flw