Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Question Roteamento: duas redes Internet/Sistema

    Tenho dois gateways, um é o Embratel, que interliga sistemas da empresa. Outro da Velox fará apenas a conexão com a internet porta 80...

    Estou usando o Suse 10.
    No servidor as portas estão assim configuradas.

    eth0= 192.168.254.3 gw 192.168.254.254 velox
    eth1= 192.168.10.1 gw 192.168.10.200 embratel

    Tentei fazer a seguinte configuração em um script:
    (...)
    ip rule add fwmark 3 table 30 prio 20
    ip rule add from 192.168.254.254 table 30 prio 20
    ip route add default via 192.168.254.254 dev eth0 table 30

    ip rule add fwmark 2 table 20 prio 20
    ip rule add from 192.168.10.200 table 20 prio 20
    ip route add default via 192.168.10.200 dev eth1 table 20

    iptables -t mangle -A PREROUTING -j MARK --set-mark 2
    iptables -t mangle -A PREROUTING -p tcp --dport 80 -j MARK --set-mark 3

    ip rule add fwmark 1 lookup 20
    ip rule add fwmark 1 lookup 30

    ip route flush cached
    (...)
    Nas máquinas que coloco o gateway 192.168.10.1 as mesmas continuam usando a internet via o gateway da embratel.

    Tentei também:
    iptables -t nat -A POSTROUTING -s 192.168.10.0/24 -p tcp --dport 80 -j SNAT -
    -to-source 192.168.254.254:80
    iptables -t nat -A POSTROUTING -s 192.168.10.0/24 -p tcp --dport 8080 -j SNAT
    --to-source 192.168.254.254:8080

    Nesse caso não acessa nada.


    Alguém já passou por essa situação, ajude-me. Ficarei grato

  2. #2

    Padrão

    iptables -t nat -A POSTROUTING -s 192.168.10.0/24 -p tcp --dport 80 -j SNAT -
    -to-source 192.168.254.254:80
    iptables -t nat -A POSTROUTING -s 192.168.10.0/24 -p tcp --dport 8080 -j SNAT
    --to-source 192.168.254.254:8080
    Ta certo esse trecho do iptables, vc ta pegando o endereço de uma rede (embratel) e ta colocando como origem o gateway da velox.
    Quando o tráfego voltar da internet ele vai vim pela velox, as máquinas da rede 192.168.10.0/24 estão também na rede 192.168.254.3?

    Por que se não, como eles vão receber o tráfego que vem pra eles, mas endereçado a outra rede...



  3. #3

    Exclamation

    Citação Postado originalmente por kairok Ver Post
    Ta certo esse trecho do iptables, vc ta pegando o endereço de uma rede (embratel) e ta colocando como origem o gateway da velox.
    Quando o tráfego voltar da internet ele vai vim pela velox, as máquinas da rede 192.168.10.0/24 estão também na rede 192.168.254.3?

    Por que se não, como eles vão receber o tráfego que vem pra eles, mas endereçado a outra rede...
    Obrigado pela resposta.

    Na rede do Velox somente estará o Modem ligada diretamente a placa do servidor, em que as máquinas da rede 192.168.10.0/24 não irá pingá-lo e vice-versa.

  4. #4

    Padrão

    eu vi muito numero ali e acabei cansando..
    esclareça apenas o que vc quer, de maneira bem simples, para que eu possa entender; será que é:

    "tenho dois links, gostaria que TUDO que seja http (porta 80) saia pelo 1 e todo o resto, exceto http, saia pelo 2".

    é isso? se não for, tente me fazer entender assim: curto e simples.




  5. #5

    Arrow

    Citação Postado originalmente por irado Ver Post
    eu vi muito numero ali e acabei cansando..
    esclareça apenas o que vc quer, de maneira bem simples, para que eu possa entender; será que é:

    "tenho dois links, gostaria que TUDO que seja http (porta 80) saia pelo 1 e todo o resto, exceto http, saia pelo 2".

    é isso? se não for, tente me fazer entender assim: curto e simples.

    Resumo: Internet porta 80 vá pelo Velox (eth0: 192.168.254.3 ; gw 192.168.254.254), demais conexões de saída vá pela Embratel (eth1: 192.168.10.1 ; gw 192.168.10.200

  6. #6



  7. #7

    Padrão

    Foi a partir desse que montei o script do 1º post, que não obtive sucesso.

    Continuo testando e estudando! Obrigado pela Colaboração.

  8. #8



  9. #9

    Padrão

    Balanceamento de carga entre links com iproute2 - mini-howto

    Se seguir a risca o que está escreito, funciona.

    Você não está configurando as redes locais nas tabelas de rotemento.

  10. #10

    Question

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    Balanceamento de carga entre links com iproute2 - mini-howto

    Se seguir a risca o que está escreito, funciona.

    Você não está configurando as redes locais nas tabelas de rotemento.
    Obrigado Pedro, mas ainda não consegui.
    Veja o script que montei a partir do seu tutorial:

    LNTW0='192.168.254.0/24'
    LNTW1='192.168.10.0/24'
    LIF0='eth0'
    LIF1='eth1'
    LIP0='192.168.254.3'
    LIP1='192.168.10.1'
    LGW0='192.168.254.254'
    LGW1='192.168.10.200'
    echo 10 tb0 >> /etc/iproute2/rt_tables
    echo 11 tb1 >> /etc/iproute2/rt_tables
    ip route add $LNTW0 dev $LIF0 src $LIP0 table tb0
    ip route add to 0/0 via $LGW0 table tb0
    ip route add $LNTW1 dev $LIF1 src $LIP1 table tb1
    ip route add to 0/0 via $LGW1 table tb1
    ip route add $LIP0 dev $LIF0 table tb0
    ip route add $LIP1 dev $LIF1 table tb1
    ip route add $LNTW0 dev $LIF0 src $LIP0
    ip route add $LNTW1 dev $LIF1 src $LIP1
    ip rule add from $LIP0 table tb0
    ip rule add from $LIP1 table tb1
    ip route add to 0/0 nexthop via $LGW0 dev $LIF0 weight 1 nexthop via $LGW1 dev $LIF1 weight 1
    ip rule add from $LNTW0 table tb0
    ip rule add from $LNTW1 table tb1
    iptables -t mangle -A PREROUTING -i $LIP1 -p tcp --dport 80 -j MARK --set-mark 0x60
    ip rule add fwmark 0x60 table tb0

    Continuo acessando tudo via Embratel
    traceroute to Under-Linux.Org O Portal do Administador de Sistemas (74.86.235.216), 30 hops max, 40 byte packets
    1 192.168.10.200 2.707 ms 2.946 ms 1.825 ms
    (...)

    Comando route:
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.10.0 * 255.255.255.0 U 0 0 0 eth1
    192.168.254.0 * 255.255.255.0 U 0 0 0 eth0
    link-local * 255.255.0.0 U 0 0 0 eth0
    loopback * 255.0.0.0 U 0 0 0 lo
    default 192.168.10.200 0.0.0.0 UG 0 0 0 eth1

    Seria algum problema nas configurações do gw default de rede?

    Se tiver algo errado aí, por favor corrija.

    Grato.



  11. #11

    Padrão

    Citação Postado originalmente por valdiclei Ver Post
    LGW0='192.168.254.254'
    LGW1='192.168.10.200'
    Esses deveriam ser os gateways dos seus links...

    Se você mudar isso, seu script estará quase identico ao meu...

  12. #12

    Question

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    Esses deveriam ser os gateways dos seus links...

    Se você mudar isso, seu script estará quase identico ao meu...
    Coloco os dois gw como Default, ou coloco um gw para cada placa, e qual ficaria como default?



  13. #13

    Padrão

    Citação Postado originalmente por valdiclei Ver Post
    Coloco os dois gw como Default, ou coloco um gw para cada placa, e qual ficaria como default?
    Você tem quatro ou três placas de rede, né isso? Duas para os links com os provedores e duas/uma para a rede local, certo? E essa máquina que está configurando é o roteador/gateway da rede, né isso?

    Digamos que vocÊ queira que as requisições da LNTW0 saia pelo link 0, então o LGW0 deve ser o gateway desse link. Isso você configura na tabela pela qual quer que a LNTW0 passe. E assim sucessivamente.

  14. #14

    Cool

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    Você tem quatro ou três placas de rede, né isso? Duas para os links com os provedores e duas/uma para a rede local, certo? E essa máquina que está configurando é o roteador/gateway da rede, né isso?

    Digamos que vocÊ queira que as requisições da LNTW0 saia pelo link 0, então o LGW0 deve ser o gateway desse link. Isso você configura na tabela pela qual quer que a LNTW0 passe. E assim sucessivamente.
    Tenho duas placas de rede... eth0 (velox), eth1 (embratel)
    Nas configuração está o gateway default como o da embratel (192.168.10.200)
    route:
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.10.0 * 255.255.255.0 U 0 0 0 eth1
    192.168.254.0 * 255.255.255.0 U 0 0 0 eth0
    link-local * 255.255.0.0 U 0 0 0 eth0
    loopback * 255.0.0.0 U 0 0 0 lo
    default 192.168.10.200 0.0.0.0 UG 0 0 0 eth1

    Vou tentar colocar para cada placa o seu gw, e realizar testes....

    Obrigado pela colaboração.



  15. #15

    Padrão

    Rapaz, eu me embaralhei todo agora...

    Você está tentando configurar com apenas duas placas de rede na máquina? VocÊ não tem duas placas para receber os links? E o IPs gateways dos links, não deveriam ser IPs válido?

  16. #16

    Lightbulb

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    Rapaz, eu me embaralhei todo agora...

    Você está tentando configurar com apenas duas placas de rede na máquina? VocÊ não tem duas placas para receber os links? E o IPs gateways dos links, não deveriam ser IPs válido?
    Isso. Estou tentando configurar com duas placas.... Uma ligada diretamente no modem do Velox com faixa de ip 192.168.254.0/24, e outra ligada a rede local com faixa 192.168.10.0/24, em que todas as máquinas da rede já estão nessa faixa.

    Não são Ips Válidos.... um IP é do Velox, cujo o modem já está ajustado para conexão direta, e outro IP vem de um roteador da Embratel que faz conexão com outras unidades da empresa.

    Resumindo: Pretendo que as máquinas da rede e o servidor (pois tb será proxy) ao requisitarem acesso a internet, usando como gw 192.168.10.1 (este servidor) vá pelo velox e demais solicitações vá pelo gateway da embratel 192.168.10.200.

    Será que compliquei mais.. rs.

    Obrigado pela ajuda.



  17. #17

    Padrão

    um diagrama ajudaria... Veja o Dia...

  18. #18

    Padrão

    Citação Postado originalmente por PEdroArthurJEdi Ver Post
    um diagrama ajudaria... Veja o Dia...
    Opa brother! Veja o diagrama:

    http://img9.imageshack.us/img9/6879/imagemqmx.jpg



  19. #19

    Padrão

    Valdiclei ele quiz dizer diagrama de rede, mas enfim, sua rede é algo +/- assim?:

    http://img22.imageshack.us/img22/5382/35509000.jpg

    Espero que ajude

  20. #20

    Padrão

    Ei cara, não esqueci de sua resposta, mas é que ando um pouco ocupado. Mas assim que estiver mais disponível, volto pra te ajudar, beleza? Esse sábado dou uma olhada a fundo no seu diagrama e lhe passo uma possível configuração, pode ser?

    Abraço!