Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Exclamation Duvidas no webproxy em paralelo com debian

    Boa tarde, tenhho muito problema em fazer o proxy paralelo no debian...
    as conf.. eh o seguinte..

    ■ Como de costume, eu renomei as interfaces:

    /interface set ether1 name=internet
    /interface set ether2 name=rede
    /interface set ether3 name=linux



    Passo 2:
    ■ Ajustar os ips das interfaces:

    /ip address add address=10.0.0.138/24interface=internet
    /ip address add address=10.10.1.1/24 interface=rede
    /ip address add address=15.15.0.1/30 interface=linux


    Depois abrir o webbox.. e configurei a interface internet... para receber DHCP do modem roteado.

    Crie o hotspot, configurando ja a parte de firewall do nat

    /ip firewall nat add chain=srcnat src-address=10.10.1.0/24 action=masquerade comment="Masquerade para rede mikrotik-cliente"
    /ip firewall nat add chain=srcnat src-address=15.15.0.0/30 action=masquerade comment="Masquerade para a rede mikrotik-linux"


    com isso já era para navegar o linux ???

    no pc que configuro o mkt ele navega normal mais qndo passo para o debian, nda de navegar...

    ja segui varios tutoriais mais sempre impaco na mesma coisa.. o debian naum navega nen com reza brabra...

    os tutu...

    Detalhando proxy paralelo com o linux

    Linux: Proxy em paralelo com o mikrotik [Artigo]


    ele pinga somente qndo o dhcp server para a classe de ip do linux esta habilitada... c naum estiver ele naum pinga ... e naum tem nenhuma comunicação...

    o debian colocamos ip fixo...

    ip-15.15.0.2
    masc-255.255.255.252
    gw-15.15.0.1
    dns-15.15.0.1

    e não navega de jeito nenhum, ja reinstalei o mikrotik do zero, reinstalei o debian do zero e da o mesmo pau, no mikrotik funciona redondo... sem nenhum pau, mais chega no debian ele não navega de jeito nenhum.

    ja testamos em arp, tambem e nda do debian navegar no micro que o winbox esta aberto.. coloquei um switch para testa em outra maquinas e funciono normal mais na interface que vai pro debian naum navega... ja fiz muita coisasss³³³

    Espero que alguem me Ajude...



    Obrigado

  2. #2

    Padrão

    Pode tá sendo problema de dns, verifique isto aí meu caro.
    Caso não dê certo, tente este aqui:
    Linux: MikroTik + Squid 2.6 com cache full [Artigo]



  3. #3

  4. #4

    Padrão

    boa tarde galera do under
    Estou tentando montar o mkt em paralelo com debian, mais sem sucesso.
    vo postar toda a configuração que fiz...
    já formatei o debian, reinstalei
    ja formatei o mikrotik .. reconfigurei e nada..
    No Mikrotik >
    Como de costume renomear as interfaces:
    /interface set ether1 name=INTERNET
    /interface set ether2 name=CLIENTES
    /interface set ether3 name=PROXY
    Ajustei os ip das interfaces seguinte
    (ate mudei as classes, mais sem sucesso)
    /ip address add address=10.0.0.138/24interface=INTERNET
    o modem esta roteado, depois disso abro o webbox, e coloco ele como DHCP
    /ip address add address=172.121.40.1/24 interface=CLIENTE
    /ip address add address=192.168.10.1/30 interface=PROXY
    Configurei o nat dos clientes pelo hotspot
    /ip firewall nat add chain=srcnat src-address=172.121.40.0/24 action=masquerade comment="CLIENTES"
    Depois configurei manualmene o do PROXY
    /ip firewall nat add chain=srcnat src-address=192.168.10.0/30 action=masquerade comment="PROXY"
    No ip> route
    Gateway: 10.0.0.138 distance 0 interface=INTERNET
    o resto veio automatico com as configurações anteriores
    destination= 10.0.0.0/24 pref.source= 10.0.0.1 interface= INTERNET (quando coloco no webbox para pegar dhcp)
    destination= 172.121.40.0/24 pref.source= 172.121.40.1 interface= CLIENTES
    destination= 192.168.10.0/24 pref.source= 192.168.10.1 interface= PROXY
    Ajustei os dns
    ip dns set primary-dns=200.204.0.10
    /ip dns static add name="CLIENTES" address=172.121.40.1
    /ip dns static add name="PROXY" address=192.168.10.1

    a INTERNET não vai de jeito nenhum para o debian, ja troquei de placa de rede, so naum troquei a maquina ainda
    ja tentei varios tutoriais e nada, estou ficando loko.
    Eu não sei se é pau do mikrotik ou do debian, acredito que seja no mikrotik porque quando eu coloco o link
    que vai pro mikrotik no debian ele pega ip e navega normal.
    Topologia feita da seguinte forma
    Link ( speedy roteado)
    |
    |
    |
    Mikrotik -------------- Proxy
    |
    |
    |
    clientes

    Os ip foi igual coloquei acima
    Link Roteado > 10.0.0.138/24
    Mikrotik > 172.121.40.1/24
    Proxy> 192.168.10.1/30
    Já fiz de tudo e o debian não navega, as 2 interfaces de saida funciona normal.
    Preciso de ajuda, espero que me ajudem...

    Obrigado a todos



  5. #5

    Padrão

    Amigo como nosso colega disse isso pode ser problema de dns:

    Um exemplo:

    cat /etc/network/interfaces
    :

    # The loopback network interface
    auto lo
    iface lo inet loopback

    iface eth2 inet static
    address 201.11.xxx.xxx
    netmask 255.255.255.0
    network 201.11.xxx.0
    broadcast 201.11.xxx.255
    gateway 201.11.xxx.xxx
    auto eth2


    cat /etc/resolv.conf :

    # generated by NetworkManager, do not edit!

    nameserver 127.0.0.1


    Neste caso eu tenho debian rodando bind9 junto. nada impede que você aponte o DNS do seu proxy para o seu MK.

    Espero ter ajudado
    Abs!

  6. #6

    Padrão

    Citação Postado originalmente por darklinux3 Ver Post
    Amigo como nosso colega disse isso pode ser problema de dns:

    Um exemplo:

    cat /etc/network/interfaces:

    # The loopback network interface
    auto lo
    iface lo inet loopback

    iface eth2 inet static
    address 201.11.xxx.xxx
    netmask 255.255.255.0
    network 201.11.xxx.0
    broadcast 201.11.xxx.255
    gateway 201.11.xxx.xxx
    auto eth2

    cat /etc/resolv.conf :

    # generated by NetworkManager, do not edit!

    nameserver 127.0.0.1

    Neste caso eu tenho debian rodando bind9 junto. nada impede que você aponte o DNS do seu proxy para o seu MK.

    Espero ter ajudado
    Abs!

    mais esses ip q na interface eh o direto com a internet ?? ou qual q ta cadastrado no mikrotik ???
    o q seria o bind9?
    obrigado
    Última edição por mktguaruja; 06-04-2009 às 00:44.



  7. #7

    Padrão

    Exato a interface eth2 estará ligada diretamente ao MK, aqueles IPs sao validos, no seu caso coloque os invalidos que citou anteriormente. Depois disso basta mascarar(compartilhar) as conexoes no mk e estara funcionando a net normalmente. O bind9 é um servidor de nomes(DNS).

    Abs!
    Última edição por darklinux3; 06-04-2009 às 09:26.

  8. #8

    Padrão

    boa tarde,

    eu tenhei fazer como vc mando no arquivos, mudava la.. mais qndo ia em informações na conexao da ip 169 .... bla bla bla...

    ativei o dhcp do mikrotik dando o primeiro ip 192.168.10.2 ele pego esse ip e navegou

    ai fui feliz no topico do

    squid(debian) em paralelo mikrotik(parent proxy) show de Bola (para iniciantes)

    minhas duvidas eh

    #chmod 777 /var/spool/squid3
    #chmod 777 /var/log/squid3
    #chown proxy.proxy /var/spool/squid3
    #chown proxy.proxy /var/log/squid3

    quando eu digito isso no terminal.. aparece algo embaixo??


    eu coloquei o seguinte codigo do squid

    #Squid.conf gerado por Adriano Soluções - Adriano Jorge Vitorino Melo Junior
    #Contato (82) 9909-3868
    #
    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128
    visible_hostname webproxy


    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid3/access.log

    #cache.log
    cache_log /var/log/squid3/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 80 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 50 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0

    minhas outras duvidas pra q server akela porta 5128 ???
    esses ip para q serveria ? 127.0.0.1/255.255.255.255


    espero q me ajudem e pra qm ja me ajudo muito obrigado..



  9. #9

    Thumbs up

    Citação Postado originalmente por mktguaruja Ver Post
    boa tarde,

    eu tenhei fazer como vc mando no arquivos, mudava la.. mais qndo ia em informações na conexao da ip 169 .... bla bla bla...

    ativei o dhcp do mikrotik dando o primeiro ip 192.168.10.2 ele pego esse ip e navegou

    ai fui feliz no topico do

    squid(debian) em paralelo mikrotik(parent proxy) show de Bola (para iniciantes)

    minhas duvidas eh

    #chmod 777 /var/spool/squid3
    #chmod 777 /var/log/squid3
    #chown proxy.proxy /var/spool/squid3
    #chown proxy.proxy /var/log/squid3

    quando eu digito isso no terminal.. aparece algo embaixo??


    eu coloquei o seguinte codigo do squid

    #Squid.conf gerado por Adriano Soluções - Adriano Jorge Vitorino Melo Junior
    #Contato (82) 9909-3868
    #
    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128
    visible_hostname webproxy


    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid3/access.log

    #cache.log
    cache_log /var/log/squid3/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 80 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 50 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0

    minhas outras duvidas pra q server akela porta 5128 ???
    esses ip para q serveria ? 127.0.0.1/255.255.255.255


    espero q me ajudem e pra qm ja me ajudo muito obrigado..
    quando altera as permissoes e donos de arquivos nao resulta nenhum comando a menos que tenha ocorrido erro.
    Qual sua versao do squid? essa config é pra squid 2.5.
    A porta 5128 é a porta do serv proxy. Essa ultima linha é para o localhost.

    []´s

  10. #10

    Padrão

    o squid q instalei foi o squid3

    # apt-get install squid3

    tem como me ajudar no codigo fonte do squid ??
    qual a diferença do squid 2.6 para p squid3???

    obrigado



  11. #11

    Padrão

    Citação Postado originalmente por mktguaruja Ver Post
    o squid q instalei foi o squid3

    # apt-get install squid3

    tem como me ajudar no codigo fonte do squid ??
    qual a diferença do squid 2.6 para p squid3???

    obrigado
    Amigo ainda nao utilizei o squid 3, em breve vou testa-lo. acredito que houveram mudanças no arquivo de configuracao, mas qualquer coisa existe um arquivo default q vem junto com a instalacao, entre na pasta /etc/squid/ visualize o arquivo squid.conf e altere as configuracoes, ele é bem explicativo.

    Abs!

  12. #12
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Citação Postado originalmente por mktguaruja Ver Post
    o squid q instalei foi o squid3

    # apt-get install squid3

    tem como me ajudar no codigo fonte do squid ??
    qual a diferença do squid 2.6 para p squid3???

    obrigado
    Não use a versão 2.6, instale ou a 3.0 ou a 2.7, a 2.7 já vem com o ZPH por padrão, mas a 3.0 não.
    Se quiser a versão 3.0 com ZPH, instale a 3.1 ou a 3.HEAD, mas a opção de configuração do ZPH muda para qos_flows (squid : qos_flows configuration directive)

    A 2.7 é em C, a 3.0 é em C++, há uma melhora na performance, mas ainda não testei direito.



  13. #13

    Padrão

    Boa tarde galera...

    hj anoite vo começar tudo do zero... novamente passar a madrugada.. tentando resolver esse problema.. se algume quiser me ajudar.... me add


    [email protected].....


    Obrigado a todos q me ajudaram

  14. #14

    Lightbulb

    galera... eu consegui... fazer o proxy paralelo com o seguinte codigo do squid....
    tem como ver c tem algum erro ??
    como eu sei q ela ta funcionando certinhu ???
    como eu consigo ver um relatorio de todos os sites acessados ????
    eu vi um programa q c chama sarg ?????

    # regras de segurança, iptables, etc. executadas no mikrotik.
    http_port 5128 transparent
    visible_hostname webproxy
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS
    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1/24
    http_access allow localhost
    http_access allow redelocal
    #bloquear todos outros acessos.
    http_access deny all
    #access log
    cache_access_log /var/log/squid3/access.log
    #cache.log
    cache_log /var/log/squid3/cache.log
    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 700 MB
    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 128 KB
    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 5120 MB
    minimum_object_size 0 KB
    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90
    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 50048 16 256
    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560
    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF
    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0



    galera tem algum erro no conf ???
    tenho como aumentar o cache rapido..
    qndo eu baixo um arquivo de uns 4mb e baixou denovu
    ele vem rapidinhu...
    agora qndo baixo um maior... de uns 20 mb.. ele vem normal.. a taxa
    q tiver cadastra no clientes.



  15. #15

    Lightbulb

    galera tem como ver c minha conf. ta certa???
    lembrando meu mikrotik 2.9.27

    / ip firewall filter
    add chain=input in-interface=internet protocol=tcp dst-port=3128 action=drop \
    comment="" disabled=no
    / ip firewall nat
    add chain=srcnat src-address=15.15.0.0/30 action=masquerade comment="Conex o \
    para o proxy" disabled=no
    add chain=pre-hotspot in-interface=clientes src-address=192.168.10.0/24 \
    dst-address=!15.15.0.2 protocol=tcp dst-port=80 hotspot=auth \
    action=redirect to-ports=3128 comment="Redirecionamento do proxy do \
    servidor para os clientes" disabled=no
    add chain=srcnat src-address=192.168.10.0/24 action=masquerade \
    comment="Conex o para os clientes" disabled=no
    /ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=squid-connection-HIT \
    passthrough=yes comment="CACHE FULL SQUID-DEBIAN" disabled=no
    add chain=output connection-mark=squid-connection-HIT action=mark-packet \
    new-packet-mark=squid-packet-HIT passthrough=yes comment="" disabled=no
    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=P2P-Conexao passthrough=yes comment="CONTROLE P2P" \
    disabled=no
    add chain=prerouting protocol=tcp tcp-flags=syn p2p=all-p2p \
    connection-limit=15,24 action=mark-connection \
    new-connection-mark=P2P-Conexao-Limite passthrough=yes comment="" \
    disabled=no
    add chain=prerouting connection-mark=P2P-Conexao action=mark-packet \
    new-packet-mark=P2P-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting connection-mark=P2P-Conexao-Limite action=mark-packet \
    new-packet-mark=P2P-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting protocol=icmp action=mark-connection \
    new-connection-mark=ICMP-Conexao passthrough=yes comment="CONTROLE ICMP" \
    disabled=no
    add chain=prerouting connection-mark=ICMP-Conexao action=mark-packet \
    new-packet-mark=ICMP-Pacotes passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-connection \
    new-connection-mark=Navegacao-Conexao passthrough=yes comment="CONTROLE \
    NAVEGACAO" disabled=no
    add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
    new-connection-mark=Navegacao-Conexao passthrough=yes comment="" \
    disabled=yes
    add chain=prerouting protocol=tcp dst-port=53 action=mark-connection \
    new-connection-mark=Navegacao-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting protocol=udp dst-port=53 action=mark-connection \
    new-connection-mark=Navegacao-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting protocol=tcp dst-port=21 action=mark-connection \
    new-connection-mark=Navegacao-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting connection-mark=Navegacao-Conexao action=mark-packet \
    new-packet-mark=Navegacao-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=1863 action=mark-connection \
    new-connection-mark=Messenger-Conexao passthrough=yes comment="CONTROLE \
    MESSENGER" disabled=no
    add chain=prerouting protocol=udp dst-port=1863 action=mark-connection \
    new-connection-mark=Messenger-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting protocol=tcp dst-port=6891-6901 action=mark-connection \
    new-connection-mark=Messenger-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting protocol=udp dst-port=6891-6901 action=mark-connection \
    new-connection-mark=Messenger-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting protocol=udp dst-port=5190 action=mark-connection \
    new-connection-mark=Messenger-Conexao passthrough=yes comment="" \
    disabled=no
    add chain=prerouting connection-mark=Messenger-Conexao action=mark-packet \
    new-packet-mark=Messenger-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=8291 action=mark-connection \
    new-connection-mark=Acesso-Remoto-Conexao passthrough=yes comment="Winbox" \
    disabled=no
    add chain=prerouting connection-mark=Acesso-Remoto-Conexao action=mark-packet \
    new-packet-mark=Acesso-Remoto-Pacotes passthrough=no comment="" \
    disabled=no
    add chain=prerouting protocol=udp action=mark-connection \
    new-connection-mark=UDP-Conexao passthrough=yes comment="CONTROLE UDP" \
    disabled=no
    add chain=prerouting connection-mark=UDP-Conexao action=mark-packet \
    new-packet-mark=UDP-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=Outras-Conexao \
    passthrough=no comment="CONTROLE SERVICOS NAO IDENTIFICADOS" disabled=yes
    add chain=prerouting connection-mark=Outras-Conexao action=mark-packet \
    new-packet-mark=Outras-Pacotes passthrough=no comment="" disabled=yes
    add chain=prerouting action=accept comment="" disabled=yes

  16. #16

    Padrão

    resto da configuração......
    tem como ver c tem algo errado para min ??
    eu sinto a nevegação um poko presa....

    / queue tree
    add name="QOS" parent=global-total packet-mark="" limit-at=128000 \
    queue=default priority=8 max-limit=100000000 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no
    add name="1 - Navegacao" parent=QOS packet-mark=Navegacao-Pacotes \
    limit-at=128000 queue=default priority=8 max-limit=100000000 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no
    add name="2 - Messenger" parent=QOS packet-mark=Messenger-Pacotes \
    limit-at=128000 queue=default priority=2 max-limit=4000000 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no
    add name="5 - P2P" parent=QOS packet-mark=P2P-Pacotes limit-at=200000 \
    queue=default priority=5 max-limit=200000 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="3 - ICMP" parent=QOS packet-mark=ICMP-Pacotes limit-at=128000 \
    queue=default priority=1 max-limit=250000 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="4 - UDP" parent=QOS packet-mark=UDP-Pacotes limit-at=128000 \
    queue=default priority=3 max-limit=1000000 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="Cache Full Squid-Debian" parent=global-out \
    packet-mark=squid-packet-HIT limit-at=0 queue=default priority=8 \
    max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    / ip pool
    add name="dhcp_pool2" ranges=192.168.10.20-192.168.10.254
    / ip dns
    set primary-dns=200.204.0.10 secondary-dns=200.204.0.138 \
    allow-remote-requests=yes cache-size=10240KiB cache-max-ttl=1w
    / ip address
    add address=10.0.0.138/24 network=10.0.0.0 broadcast=10.0.0.255 \
    interface=internet comment="" disabled=yes
    add address=192.168.10.1/24 network=192.168.10.0 broadcast=192.168.10.255 \
    interface=clientes comment="" disabled=no
    add address=15.15.0.1/30 network=15.15.0.0 broadcast=15.15.0.3 interface=proxy \
    comment="" disabled=no
    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" \
    transparent-proxy=yes parent-proxy=15.15.0.2:5128 \
    cache-administrator="webmaster" max-object-size=1KiB cache-drive=system \
    max-cache-size=none max-ram-cache-size=unlimited
    / ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    add src-address=192.168.10.0/24 action=allow comment="Acesso a rede " \
    disabled=no
    add action=deny comment="" disabled=no
    add url="http://www.speedyzone/wsc/" action=deny comment="" disabled=no
    add url="http://speedyzone/wsc/" action=deny comment="" disabled=no
    add url="http://www.speedy.zone/wsc/" action=deny comment="" disabled=no
    add url="speedy.zone/wsc/" action=deny comment="" disabled=no
    add url="http://200.171.222.97/wsc/" action=deny comment="" disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" \
    disabled=no
    add url="https://" action=deny comment="don't cache dynamic https pages" \
    disabled=no


    obrigado a todos q me ajudaram.
    e me ajudam...


    muto obrigado a todos... sem vc´s naum teria conseguido fazer nda..
    muito obrigado a todos ...



  17. #17

    Padrão

    eu tava pensando c eu colocar o debian no switch ele vai funcionar em paralelo ???


    internet
    !
    !
    roteador
    !
    !
    Mkt
    !
    !
    switch ------ Debian
    !
    !
    clientes


    assim funciona ou ele naum vai localizar o mkt ??
    entuam galera minha regras q postei anteriormente ta certinha ???
    eu sinto e ele ta dando umas travadas.....

    preciso de ajuda..
    obrigado a todos q me ajudaram agradeço muito


    Obrigado

  18. #18

    Padrão

    alguma ideia galera ????
    me ajudem por favor..



  19. #19

    Padrão

    Funcionaria normal acordo com a sua configuracao, voce poderia redirecionar todas as requisicoes para a porta 5128 do proxy porém desta maneira utilizaria a mesma interface para suprir clientes e o proxy. Aqui utilizo uma interface somente para proxy ligada diretamente no debian e outra somente para distribuir para os clientes.
    Em outro topico eu explico as diferentes formas de configurar o proxy com mk.

    Vale apena por o Cache full? - Página 3

    Aqui tem uma receita e até squid conf pra versao 2.6:

    Duvida iniciante- Squid limitando Cache (cahce full) ZPH

  20. #20

    Padrão

    boa tarde galera, o meu squid ta funcionando normal mais no codigo dele qndo eu abro
    vi/etc/squi/squid.conf aparece assim..

    # Regras de seguran a, iptables realizados pelo Mikrotik^M
    ^M
    http_port 5128^M
    visible_hostname proxy^M
    ^M
    acl all src 0.0.0.0/0.0.0.0 ^M
    acl manager proto cache_object^M
    acl localhost src 127.0.0.1/255.255.255.255^M
    acl SSL_ports port 443 563 # msn^M
    acl Safe_ports port 80 # http^M
    acl Safe_ports port 21 # ftp^M
    acl Safe_ports port 70 # protocolo gopher^M
    acl Safe_ports port 210 # whais^M
    acl Safe_ports port 1024-65535 # portas altas^M
    acl Safe_ports port 280 # http-mgmt ^M
    acl Safe_ports port 488 # gss-http ^M
    acl Safe_ports port 591 # filemaker ^M
    acl Safe_ports port 777 # multi http ^M
    acl Safe_ports port 901 # acesso swat^M
    acl purge method PURGE^M
    acl CONNECT method CONNECT^M
    http_access allow manager localhost^M
    http_access deny manager^M
    http_access allow purge localhost^M
    http_access deny purge^M
    http_access deny !safe_ports^M
    http_access deny CONNECT !SSL_PORTS^M
    ^M
    # Permiss o de acesso ao proxy - rede Mikrotik ^M
    # Classe de rede ou classes separadas por espa o^M
    acl redelocal src 192.168.0.1^M
    http_access allow localhost^M
    http_access allow redelocal^M
    ^M
    # Regras novas liberar temp^M
    always_direct allow all^M
    ^M
    # Bloquear todos os outros acessos^M
    http_access deny all^M
    ^M
    # Access Log^M
    cache_access_log /var/log/squid/access.log^M
    ^M
    # Cache log^M
    cache_log /var/log/squid/cache.log^M
    ^M
    # Memoria reservada para o cache total de 40% do disponivel^M
    cache_mem 1024 MB^M
    ^M
    # Maximo tamanho dos arquivos cache na memoria^M
    maximum_object_size_in_memory 96 KB^M
    ^M
    # Regras novas monitoramento^M
    ipcache_size 1024^M
    ipcache_low 90 ^M
    ipcache_high 93 ^M
    ^M
    # Maximo tamanho dos arquivos cache no HD^M
    maximum_object_size 1024000 KB^M
    minimum_object_size 0 KB ^M
    ^M
    # Regra que come a a esvaziar/substituir arquivos no cache em 90%^M
    cache_swap_low 80^M
    cache_swap_high 90^M
    ^M
    # Regras novas policiamento memoria^M
    memory_replacement_policy lru^M
    ^M
    # Regras novas adicionais policiamento memoria^M
    # memory_replacement_policy heap GDSF^M
    # cache_replacement_policy heap LFUDA^M
    ^M
    # Indica o de localiza o da pasta de arquivos cache em sequencia valor^M
    # total em MB de espa o no HD a ser usado pelo cache/numero de pastas/ lor^M
    # e subpastas.^M
    cache_dir ufs /var/spool/squid 1500048 16 256^M
    ^M
    # Intervalo de tempo que o proxy verifica os arquivos do site acessados^M
    # conferem com o do cache. O valor 2280 significa a cada 2 dias^M
    refresh_pattern ^ftp: 15 20% 2280 ^M
    refresh_pattern ^gopher: 15 0% 2280^M
    refresh_pattern . 15 20% 2280^M
    ^M
    # Mantendo objetos recentes e pequenos na memoria^M
    # Pools em 32 MB^M
    memory_pools off^M
    memory_pools_limit 0^M
    ########################-FIM-########################################^M



    esse ^M o que seria ???
    sera q ele ta funcionando mesmo ??