Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa noite a todos. Amigos, preciso de um script que leia todo o conteudo do /ip hotspot cookie , e gere um arquivo no formato pra importar no access-list do AP. Algo mais ou menos assim:

    :foreach i in=[/ip hotspot cookie find] do={
    :local usuario [/ip hotspot cookie get $i user]
    :local mac [/ip hotspot cookie get $i mac-address]
    }
    :log info "/interface wireless access-list add interface=wlan1 comment=$usuario mac-address=$mac"

    Nao quero jogar no log, alias nem deu certo jogar no log tambem...e sim gerar um arquivo .rsc pra ser importado em outro equipamento. Espero que tenham entendido o que nescessito e se alguem souber como fazer, me dar uma ajuda por favor
    Desde já grato
    Gabriel Siena

  2. acho que se tu especificar file=arquivo.rsc

    ele gera o arquivo.. faz um teste ai..



  3. outra opção é vc usar o API do mikrotik.. dai vc consegue fazer tudo que quiser... exportar dados do jeit q quiser...

  4. Você terá que usar a api mesmo, pois o mikrotik não aceita print com a extensão "rsc", só usando o comando export e não é possível exportar os cookies.



  5. Obrigado pelas respostas, poderiam me indicar um material bom pra leitura sobre API do Mikrotik?






Tópicos Similares

  1. Respostas: 1
    Último Post: 26-06-2015, 16:06
  2. Respostas: 35
    Último Post: 03-01-2014, 15:52
  3. Respostas: 12
    Último Post: 19-04-2009, 11:06
  4. para os bons no script
    Por no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 24-08-2003, 15:22
  5. Para os Feras!!! BSD/Linux
    Por jennersouza no fórum UnderLinux
    Respostas: 2
    Último Post: 07-12-2002, 15:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L