Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Liberando uma interface do HotSpot

    Pessoal tenho 3 interfaces no meu mikrotik:

    Local ----> Recebo um cabo local, que vai do meu pc ao mikrotik
    Link -----> Recebo o link adsl que vem do modem
    Wireless ----> Mando o sinal para minha onmi, onde os clientes se conectam.

    Eu criei uma bridge para essas interfaces e como meu modem esta em bridge criei um pppoe para fazer autenticação do adsl no mikrotik, esse pppoe esta na interface bridge criada para as interfaces Local,Link,Wireless.

    Depois fiz o hotspot, cadastrei os user e tal, funciona tudo blz, só que como trabalho com hotspot sempre que vou me conectar a internet meu micro passa pelo hotspot pedindo login e senha, como estou conectado por uma interface que só eu me conecto, que é a interface local, eu queria saber se tem como livrar minha interface de rede local de passar pelo hotspot ?

    Será que alguém tem alguma dica ???

    agradeço de antemão pessoal.

  2. #2

    Padrão

    Citação Postado originalmente por rafaelmju Ver Post
    Pessoal tenho 3 interfaces no meu mikrotik:

    Local ----> Recebo um cabo local, que vai do meu pc ao mikrotik
    Link -----> Recebo o link adsl que vem do modem
    Wireless ----> Mando o sinal para minha onmi, onde os clientes se conectam.

    Eu criei uma bridge para essas interfaces e como meu modem esta em bridge criei um pppoe para fazer autenticação do adsl no mikrotik, esse pppoe esta na interface bridge criada para as interfaces Local,Link,Wireless.

    Depois fiz o hotspot, cadastrei os user e tal, funciona tudo blz, só que como trabalho com hotspot sempre que vou me conectar a internet meu micro passa pelo hotspot pedindo login e senha, como estou conectado por uma interface que só eu me conecto, que é a interface local, eu queria saber se tem como livrar minha interface de rede local de passar pelo hotspot ?

    Será que alguém tem alguma dica ???

    agradeço de antemão pessoal.
    Como vc criou esse hotspot, a 2 maneiras de resolver este problema, se deseja que toda a rede local passe "direto" apenas desativar o servidor hotpost da rede local, e deixar so da wireless, se deseja que somente sua maquina tenha acesso sem passar pelo hotspot, basta cadastrar seu mac e ip na aba do Hotpost-> Ip Bindings e selecionar bypassed.



  3. #3

    Padrão

    E dai Raus blz,

    Eu tenho um ip (192.168.10.3), na interface local e mesmo com o dhcp ativo eu consigo colocar um ip na interface local, dai fui lá em hotspot -> ip dindigs, e cadastrei o mac e o ip, em address e to address coloquei o mesmo ip(192.168.10.3), selecionei o opção bypassed, porém não funcionou , não sei porq.

    Então tirei o ip da minha interface e coloquei pra pegar o ip automatico, e fui em hotspot -> ip dindigs e coloquei apenas o mac, dai deu certo.

    Porém, pra min não pode ser assim, porq eu preciso ter um ip na minha interface local.

    Você tem idéia porq isso acontece ???
    Última edição por rafaelmju; 03-04-2009 às 20:33.

  4. #4

    Padrão

    Citação Postado originalmente por rafaelmju Ver Post
    E dai Raus blz,

    Eu tenho um ip (192.168.10.3), na interface local e mesmo com o dhcp ativo eu consigo colocar um ip na interface local, dai fui lá em hotspot -> ip dindigs, e cadastrei o mac e o ip, em address e to address coloquei o mesmo ip(192.168.10.3), selecionei o opção bypassed, porém não funcionou , não sei porq.

    Então tirei o ip da minha interface e coloquei pra pegar o ip automatico, e fui em hotspot -> ip dindigs e coloquei apenas o mac, dai deu certo.

    Porém, pra min não pode ser assim, porq eu preciso ter um ip na minha interface local.

    Você tem idéia porq isso acontece ???
    Quando voce entrou com ip automatico, qual voce haveria pego?
    Pode ser que ele ja estava cadastrado, e o mk nao liberou o aecsso a voce, o ideal se vc quer usar ip fixo, seria ir la em pools, e limitar para começar a distribuir seus ips a partir do 192.168.10.4, ae vc ficaria com os abaixo para poderem usar fixamente na sua placa de rede local ou em outro pc, mais acho q isso afeta nao.
    Qualquer duvida, posta ae.



  5. #5

    Padrão

    Prezado Amigo,

    Dessa forma o Hotspot entende que Address é o ENDEREÇO que você está cessando e to address é o Endereço 192.168.10.3. Então você deve deixar como fez, apenas o seu MAc liberado em Ip-Bilding .

    Seu hotpost deve estar setado para interface bridge e não nas outras interfaces.

  6. #6

    Padrão

    Primeiro quero agradecer quem tentou me ajudar .

    Antes eu usava uma bridge e criei o hotspot em cima de bridge, nesse bridge tinha as minhas 3 iterfaces de redes, ether1,ethe2,wireless, como disse entes ai, então não conseguia navegar sem passar pelo hotspot, então resolvi mudar minha config e criei o hotspot apenas para a rede wireless, ja que meus clientes se conectam apenas pela wireless.

    Os clientes da rede wireless conectam normal como eu quero, passando pelo hotspot, digitando senha e tal, como não inclui minha placa local no hotspot eu criei o address e o pool como vcs podem ver na imagem,

    http://www.conectmt.com.br/images/publicas/mikro.jpg

    criei também um dhcp para minha rede local, bom o fato é que quando eu colocar pra pegar ip automatico na minha interface local, eu navego normalmente, agora sem passar pelo hotspot claro, porém quando defino um ip na minha interface local, eu não consigo navegar.

    Ja desabilitei o servidor dhcp e dai também vai, até mesmo porq o gateway que defino na minha interface local é criado na parte networks do servidor dhcp, então se eu desabilito o dhcp onde vou definir um gateway pra minha rede?

    Fiquei meio perdido nesse ponto, sera q é possivel navegar na internet sem criar um servidor dhcp ?

    Será que alguém pode me ajudar por favor ???



  7. #7

    Padrão

    Citação Postado originalmente por rafaelmju Ver Post
    Ja desabilitei o servidor dhcp e dai também vai, até mesmo porq o gateway que defino na minha interface local é criado na parte networks do servidor dhcp, então se eu desabilito o dhcp onde vou definir um gateway pra minha rede?

    Fiquei meio perdido nesse ponto, sera q é possivel navegar na internet sem criar um servidor dhcp ?

    Será que alguém pode me ajudar por favor ???

    Defina o Gateway em IP > Route .

    Destination=0.0.0.0/0
    Gateway=(Seu Gateway)

    Só isso e pronto.

  8. #8

    Padrão

    Citação Postado originalmente por rafaelmju Ver Post
    Primeiro quero agradecer quem tentou me ajudar .

    Antes eu usava uma bridge e criei o hotspot em cima de bridge, nesse bridge tinha as minhas 3 iterfaces de redes, ether1,ethe2,wireless, como disse entes ai, então não conseguia navegar sem passar pelo hotspot, então resolvi mudar minha config e criei o hotspot apenas para a rede wireless, ja que meus clientes se conectam apenas pela wireless.

    Os clientes da rede wireless conectam normal como eu quero, passando pelo hotspot, digitando senha e tal, como não inclui minha placa local no hotspot eu criei o address e o pool como vcs podem ver na imagem,

    http://www.conectmt.com.br/images/publicas/mikro.jpg

    criei também um dhcp para minha rede local, bom o fato é que quando eu colocar pra pegar ip automatico na minha interface local, eu navego normalmente, agora sem passar pelo hotspot claro, porém quando defino um ip na minha interface local, eu não consigo navegar.

    Ja desabilitei o servidor dhcp e dai também vai, até mesmo porq o gateway que defino na minha interface local é criado na parte networks do servidor dhcp, então se eu desabilito o dhcp onde vou definir um gateway pra minha rede?

    Fiquei meio perdido nesse ponto, sera q é possivel navegar na internet sem criar um servidor dhcp ?

    Será que alguém pode me ajudar por favor ???
    Posta suas regras de firewall nat, vc fez um mascaramento geral? ou por ip, cada ip tem seu mascaramento? o arp esta habilitado ou nao?



  9. #9

    Padrão

    Citação Postado originalmente por raus Ver Post
    Posta suas regras de firewall nat, vc fez um mascaramento geral? ou por ip, cada ip tem seu mascaramento? o arp esta habilitado ou nao?
    Ai estão as regras.

    / ip firewall nat
    add chain=srcnat src-address=192.168.10.0/24 action=masquerade comment="Rede do Hotspot" disabled=no
    add chain=srcnat src-address=10.1.0.0/24 action=masquerade comment="Rede Local" disabled=no
    add chain=dstnat in-interface=Globo protocol=tcp dst-port=13235 action=dst-nat \
    to-addresses=10.1.0.2 to-ports=13235 comment="LIBERA PORTA DO TORRENTE" \
    disabled=no

    é isso ai..

  10. #10

    Padrão

    Citação Postado originalmente por fabiocp1984 Ver Post
    Defina o Gateway em IP > Route .

    Destination=0.0.0.0/0
    Gateway=(Seu Gateway)

    Só isso e pronto.
    Meu caro fabio,

    É o seguinte, quando tento definir um gateway pelo ip > route da um erro não selecionando a interface local, verifiquei q é porq eu não tinha criado o ip > address, entao criei o ip address porem dai fica azul, como vc pode ver na imagem. não sei o q acontece.

    http://www.conectmt.com.br/images/publicas/mikro2.jpg

    O que eu quero é tão simples porém não consigo.

    Tenho 3 interfaces no meu mikrotik, umas recebe o sinal adsl, outra recebe um cabo que sai do meu micro, a ultima é a wireless onde mando sinal para meus clientes.

    A rede wireless ja esta configurada e funcionando como quero com hotspot, servidor dhcp com os ips definidos na faixa 192.168.10.0, agora só quero que meu micro que esta conectado na interface local navegue na net sem passar pelo hotspot e sem servidor dhcp, porq preciso definir um ip na minha interface de rede, e quando crio um servidor dhcp no mikrotik e coloco um ip na minha interface local não funciona.

    Ja tentei de todo jeito e nada..

    Será que alguém tem uma solução ????



  11. #11

    Cool

    Prezado Amigo,

    Vc terá que criar um MArk routing, pois seu servidor já possui Gateway.

    Vá em IP > Firewall Mangle

    +
    General
    chain=forward
    dst.address=10.1.1.1
    Action
    action=mark routing
    new routing mark=saidalocal
    passthrough=yes

    Depois vá em IP > Route
    +
    Destination=0.0.0.0/0
    Gateway=10.1.1.1
    Mark=saidalocal


    Agora direcione quem vc quer que saia por este Gateway


    Em Ip > Firewall MAngle
    crie um Prerouting

    +
    General
    chain=prerouting
    Src.address= ( ou toda rede 10.1.1.1/24 ou um IP específico tipo 10.1.1.5 )
    Action
    action=mark routing
    new routing mark=saidalocal


    Espero ter ajudado.

  12. #12

    Padrão

    Pô brother agora que eu vi, esse Gateway não pode ser o IP do Mkt.
    Esquece.

    Só configurar manualmente nesta rede com este Gateway que vai funcionar.
    Não esquece de fazer nat na interface externa.



  13. #13

    Padrão

    Meu amigo fabio desculpe minha ignorancia, e me diga como posso configurar "nesta rede com este Gateway" que vc citou ???

    Me diz os passos por favor , to quebrando a cabeça e não to conseguindo ...

    E fala também como vai ficar o servidor dhcp, eu vou precisar do dhcp ou não ??

  14. #14

    Padrão

    Meu caro,
    Pelo que eu vi, você tem 3 interfaces e apenas uma para o hotspot(wireless) e tá querendo configurar o seu ip com um ip da rede do hotspot que está numa interface diferente da qual está conectado.

    Olha só, se você quer acessar a internet da 2 placa (sem o hs server), você terá que criar uma rede para esta interface.
    Veja o exemplo:

    Código :
    /ip address add address=192.168.10.0/24 interface="wireless-hs" comment="rede do hotspot"
    /ip address add address=10.16.10.0/24 interface="redelocal" comment="rede do sem hotspot"
    /ip address add address=xxx.xxx.xxx.xxx/xx interface="internet" comment="rede do hotspot"

    Código :
    /ip route add gateway=xxx.xxx.xxx.xxx /*este é o ip do moden ou roteador vindo da internet caso seje roteado*/)

    Código :
     /ip firewall nat add chain=srcnat out-interface="internet" action=masquerade comment="compartilha a internet com qualquer rede criada"

    Se você tiver na interface do hotspot você precisa add no bindings, caso contrário, não precisa.
    Você só precisa add o mac da sua placa no ip bindings.

    Espero ter ajudado.
    Última edição por Raniel; 07-04-2009 às 21:19.



  15. #15

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Meu caro,
    Pelo que eu vi, você tem 3 interfaces e apenas uma para o hotspot(wireless) e tá querendo configurar o seu ip com um ip da rede do hotspot que está numa interface diferente da qual está conectado.

    Olha só, se você quer acessar a internet da 2 placa (sem o hs server), você terá que criar uma rede para esta interface.
    Veja o exemplo:

    Código :
    /ip address add address=192.168.10.0/24 interface="wireless-hs" comment="rede do hotspot"
    /ip address add address=10.16.10.0/24 interface="redelocal" comment="rede do sem hotspot"
    /ip address add address=xxx.xxx.xxx.xxx/xx interface="internet" comment="rede do hotspot"

    Código :
    /ip route add gateway=xxx.xxx.xxx.xxx /*este é o ip do moden ou roteador vindo da internet caso seje roteado*/)

    Código :
     /ip firewall nat add chain=srcnat out-interface="internet" action=masquerade comment="compartilha a internet com qualquer rede criada"

    Se você tiver na interface do hotspot você precisa add no bindings, caso contrário, não precisa.
    Você só precisa add o mac da sua placa no ip bindings.

    Espero ter ajudado.
    Caro Raniel é quase isso que vc falou,
    "Pelo que eu vi, você tem 3 interfaces e apenas uma para o hotspot(wireless) e tá querendo configurar o seu ip com um ip da rede do hotspot que está numa interface diferente da qual está conectado."

    A única diferença é que não estou querendo configurar o meu ip com um ip do hotspot, a rede do hotspot esta usando essa classe 192.168.10.0/24 de ips, e queria justamente configurar outra rede para minha placa local, com outra classe de ips, tipo 10.1.1.0/24 porém, sem hotspot e sem servidor dhcp para eu definir um ip na minha rede local, entendeu ???

    Será que essa config que vc me passou pode ser usada para config do jeito que te falei ai ??

    até ++++

  16. #16

    Padrão

    Dá sim meu caro,
    É só você configurar que dá "certim".



  17. #17

    Padrão

    Raniel, existem algumas diferenças nas configs que vc me passou.


    Meu modem esta em bridge porq faço pppoe no mikrotik, então fiquei na dúvida quando vc diz pra eu ir em /ip route add gateway=xxx.xxx.xxx.xxx /*este é o ip do moden ou roteador vindo da internet caso seje roteado*/), nesse caso com faço ???


    Outra coisa é que quando vou em --> ip address add address=10.16.10.0/24 interface="redelocal" comment="rede sem hotspot"

    Ja cria automatico a rota, /ip route add , e dai não tem como eu adicionar um gateway por lá,
    como devo proceder nesse caso ??

  18. #18

    Padrão

    O Gateway dá sua rede interna é este Ip que vc acaba de criar no Mikrotik. Só isso.
    O Gateway do MIkrotik já está criado conforme vc mostrou nas imagens.

    Se criou o IP 10.16.1.1/24 no MIkrotik é só configurar no PC:

    IP 10.16.1.x
    Mask 255.255.255.0
    Gateway 10.16.1.1
    dns 10.16.1.1

    Não esquece de colocar o IP de rede interna do Mikrotik como DNS para utilizar esta configuração.

    IP > DNS
    +



  19. #19

    Padrão

    Fabio agradeço pela ajuda cara, mas infelismente não esta dando certo, fiz tudo certinho como vc falou, veja a imagem ai.

    http://www.conectmt.com.br/images/publicas/mikrotik.jpg


    Quanto utilizo essa configuração o engraçado é que torrente , emule funcionam só não consigo navegar, receber email, msn, agora emule , torrent funciona, isso é coisa de louco mesmo.

    Onde que estou errando ???

    Se vc puder dar uma olhada no meu mikrotik eu te passo meu login e senha em pvt, pra apenas pra vc ver minha config e me dizer onde estou errando.

    Abraços e obrigado pela ajuda.

    Rafael.

  20. #20

    Padrão

    Citação Postado originalmente por rafaelmju Ver Post
    Fabio agradeço pela ajuda cara, mas infelismente não esta dando certo, fiz tudo certinho como vc falou, veja a imagem ai.

    http://www.conectmt.com.br/images/publicas/mikrotik.jpg


    Quanto utilizo essa configuração o engraçado é que torrente , emule funcionam só não consigo navegar, receber email, msn, agora emule , torrent funciona, isso é coisa de louco mesmo.

    Onde que estou errando ???

    Se vc puder dar uma olhada no meu mikrotik eu te passo meu login e senha em pvt, pra apenas pra vc ver minha config e me dizer onde estou errando.

    Abraços e obrigado pela ajuda.

    Rafael.

    Coloque o masquerade(Globo) na primeira linha da aba NAT.