Olá pessoal!

Ja tenho algumas instalações do Zimbra nas costas e agora me deparei com uma situação que nao estou conseguindo resolver.

Estou com o servidor perfeitamente funcional, mas para a migração tenho que deixar por algum tempo o exchange e o zimbra funcionando em paralelo para fins de homologação.

Pensei em 2 possibilidades configrar o fetchmail para conectar no exchange buscar as mensagens e entregar no zimbra ou mudar o postfix que hoje ja recebe as mensages e encaminha ao exchange para que encaminhe a mensagem para os 2 servidores.

Estou na primeira opção visto que não tenho experiencia avançada com postfixz para tal façanha, o problema com a primeira opção está na autenticação do fetchmail no exchange, a parte de entrega no zimbra está ok visto que os erros de autenticação são enviados a caixa postal correspondente no zimbra, pelo que entendi do log o fetchmail não entende a "\" que separa o dominio do nome do usuário, segue a minha configuração e o erro:

CONFIGURAÇÃO

[root@mx ~]# cat .fetchmailrc
set logfile "/var/log/fetchmaillog"
set daemon 30
set bouncemail
poll 192.168.1.29 protocol imap
username "aenaint\USUARIO" password "SENHA" smtphost 192.168.1.102 smtpname USUARIO@DOMAIN

ERRO

fetchmail: awakened at Mon 06 Apr 2009 02:12:53 PM BRT
fetchmail: 6.3.6 querying 192.168.1.29 (protocol IMAP) at Mon 06 Apr 2009 02:12:53 PM BRT: poll started
fetchmail: Trying to connect to 192.168.1.29/143...connected.
fetchmail: IMAP< * OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (correio03.AENA.INT) ready.
fetchmail: IMAP> A0001 CAPABILITY
fetchmail: IMAP< * CAPABILITY IMAP4 IMAP4rev1 IDLE LOGIN-REFERRALS MAILBOX-REFERRALS NAMESPACE LITERAL+ UIDPLUS CHILDREN
fetchmail: IMAP< A0001 OK CAPABILITY completed.
fetchmail: 192.168.1.29: opportunistic upgrade to TLS failed, trying to continue
fetchmail: IMAP> A0002 NOOP
fetchmail: IMAP< A0002 OK NOOP completed.
fetchmail: IMAP> A0003 LOGIN "AENAINT8" *
fetchmail: IMAP< A0003 BAD Protocol Error: "Invalid string supplied for user name".
fetchmail: IMAP> A0004 *
fetchmail: Unknown login or authentication error on AENAINT8@192.168.1.29
fetchmail: IMAP> A0005 LOGOUT
fetchmail: IMAP< A0004 BAD Protocol Error: "Unknown command found".
fetchmail: IMAP< * BYE Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 signing off.
fetchmail: IMAP< A0005 OK LOGOUT completed.
fetchmail: client/server synchronization error while fetching from AENAINT8@192.168.1.29
fetchmail: 6.3.6 querying 192.168.1.29 (protocol IMAP) at Mon 06 Apr 2009 02:12:53 PM BRT: poll completed
fetchmail: Query status=7 (ERROR)
fetchmail: sleeping at Mon 06 Apr 2009 02:12:53 PM BRT for 30 seconds

Se alguém souber fazer, usando uma maneira ou outra, eu agradeço muito, já faz alguns dias que estou nisso.

Obrigado!

Alan