Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Vi que alguns tem dificuldade para colocar o cachefull + webproxy+PPPoe no Mk, Então resolvi postar as regras que Utilizei para que vcs mesmos possam adaptar à suas regras:

    IP => Firewall => Filter Rules:
    /ip firewall filter
    add action=accept chain=input comment="ACEITAR CONEXOES PROXY" disabled=no \
    dst-port=3128 protocol=tcp
    add action=drop chain=input comment="BLOQUEIO DO PROXY EXTERNO" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    Ip => Firewall => Nat
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no \
    dst-port=80 in-interface=!Clientes protocol=tcp src-address=\
    172.10.20.0/24 to-ports=3128
    Ip => firewall => Mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3128 new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    Queue => Tree
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="[CACHE-FULL] - Download" packet-mark=\
    pacotes_squid-down parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5000000 name="[CACHE-FULL] - Upload" packet-mark=\
    pacotes_squid-up parent=global-out priority=1 queue=default

    IP => Proxy
    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=400000000KiB \
    max-client-connections=600 max-fresh-time=4w2d max-server-connections=\
    600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow comment="" disabled=no src-address=172.10.20.0/24


    Lembrando que na Ultima regra deve alterar "max-cache-size=400000000KiB" Para o Tamanho do seu cache e "src-address=172.10.20.0/24" Para Sua rede de Ip do PPPoE,

    Caso Alguem Possa Ajudar a Implementar a regra Aceito de bom Coração =)
    E uma Duvida:
    Posso Colocar o Webproxy para a porta 80 para não ter que redirecionar e evitar assim tem que criar regras para Radio Uol e coisas do tipo?
    e alguem conseguio liberar a Radio Uol Com PPPoE?

    Obrigado Espero poder ajudar

  2. Sunnet,


    Não entendi muito bem sua disposição, seu proxy é o do próprio MK ou vc tá usando uma máquina à parte para fazer proxy?

    Qual a versão do MK q vc tá usando?


    Abs.



  3. Citação Postado originalmente por xnetinho Ver Post
    Sunnet,


    Não entendi muito bem sua disposição, seu proxy é o do próprio MK ou vc tá usando uma máquina à parte para fazer proxy?

    Qual a versão do MK q vc tá usando?


    Abs.
    Ele ta usando no proprio MK, estou postando este tutorial de como fazer o proxy paralelo com debian e squid com zph integrado fazendo cache de videos do youtube e outros mais, vale a pena conferir.
    Tutorial Debian Cache para integração com Mikrotik

  4. Citação Postado originalmente por m4d3 Ver Post
    Ele ta usando no proprio MK, estou postando este tutorial de como fazer o proxy paralelo com debian e squid com zph integrado fazendo cache de videos do youtube e outros mais, vale a pena conferir.
    Tutorial Debian Cache para integração com Mikrotik

    Amigo, é possivel fazer cache dos videos do youtube?



  5. Citação Postado originalmente por xnetinho Ver Post
    Sunnet,


    Não entendi muito bem sua disposição, seu proxy é o do próprio MK ou vc tá usando uma máquina à parte para fazer proxy?

    Qual a versão do MK q vc tá usando?


    Abs.
    Meu Proxy è o Proprio Mikrotik, Mas Para o Proxy Externo Muda Pouca coisa na regra, Onde o pessoal que usa PPPoe esquece eh esta Exclamação no redirecionamento para do nat, Mas eu n consegui fazer a o dst-nat do radiouol com PPPoe se alguem puder me ajudar +)

    Ah sim, Uso a 3.22, está funcionando legal aqui =)
    Última edição por sunnetwork; 13-04-2009 às 07:43. Razão: Esqueci da versão






Tópicos Similares

  1. PPPoE Server Mikrotik
    Por elimartins no fórum Redes
    Respostas: 1
    Último Post: 12-03-2008, 01:50
  2. cliente x pppoe x mikrotik
    Por nosferatusmg no fórum Redes
    Respostas: 0
    Último Post: 08-02-2008, 21:56
  3. Myauth fazendo quase tudo pppoe no mikrotik
    Por harrypotheard no fórum Redes
    Respostas: 0
    Último Post: 23-01-2008, 22:35
  4. Squid X Webproxy Mikrotik
    Por SHREK no fórum Servidores de Rede
    Respostas: 3
    Último Post: 14-10-2007, 22:58
  5. Gerenciamento de PPPoe no Mikrotik
    Por maxtex no fórum Redes
    Respostas: 6
    Último Post: 12-03-2007, 11:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L