+ Responder ao Tópico



  1. #1

    Padrão Smb_Auth Autenticando no AD

    Montei um debian 4 com squid 2.6 usando a autenticacao do AD com o smb_auth.

    Aqui consegui autenticar tranquilamente, mas quando levei para o cliente nao funcionava.
    Apos muito procurar apenas tirei o enedereço IP do servidor AD deixando apenas o nome do dominio.

    Funcionou 2 semanas e parou, agora nem com IP ou IP do servidor de AD funciona.

    no teste como o comando /usr/lib/squid/smb_auth -W -U ou sem -d retorna o seguinte erro

    Domain Controller IP Address: ERR

    Retirei o servidor do cliente e trouxe de volta e aqui funciona.

    Estou pensando que possa ser alguma coisa relacionado a cache de dns mas ja montei outro e funciona ate hj.

    Se alguem tiver a chave desse misterio ficarei muito grato.

    Obrigado.

  2. #2

    Padrão

    Olá amigo,

    Cara, tenta fazer o seguinte, rode os seguintes comandos abaixo e cole o resultado aqui.


    # klist

    e após

    # wbinfo -u

    O primeiro vai verificar o ticket do kerberos e o segundo vai puxar o nome de usuários do AD.

    Conforme o resultado do teste da pra gente verificar os possiveis problemas!

    : ))



  3. #3

    Padrão

    Obrigado desde ja pela atencao.

    qual seria a sintaxe desses comandos?

  4. #4

    Padrão

    Oi,

    Conforme eu coloquei (como root)

    # klist

    E logo após (também como root)

    # wbinfo -u

    Só isto, simples : ))



  5. #5

    Padrão

    Estou digitando assim como root e retorna

    -bash : command not found

  6. #6

    Padrão

    Cara,

    Como você esta fazendo esta integração?

    Você tem o kerberos instalado na máquina? tem o winbind?

    verifique com o comando 'whereis'

    # whereis winbindd

    Abraços



  7. #7

    Padrão

    Na verdade verdade tenho uma instalacao padrao do debian e a integracao e via smb_auth.

    Aprendi via tutorial no site como autenticar o squid usando a base do AD do 2003.

    Tenho outro servidor em outro lugar que funciona normalmente.

    Agora se precisa do Kerberos, winbind eu nao sei dizer.

    Se e necessario deve ser instalado no debian 4 por padrao.

    A unica exigencia e o samba instalado e isso eu tenho.

    executei o comando e retorna

    windbind:
    kerberos:

    so isso mais nada.

  8. #8

    Padrão

    Você esta autenticando utilizando o 'smb_auth'

    Eu recomendo você utilizar o ' ntlm_auth ' a autenticação fica bem mais transparente do que a com o smb_auth.

    Mas caso, necessite que seja o 'smb_auth'

    Verifique o seguinte:

    - Configuração de rede (se o AD do seu cliente e o Proxy estão na mesma rede)
    - Se o DNS primário no resolv.conf de seu server Proxy é o mesmo IP do AD
    - Verifique as configurãções de IP no arquivo /etc/hosts
    - Verifique se você esta ingressado no dominio do AD (net ads join -U Administrador)

    Pelo que você descreve, provavelmente é algum erro de ticket.

    Abraços



  9. #9

    Padrão

    Configuração de rede (se o AD do seu cliente e o Proxy estão na mesma rede)

    Esta OK

    - Se o DNS primário no resolv.conf de seu server Proxy é o mesmo IP do AD

    Pra teste eu coloquei, mas ele pega o dns do externo que o modem da internet manda.

    - Verifique as configurãções de IP no arquivo /etc/hosts

    adicionei um registro com o nome e ip do servidor para teste nesse arquivo.

    - Verifique se você esta ingressado no dominio do AD (net ads join -U Administrador)

    Esse nao esta, ainda nao precisei colocar ele no dominio. o Comando retorna Host is not configured as a member server. Invalid configuation. Exiting....

  10. #10

    Padrão

    um...

    na sua casa (aonde vc fez os testes antes de instalar no cliente), o proxy funciona certinho? ele esta com a mesma topologia da que vc esta utilizando em sua casa?


    Configura se você esta com os arquivos .bat criado no netlogon?

    Abraços



  11. #11

    Padrão

    No ambiente que montei funciona corretamente.

    A topologia é a mesma a unica diferenca é que no cliente é x64 e aqui é x32.

    No netlogon eu tenho o proxyauth como manda a regra, mas o servidor nao consegue se comunicar com o Domain Controller.

    Como faço pra juntar ele ao dominio? Pode ser que resolva o problema?

    Em ultimo caso tenho a sua sugestao de usar o ntlm que tbm utiliza a base do AD mas pelo que verifiquei nao é tao simples quanto o smb_auth. O ncsa parece simples mas obriga a criacao de usuario no tbm linux.

    O ntlm é complexo mesmo?

  12. #12

    Padrão

    Opa, vc pode esclarecer uma coisa, seu proxy é seu firewall tb ?



  13. #13

    Padrão

    Positivo.

    Meu proxy tbm faz o papel de Firewall.

    A internet entra diretamente nele e atraves do IPTABLES faço encaminhamento de portas, liberacao de algumas conexoes como Conectividade Social entre outros.

    E redireciono o trafego da porta 80 para 3128.