Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão PING perde pacote para o link da telefonica.

    Pessoal,
    tenho um link dedicado da telefônica que entra na placa de rede eth0 do meu servidor linux com a função de Gateway (roteador/NAT) e sai pela eth1 indo para o meu switch que distribui para minha rede interna.
    Ao pingar de um pc interno o IP da minha placa eth1, não perco pacote.
    Ao pingar do servidor o IP da ponta que esta na telefônica, não perde pacote.
    Mas, ao pingar o IP da telefônica de qualquer PC da minha rede interna, perde pacote.

    Por que será?
    Será o switch? Se fosse o switch não era pra perder quando eu desse ping de um pc da rede interna para a eth1 do servidor também?
    Será minha placa de rede? Se fosse a placa de rede, a mesma coisa, não era pra perder quando eu desse ping da minha rede interna pro servidor, ou do servidor pra IP da telefônica?

    Meu servidor é um debian com 512 de memória e processador Intel(R) Pentium(R) 4 CPU 1.70GHz.
    Através do comando top no linux vi que o máximo que ele consome de memória é 256 e CPU nem 20%. Acho que isso não seria, ou pode ser?

    Vi também que meu trafego chega a 90% do seu total.

    Bom, acho que coloquei as informações necessárias e consegui expressar meu problema.
    É isso aí, valeu!!

  2. #2

    Padrão

    Bom Dia
    isso é normal nesta quantidade de uso do seu link
    a proposito de quanto é seu link
    lembrado que um link de 2mb nao chega de fato a 2048kbps e sim a 1960kbps devido a configuração dos modens sem contar com o tamanho do cabelho do protocolo ,e por o protocolo do ping nao ter prioridade o que acontece é o descarte de pacotes,
    precisa ver se seu link perde pacotes a 50% de trafego ai sim
    e olhar no roteador se esta incrementando erros de CRC ou imput error
    eu considero que em um link de 2mb 1900k esteja de bom tamanho
    qualquer duvida postar ae



  3. #3

    Padrão

    Tenho 30mb passados por fibra ótica. O ping é o último a ter passagem, mas creio eu se ainda tem link sobrando, ele tem que dar ping normal, sem perder. Só iria perder pacote se a banda, o link, estivesse todo sendo usado, o que não é o caso.
    Tenho dúvidas sobre esses erros de CRC ou input error.
    O que seria?
    E só acrescentando mais sobre o problema, no servidor tenho o iptables com algumas regras de icmp(ping).
    iptables -A INPUT -d eth0 -p icmp -m icmp --icmp-type echo-request -m limit --limit 3/sec -i eth0 -j ACCEPT
    iptables -A INPUT -p icmp -m icmp --icmp-type echo-request -i eth0 -j LOG --log-prefix " ICMP DENY"
    iptables -A INPUT -p icmp -m icmp --icmp-type echo-request -i eth0 -j DROP

    Creio também que essas regras não tem interferência alguma.

  4. #4

    Padrão

    Citação Postado originalmente por MrJoe Ver Post
    Tenho 30mb passados por fibra ótica. O ping é o último a ter passagem, mas creio eu se ainda tem link sobrando, ele tem que dar ping normal, sem perder. Só iria perder pacote se a banda, o link, estivesse todo sendo usado, o que não é o caso.
    Com essa quantidade toda de link, era pra voce ter um servidor um pouco melhor não?



  5. #5

    Padrão

    Mas você viu que o uso da memória e do processador estão baixo?
    Será isso mesmo?
    Se fosse não era pra estar com a memória no talo e a CPU com uso alto no processamento?

  6. #6

    Padrão

    Broder, hoje em dia, existe em todos so pcs desde os processadores Pentiu II e similares da epoca uma coisa chamada DMA...

    Vou explicar: Quando vco esta usando o PC como servidor de internet ou arquivos, ele nao precisa usar o processador pra fazer calculos, basta ele intruir e dizer "arquivo ou dado tal, passe por este local" e pronto. o resto o sistema faz.

    Quando vc roteia um pc, ele carrega na memoria as instruções necessarias ao pc mostrar qual é o caminho que o dado deve seguir, nesse caso de uma placa a outra atraves das trilhas da placa mãe segundo as regras que vc definiu e pronto... o processador nao fica fiscalizando a acao pois o recurso de DMA (acesso direto a memoria e a dispositivos) esta ativado. (desative o DMA que vc vai ver a carroca que vai cficar e como o processador vai ficar louco)

    Esse seu pc por ser um pouco mais antigo, deve possuir chipsets e memorias mais limitados e nao estao conseguindo fazer com que o trafego de 30MiB flua bem.

    Um Pentium 4 ou superior com 1gb de memoria viria a calhar. 30 Mib é muito trafego.

    Dá uma checada tambem na sua placa de rede.



  7. #7

    Padrão

    Aproveitando o gancho do que o Pedro0278 falou, se você puder testar o link substituindo este servidor por um roteador ADSL (de preferência, Gigabit), será mais fácil você eliminar algumas dúvidas do tipo hardware em mal-funcionamento e a própria perda de pacote com roteamento.

    abracos

  8. #8

    Padrão Configuração da porta de rede.

    MrJoe, tive problema parecido com um link de 50 megas, quando passava de 30 megas começava a descartar pacotes, o problema é que o link e o switchs estavam em "auto-negociação", de um lado o link subia como 100 FD e do outro lado subia como 100 HD (não sei porque mas é isso que acontecia), forcei ambos em 100FD e a coisa fluiu. Tenta aí.



  9. #9

    Padrão

    Amigo,

    Aumente o tamanho do ping e verifique se vai aumentar a perda, se aumentar a perda e o tráfego do seu link vai bater nos 100% de uso.

    César.

  10. #10

    Padrão

    Pedro, muito orbigado. Fiz o que você disse, troquei o servidor por um outro melhor e agora está funcionando perfeitamente. Valeu pela força!!!

    Frusciante, não tinha pensado nisso, boa ideia. Vou deixar um roteador ADSL aqui de backup, qualquer problema utilizo ele para testes. Valeuuu!!!

    Israel, já tinha verificado isso.. de acordo com a telefonica meu roteador tem que estar com 100baseTx-FD. Valeu pela dica!

    Cesar, tinha aumentado o tamanho do ping, além dele não chegar no 100% começou a perder mais ainda. Valeu pela ajuda!

    Considero esse tópico fechado, a troca do servidor por um melhor foi resolvido.
    Como fecha o tópico? Ou são os administrador do under-linux que fecham? rs!
    Obrigado a todos!!



  11. #11

    Padrão

    Possuo um roteador cisco 1751v , mas uso adsl ainda pois possuo poucos clientes, gostaria de saber se tenho como usar esse roteador da cisco com adsl.

    a infra ta assim:

    linha telefonica - modem adsl - MK eth 01 - clientes eth 02

  12. #12

    Padrão

    Usar esse roteador praque se ele é pra funcionar em conjunto com um modem MDSL e nao ADSL?

    Ele nao vai ter utilidade alguma.



  13. #13

    Padrão

    Citação Postado originalmente por marcosddc Ver Post
    Bom Dia
    isso é normal nesta quantidade de uso do seu link
    a proposito de quanto é seu link
    lembrado que um link de 2mb nao chega de fato a 2048kbps e sim a 1960kbps devido a configuração dos modens sem contar com o tamanho do cabelho do protocolo ,e por o protocolo do ping nao ter prioridade o que acontece é o descarte de pacotes,
    precisa ver se seu link perde pacotes a 50% de trafego ai sim
    e olhar no roteador se esta incrementando erros de CRC ou imput error
    eu considero que em um link de 2mb 1900k esteja de bom tamanho
    qualquer duvida postar ae
    Se nao chega a 2mb nao é full dedicado....... Tinha um que era 2048 Cravados!

  14. #14

    Padrão

    Citação Postado originalmente por Pedro0278 Ver Post
    Usar esse roteador praque se ele é pra funcionar em conjunto com um modem MDSL e nao ADSL?

    Ele nao vai ter utilidade alguma.
    Pedro, tenho um roteador desse e ele tem interface ADSL tbm.... porem nunca usei...



  15. #15

    Padrão

    Citação Postado originalmente por damacenoneto Ver Post
    Pedro, tenho um roteador desse e ele tem interface ADSL tbm.... porem nunca usei...
    Esse ai que voces falam nao é aquele de 3 portas Ethernet?

  16. #16

    Padrão

    O vendedor me indicou para link full mdsl. O que queria saber é se colocar ele com um bom modem adsl melhoraria alguma coisa. Na verdade eu nem sei se da pra fazer isso.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         DSC02478.JPG
Visualizações:	100
Tamanho: 	1,31 MB
ID:      	4020   Clique na imagem para uma versão maior

Nome:	         DSC02475.jpg
Visualizações:	238
Tamanho: 	1,52 MB
ID:      	4021  

    Clique na imagem para uma versão maior

Nome:	         DSC02477.jpg
Visualizações:	135
Tamanho: 	1,36 MB
ID:      	4022  



  17. #17

    Padrão

    Citação Postado originalmente por damacenoneto Ver Post
    Se nao chega a 2mb nao é full dedicado....... Tinha um que era 2048 Cravados!

    infelizmente isso é fisicamente , teoricamente e tecnicamente impossivel ja que o modem é configurado a 1980

  18. #18

    Padrão

    Citação Postado originalmente por FernandodeDeus Ver Post
    O vendedor me indicou para link full mdsl. O que queria saber é se colocar ele com um bom modem adsl melhoraria alguma coisa. Na verdade eu nem sei se da pra fazer isso.
    Pelas fotos que vc postou é desse mesmo que estou falando, é um router MSDL nao serve pra ADSL.

    Eu tenho um mais novo e fino que esse, o Cisco 2600 tem mais portas e tudo mai e nao serve pra ADSL. pra ele funcionar vc tem que ter o modem MDSL. logado a ele, pra dai entao vc ter a saida do link dedicado.



  19. #19

    Padrão

    é só o nosso amigo comprar um wic com porta ADSL pq o cisco 1751 faz roteamento adsl tbm..
    e isso de dizer que o router 1751 só funciona pra mdsl eu nunca tinha escutado. rsrsr na verdade ele funciona em qualquer tecnologia que entreque o sinal para ele em um cabo serial v.35..

    msdsl é apenas uma forma de transmissão de sinal.. existe tbm shdsl, xdsl, adsl, entre outras, cada um com suas caractericas...

  20. #20

    Padrão

    Citação Postado originalmente por libo8 Ver Post
    e isso de dizer que o router 1751 só funciona pra mdsl eu nunca tinha escutado. rsrsr na verdade ele funciona em qualquer tecnologia que entreque o sinal para ele em um cabo serial v.35..

    msdsl é apenas uma forma de transmissão de sinal.. existe tbm shdsl, xdsl, adsl, entre outras, cada um com suas caractericas...
    Desculpe, mas eu ainda nao vi um modem ADSL que use cabo serial V.35 (ate onde sei que usa esse cabo são modens MSDSL)

    Se vejo modens ADSL com USB, Ethernet ou Wireless.

    Se voce tem um ai posta a imagem ou mande o link pra eu verificar.