+ Responder ao Tópico



  1. #1

    Padrão Proxy com squid.. depois entrar no mkt

    Boa tarde galera....

    Eu recentimente.. montei o servidor de proxy em paralelo com mkt.. mais adquiri outro link.... e estou tentando, tirar o squid de trabalhar em paralelo e trabalhar antes... tento o contato direto com o link...

    a topologia fikaria a seguinte...

    1 link 2 link
    | |
    |_ _ _ _ _|
    |
    |
    |
    Squid
    |
    |
    MKT


    Eu axo que no mikrotik fikaria assim:

    Renomear as interfaces=

    Como de costume, eu nomeio as interfaces:

    Passo 1:
    /interface set ether1 name=internet/squid
    /interface set ether2 name=rede


    Passo 2:
    ■ Ajustar os ips das interfaces:

    /ip address add address=172.121.40.1/24 interface=internet/squid
    /ip address add address=192.168.10.1/24 interface=rede

    Passo 3:
    ■ Compartilhar à internet com o linux e os clientes:

    /ip firewall nat add chain=srcnat src-address=192.168.10.0/24 action=masquerade comment="Masquerade para a rede"

    Passo 4:
    ■ Criar o hotspot

    Passo 5:
    ■ Configurar os DNS.

    Axo que essa configuração no mkt ja iria funcionar.. depois faz um boa configuração de firewall... com QOs...

    Agora vem a parte invocada como configurar o squid.

    queria tirar umas duvidas basicas... para depois começar montar...

    eu tenho 2 links que eh adsl....
    eu faria eles 2 roteados.. por um dlink ..e um outro roteador link's ou ate mesmo outro dlink( eh bom esses router )

    o gateway deles real eh o mesmo.. mais no codigo no squid.conf seria o gateway dos meus roteadores e naum o gateway real neh ?

    eu no servidor teria 3 interfaces... eth0 = 1 link eth1 = 2 link eth3 = rede/mkt ?

    as regras de balanceamento seria como o iptables?

    eu to estudando como vo fazer isso logo logo eu posto pra vc´s corrigir minha buradas...
    hehehe

    obrigado por tudo.. galera under....

    t +

  2. #2

    Padrão

    Cara, aqui eu entro 2 links no Mikrotik usando LoadBalance, e saio para o Linux com Squid.



  3. #3

    Padrão

    eu tbm estou usando assim....
    tem como c da uma olhada na minha configuraçaõ ??

    Duvidas no webproxy em paralelo com debian


    eu sinto a net um poko pressa.... axo q tem algo errado.. .hehe

    obrigado

  4. #4

    Padrão

    Citação Postado originalmente por mktguaruja Ver Post
    eu tbm estou usando assim....
    tem como c da uma olhada na minha configuraçaõ ??

    Duvidas no webproxy em paralelo com debian


    eu sinto a net um poko pressa.... axo q tem algo errado.. .hehe

    obrigado
    Paralelo, né. Testei e tive essa impressão também, meio presa. Contudo eu não uso assim. Tenho 2 NAT, um no MK e outro no CentOS, um liga no outro por um cabo Cross. Todo o controle é feito no CentOS, o MK só LoadBalance.



  5. #5

    Padrão

    Alguma novidade aqui ???

    O Squid tem uma opção que faz certos clientes sairem por um ou outro IP, a saber tcp_outgoing_address, veja Squid 2.7.STABLE6 Configuration File: tcp_outgoing_address o meu problema é que o squid só registra o ip da interface do mikrotik eth0 ao qual esta conectado.
    link1\
    link2 \
    ...... \
    ......../--switch--(eth0-ubuntu server-eth1)---(eth0-mikrotik)
    ......./
    linkn/
    Última edição por numlock; 23-04-2009 às 00:26. Razão: ortografia

  6. #6

    Padrão

    Citação Postado originalmente por numlock Ver Post
    Alguma novidade aqui ???

    O Squid tem uma opção que faz certos clientes sairem por um ou outro IP, a saber tcp_outgoing_address, veja Squid 2.7.STABLE6 Configuration File: tcp_outgoing_address o meu problema é que o squid só registra o ip da interface do mikrotik eth0 ao qual esta conectado
    link1\
    link2 \
    ...... \
    ......../--swich--(eth0-ubuntu server-eth1)---(eth0-mikrotik)
    ......./
    linkn/
    Interessante isso, vo dar uma olhada.



  7. #7

    Padrão

    ei vc disse que esse sistema de link --->squid --->Mk--->cliete..
    sentio a net meio pressa?
    estava pensando em fazer esse sistema aki...é so 1link dedicado

  8. #8

    Padrão

    o meu fiko um poko presa em paralelo com proxy...
    mais provavelmente seja algo errado que fiz..
    muitos fez e axou excelente....
    o meu eh erro de conf.. tem algo errado....

    tenta fazer.. eh uma otima solucao...

    t +