Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Oi pessoal,

    Estou aqui neste fórum mais uma vez solicitar ajuda dos colegas, para resolvemos juntos o meu problema, já estou a dias quebrando a cabeça com este problema, como não encontre solução para o problema, achei melhor pedir ajuda ao fórum. Vamos ao problema, estou configurando um dns primário e secundário utilizando o slackware 12.1 usando e o bind-9.3.1, segue baixo as configurações de cada servidor.

    MASTER (named.conf)

    options {
    directory "/conf";
    pid-file "/var/run/named.pid";
    statistics-file "/var/run/named.stats";
    dump-file "/var/run/named.db";
    transfer-format many-answers;
    # hide our "real" version number
    version "[secured]";
    };

    # Use with the following in named.conf, adjusting the allow list as needed:
    key "rndc-key" {
    algorithm hmac-md5;
    secret "minhachave==";
    };

    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { "rndc-key"; };
    };
    # End of named.conf

    # The root nameservers
    zone "." {
    type hint;
    file "db.rootcache";
    };

    # localhost - forward zone
    zone "localhost" {
    type master;
    file "db.localhost";
    notify no;
    };

    # localhost - inverse zone
    zone "0.0.127.in-addr.arpa" {
    type master;
    file "db.127.0.0";
    notify no;
    };

    zone "128-191.xxx.xxx.200.in-addr.arpa" IN {
    type master;
    notify yes;
    file "/conf/master/128-191.xxx.xxx.200.zone";
    allow-transfer { 200.xxx.xxx.131; };
    };

    // Domain Default
    zone "bogus.com.br" IN {
    type master;
    notify yes;
    file "/conf/master/bogus.com.br";
    allow-transfer { 200.xxx.xxx.131; };
    };

    Obs. O servidor master esta transferindo a zona bogus.com.br para o servidor slave, já a zona reversa não consegue ser transferida.

    SLAVE (named.conf)

    options {
    directory "/conf";
    pid-file "/var/run/named.pid";
    statistics-file "/var/run/named.stats";
    dump-file "/var/run/named.db";
    transfer-format many-answers;
    # hide our "real" version number
    version "[secured]";
    };

    # Use with the following in named.conf, adjusting the allow list as needed:
    key "rndc-key" {
    algorithm hmac-md5;
    secret "minhachave==";
    };

    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { "rndc-key"; };
    };
    # End of named.conf

    # The root nameservers
    zone "." {
    type hint;
    file "db.rootcache";
    };

    # localhost - forward zone
    zone "localhost" {
    type master;
    file "db.localhost";
    notify no;
    };

    # localhost - inverse zone
    zone "0.0.127.in-addr.arpa" {
    type master;
    file "db.127.0.0";
    notify no;
    };

    // Reverse
    zone "128-191.xxx.xxx.200.in-addr.arpa" {
    type slave;
    file "/conf/slave/128-191.xxx.xxx.200.in-addr.arpa.rev";
    masters { 200.xxx.xxx.130; };
    };

    // Domain Default
    zone "bogus.com.br" {
    type slave;
    file "/conf/slave/bogus.com.br";
    masters { 200.xxx.xxx.130; };
    };

    Obs. Meu dns esta rodando como chroot.

    Segue as permissões das pasta e arquivos:

    MASTER/SLAVE:


    em anexo permisao.pdf

    Ja instalei também o bind-9.4.3-P1 e o corre o mesmo problema, ou seja ele não transfere a zona reversa para o servidor slave, so transfere o domínio bogus.com.br, alguém já teve este problema ou sabe como posso resolver?

    Agradeço desde já a todos que me ajudarem!!!
    Miniaturas de Anexos Miniaturas de Anexos permisao.pdf  

  2. Seu firewall slave recebe tcp 53 ? Acho que pra transferencia de zona vc precisa liberar o 53 tcp, nesse site aqui so funciono o teste do transfer com o a porta 53 tcp aberta; G E E K T O O L S, testa ae, vai em tool depois no fim da pagina dig ae seleciona teste de transferencia, vlw !!!



  3. Citação Postado originalmente por GuE Ver Post
    Seu firewall slave recebe tcp 53 ? Acho que pra transferencia de zona vc precisa liberar o 53 tcp, nesse site aqui so funciono o teste do transfer com o a porta 53 tcp aberta; G E E K T O O L S, testa ae, vai em tool depois no fim da pagina dig ae seleciona teste de transferencia, vlw !!!
    Gue,

    nao estou usando firewall em nenhum dos servidores, segue o teste como vc me solicitou!

    bogus.com.br

    ; <<>> DiG 8.2 <<>> @200.xxx.xxx.131 bogus.com.br AXFR
    ; (1 server found)
    $ORIGIN bogus.com.br.
    @ 1D IN SOA localhost. root (
    2 ; serial
    3H ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum

    1D IN NS ns1.bogus2.com.br.
    1D IN NS ns2.bogus2.com.br.
    1D IN MX 0 mx
    1D IN MX 10 mx
    localhost 1D IN A 127.0.0.1
    1D IN HINFO "INTEL/110" "LINUX"
    ns1 1D IN A 200.xxx.xxx.4
    ns2 1D IN A 200.xxx.xxx.5
    www 1D IN A 200.xxx.xxx.130
    @ 1D IN SOA localhost. root (
    2 ; serial
    3H ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum

    ;; Received 1 answer (11 records).
    ;; FROM: gp.centergate.com to SERVER: 200.xxx.xxx.131
    ;; WHEN: Wed Apr 15 06:21:41 2009


    128-191.xxx.xxx.200.in-addr.arpa

    ; <<>> DiG 8.2 <<>> @200.xxx.xxx.131 128-191.xxx.xxx.200.in-addr.arpa AXFR
    ; (1 server found)
    ;; Received 0 answers (0 records).
    ;; FROM: gp.centergate.com to SERVER: 200.xxx.xxx.131
    ;; WHEN: Wed Apr 15 06:23:51 2009

  4. Bom nunca fiz dns no slackware, porem no debian centos e derivados ta vendo ali na sua config tem @ 1D, então ou vc tira o @ ou subistitui o 1D por @ entendeu ? pois vc ta colocando @ 1D in SOA, e no ns1 vc ta chamando o 1D porem o primeiro parametro ta @ e o ns ta apontando 1D, e tb creio que não precisa mostrar ali
    ns1 1D IN A 200.xxx.xxx.4
    ns2 1D IN A 200.xxx.xxx.5

    Tira o 1D, deixa ns1 IN A IP, verifica ae.
    Última edição por GuE; 15-04-2009 às 12:22.



  5. Segue minhas configs no debian e centos não sei se muda no slack

    $ttl 78000
    @ IN SOA bells.ripcurl.com.br. gueneto.gmail.com. (
    22012009
    10800
    3600
    432000
    38400 )

    @ IN MX 5 astrix
    @ IN NS astrix
    @ IN NS bells
    astrix IN A 200.228.110.7
    luna IN A 192.168.3.252
    bells IN A 200.228.110.4
    kunka IN A 192.168.3.251
    www IN CNAME astrix
    ftp IN CNAME astrix






Tópicos Similares

  1. Bind nao funcioa :(
    Por nopp_lnx no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-02-2005, 17:35
  2. BIND não resolve
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 21-07-2004, 11:54
  3. Zona reversa
    Por beastie no fórum Servidores de Rede
    Respostas: 3
    Último Post: 04-10-2003, 06:07
  4. Zona Reversa
    Por beastie no fórum Servidores de Rede
    Respostas: 8
    Último Post: 25-09-2003, 15:28
  5. BIND não aceita conexões
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-01-2003, 09:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L