Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Redirecionar youtube para um único link

    Pessoal,
    Já li e reli várias vezes esre tópico do nosso amigo Roberto21:
    Mikrotik X youtube...perda de tempo...

    Fiz as regras e elas funcionam ok.. como mostra a imagem anexa, os contadores delas estão marcado o tráfego.
    Porém, agora quero jogar esses pacotes do youtube para um link separado.
    Já uso o mark routing para marcar os pacotes vindos de uma das minhas redes de clientes e funciona sem problemas...
    Mas qnd tentei usar o mark routing para marcar os pacotes que contém youtube (content = youtube) o youtube para de abrir....
    Alguém já direcionou todo o tráfego do youtube para um link separado?

    Agradeço desde já,
    Abs
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         youtube.jpg
Visualizações:	587
Tamanho: 	26,4 KB
ID:      	4009  

  2. #2

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Pessoal,
    Já li e reli várias vezes esre tópico do nosso amigo Roberto21:
    Mikrotik X youtube...perda de tempo...

    Fiz as regras e elas funcionam ok.. como mostra a imagem anexa, os contadores delas estão marcado o tráfego.
    Porém, agora quero jogar esses pacotes do youtube para um link separado.
    Já uso o mark routing para marcar os pacotes vindos de uma das minhas redes de clientes e funciona sem problemas...
    Mas qnd tentei usar o mark routing para marcar os pacotes que contém youtube (content = youtube) o youtube para de abrir....
    Alguém já direcionou todo o tráfego do youtube para um link separado?

    Agradeço desde já,
    Abs
    Estou a procura disso também.



  3. #3
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Redirecionar Youtube

    Amigo qual a versão do seu MK?? Na versão 3.22 as marcações de rotas foram corrigidas.

  4. #4

    Padrão

    Estou usando a 2.9.27... se fizer o up para a 3.22 será que funciona?



  5. #5
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Versão

    2.9.27 era pra estar funcionando então deve ser erro de configuração mesmo.

  6. #6

    Padrão

    Citação Postado originalmente por minelli Ver Post
    2.9.27 era pra estar funcionando então deve ser erro de configuração mesmo.
    Menos mal..rs.. e vc tem alguma dica pra gnt do que podemos estar errando?



  7. #7

    Padrão

    fera coloca por destino é mais certo ex add route 208.0.0.0/24 distance 2 link2, tentei varias vezes por mark routing e parava de abrir....
    tem os tuto ae

  8. #8

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Pessoal,
    Já li e reli várias vezes esre tópico do nosso amigo Roberto21:
    Mikrotik X youtube...perda de tempo...

    Fiz as regras e elas funcionam ok.. como mostra a imagem anexa, os contadores delas estão marcado o tráfego.
    Porém, agora quero jogar esses pacotes do youtube para um link separado.
    Já uso o mark routing para marcar os pacotes vindos de uma das minhas redes de clientes e funciona sem problemas...
    Mas qnd tentei usar o mark routing para marcar os pacotes que contém youtube (content = youtube) o youtube para de abrir....
    Alguém já direcionou todo o tráfego do youtube para um link separado?

    Agradeço desde já,
    Abs


    ontem li um artigo q existe uma ferramenta para se usar junto com o squid no linux em q vc ve os arquivos q foram pra cache e vc faz uma marcaçao nele (ou copia pra outro lugar no disco, nao lembro direito) q na proxima vez q for acessado um arquivo com mesmo nome, independente da data e do host usado, ja baixaria esse arquivo de mesmo nome.... o unico problema ai seria os vaaarios videos q devem acessar por dia, mas vc podia marcar apenas os mais acessados...
    da uma pesquisada ai sobre isso...

    mas se vai so direcionar mesmo, coloca a classe inteira
    208.0.0.0/8 ou /24 como falaram ai....



  9. #9

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    ontem li um artigo q existe uma ferramenta para se usar junto com o squid no linux em q vc ve os arquivos q foram pra cache e vc faz uma marcaçao nele (ou copia pra outro lugar no disco, nao lembro direito) q na proxima vez q for acessado um arquivo com mesmo nome, independente da data e do host usado, ja baixaria esse arquivo de mesmo nome.... o unico problema ai seria os vaaarios videos q devem acessar por dia, mas vc podia marcar apenas os mais acessados...
    da uma pesquisada ai sobre isso...

    mas se vai so direcionar mesmo, coloca a classe inteira
    208.0.0.0/8 ou /24 como falaram ai....
    Opa, valeu amiigos,
    Estou viajando nesse feriado, mas volto amanha.. não vou arriscar fazer nada remoto... rs.. Mas volto amanha aí crio a rota para a classe inteira e posto como ficou!
    Sobre a ferramente citada.. estou usando o tundercache.. cache efetivo para youtube e diversoso outros sites de vídeos, windowsupdate, antivírus.. etc.. é fantástica.. e por isso quero direcionar o youtube todo para esse servidor.. que está rodando o thunder..
    Alterando amanha, posto os resultados.
    Obrigado por enquanto pessoal!
    Valeu, abs

  10. #10

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Opa, valeu amiigos,
    Estou viajando nesse feriado, mas volto amanha.. não vou arriscar fazer nada remoto... rs.. Mas volto amanha aí crio a rota para a classe inteira e posto como ficou!
    Sobre a ferramente citada.. estou usando o tundercache.. cache efetivo para youtube e diversoso outros sites de vídeos, windowsupdate, antivírus.. etc.. é fantástica.. e por isso quero direcionar o youtube todo para esse servidor.. que está rodando o thunder..
    Alterando amanha, posto os resultados.
    Obrigado por enquanto pessoal!
    Valeu, abs

    legal, deve ser esse ai mesmo q li, pois o cara tb falou q tinha muitos arquivos de windows update, oq vc ta usando é o descrito nesse tutorial:
    Thunder Cache - Cache inteligente ?

    sera q é melhor q esse sistema:
    Linux: Cache do Youtube efetivo no Linux [Artigo] ?

    pelo menos parece ser mais facil...rs


    ah! tava olhando o torch aqui e vi q uns videos do youtube vem da serie de ips 74.125.6.X talvez vc tenha q colocar 74.0.0.0/8 em destination tb....
    abraços
    Última edição por lelyrock; 19-04-2009 às 15:26.



  11. #11

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    legal, deve ser esse ai mesmo q li, pois o cara tb falou q tinha muitos arquivos de windows update, oq vc ta usando é o descrito nesse tutorial:
    Thunder Cache - Cache inteligente ?

    sera q é melhor q esse sistema:
    Linux: Cache do Youtube efetivo no Linux [Artigo] ?

    pelo menos parece ser mais facil...rs


    ah! tava olhando o torch aqui e vi q uns videos do youtube vem da serie de ips 74.125.6.X talvez vc tenha q colocar 74.0.0.0/8 em destination tb....
    abraços
    Amigo,
    Estou usando o Thunder Cache (ThunderCache.org).
    O desenvolvedor é o Luiz Biazus, o mesmo do outro link que vc passou, então concluo que se trata do mesmo sistema, mas o Thunder é a versão mais nova e atualizada. Entre no site e dê uma olhada.. é muito bom e muito fácil de instalar!
    Valeu pela dica da outra classe de ip.. como disse, amanha testo e posto os resultados.
    Valeu por enquanto!
    Abs

  12. #12

    Padrão

    Amigos,
    Valeu pelas dicas.. mas ainda não foi..rs
    Coloquei a rota para as classes citadas.. dou um tracert -d YouTube - Broadcast Yourself. e sai pela rota que defini certinho... o problema é qnd vou abrir algum vídeo.. ele abre a página mas não carrega o vídeo.. talvez seja algum problema entre o meu sistema de cache e o redirecionamento.. mas quem ler este post e quiser tentar jogar dessa forma, pela rota, acho que vai dar certo.
    Vou analisar mais um pouco aqui...se descobrir algo posto aqui!
    Obrigado por enquanto!



  13. #13

    Padrão

    bom apesar de tentar ajudar nunca usei, mas pelo meu raciocinio pode ser duas coisas:

    1- o seu tunder cache q pode estar faltando alguma configuraçao e ele nao ta fazendo o armazenamento ou nao ta repassando..... antes de vc jogar ele nessa nova rota, ele funcionava?
    2- o youtube tem varios servidores e em classes de ip diferentes, parece q o conteudo html sai pelo 208.x.x.x e os videos mesmo em *flv sai por outras classes.... eu sitei o 74.x.x.x pq foi 1 video q eu vi, talvez o video q vc viu ta em outro servidor, em outra classe... usa o torch pra vc ver todas as classses q aparecem...


    se nao for isso mas se conseguir de outra forma posta os resultados pra gente pq isso é mto interessante....

  14. #14

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    bom apesar de tentar ajudar nunca usei, mas pelo meu raciocinio pode ser duas coisas:

    1- o seu tunder cache q pode estar faltando alguma configuraçao e ele nao ta fazendo o armazenamento ou nao ta repassando..... antes de vc jogar ele nessa nova rota, ele funcionava?
    2- o youtube tem varios servidores e em classes de ip diferentes, parece q o conteudo html sai pelo 208.x.x.x e os videos mesmo em *flv sai por outras classes.... eu sitei o 74.x.x.x pq foi 1 video q eu vi, talvez o video q vc viu ta em outro servidor, em outra classe... usa o torch pra vc ver todas as classses q aparecem...


    se nao for isso mas se conseguir de outra forma posta os resultados pra gente pq isso é mto interessante....
    Certo amigo, quanto às questões que vc levantou:
    1 - O meu server Mk funciona com 2 classes de IP, sendo que uma sai pelo link1 e a outra sai pelo link2.. faço esse balance há um bom tempo através de marcação de pacotes no mangle... cada link passa, antes de chegar para o Mk, em um servidor linux para fazer cache.. minha topologia fica da seguinte forma:

    LINK 1 LINK 2
    | |
    SERVER1 SERVER2
    | |
    \ /
    \ /
    MIKROTIK
    |
    CLIENTES

    O Server 2 é onde está instalado o Ubuntu com o Thunder Cache. Os os clientes pertencentes à rede marcada para o Link2 passam por ele e usam o Thunder perfeitamente, os vídeos são armazenados e acompanho pelo iptraf a economia que faço de link. Bom, em resumo o Tunder tá ok, mas só quando a marcação do pacote é feita sobre a rede. O que queria fazer é marcar os pacotes do youtube dos clientes que saem pelo link 1 para direcionar só estes pacotes deles, por enquanto, para o link2... pq eu não instalo o thunder no server1? Pq vou precisar aumentar memória e hd..rs.. e já fiz isso no server2.. coloquei 1TB lá..rs.. pq o Thunder armazena tudo..hehe
    O estranho é que se dá certo marcar os pacotes da rede para o link2... pq não dá qnd eu marco só do youtube?,,rs.. essa é a questão..

    2- Tentei marcar a rota para 208.0.0.0/8 (/24 nem abriu o site, /8 abriu o site mas não carregou os vídeos) e 74.0.0.0/8.. abre td normal.. só não começa a carregar o vídeo...

    Vou tentando aqui e posto novidades, pode deixar!
    Mais uma vez obrigado pela atenção amigo!
    Abs



  15. #15

    Padrão

    Humm.. depois que postei que vi que minha topologia saiu desconfigurada...rs..
    Mas o esquema queria demostrar o seguinte:
    LINK 1 - SERVER1 - MKSERVER
    LINK2 - SERVER2 - MKSERVER
    MKSERVER - CLIENTES

    blza?
    Qq dúvida eu esclareço melhor..rs

  16. #16

    Padrão

    se tira o 74.0.0.0/8 os videos deve sair pelo link 1 ne? faz o teste deixando so o 208.0.0.0/8



  17. #17

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    se tira o 74.0.0.0/8 os videos deve sair pelo link 1 ne? faz o teste deixando so o 208.0.0.0/8
    Fiz esse teste agora.. mas deixando as duas rotas ativadas ou só a 208.0.0.0/8 acontece a mesma coisa, abre a página normal do vídeo, mas o player só fica preto e não roda o vídeo..

    continuo tentando..rs

  18. #18

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Fiz esse teste agora.. mas deixando as duas rotas ativadas ou só a 208.0.0.0/8 acontece a mesma coisa, abre a página normal do vídeo, mas o player só fica preto e não roda o vídeo..

    continuo tentando..rs
    parece q o orkut tb abre pelo 74.0.0.0/8..... redirecionando essa rota pro seu lin2 o orkut abre normalmente?
    se abrir e passar pelo link2 o problema deve ser no cache de arquivos em *flv mesmo.... vc disse q ele ta armazenando... entao talvez por algum motivo nao esta repassando....

    ideia meio loka pra teste:
    tenta baixar um video do youtube usando um gerenciador de downloads ao invez do browser (free download manger)



  19. #19

    Padrão

    iai, conseguiu resolver?
    to querendo implantar o thundercahe aqui tb....

  20. #20

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    iai, conseguiu resolver?
    to querendo implantar o thundercahe aqui tb....
    Amigo, o thunder funciona 100%, mas ainda não consegui jogar todas as requisições do youtube para ele. As redes marcadas para sair pelo link com o thunder passam sem problemas. Continuo pesquisando.. mas se vc quiser implantar o thunder com certeza é uma ótima opção!