Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde galera do underlinux,
    Eu li muito topicos e sempre tirando umas duvidas mais nada o proxy paralelo funcionar correto.
    Ele da umas travadas quando vai abrir as paginas, e quando eu baixo um arquivo.. tem vez que vem a 1,2mb/s tem vez q vem a taxa normal.. de donwloads.
    O meu mikrotik eh a famosa 2.9.27 cracked
    Um AMD Durom de 900mhz 512MB HD 10gb
    e fiz a seguinte conf...
    Renomeie as interfaces

    EthClientes
    EthModem
    EthDebian

    / ip address

    192.168.10.1/24 - EthClientes
    192.168.0.1/24 - EthModem
    192.168.20.1/24 - EthDebian

    / ip routes

    GW: 192.168.0.1

    / ip firewall filter
    add chain=input in-interface=EthModem protocol=tcp dst-port=3128 action=drop comment="BLOQUEIO DE PROXY EXTERNO" disabled=no

    /ip firewall magle

    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" action=mark-connection new-connection-mark=squid-connection-HIT passthrough=yes \
    comment="CACHE FULL SQUID-DEBIAN" disabled=no
    add chain=output connection-mark=squid-connection-HIT action=mark-packet new-packet-mark=squid-packet-HIT passthrough=yes comment="" disabled=no
    add chain=prerouting p2p=all-p2p action=mark-connection new-connection-mark=P2P-Conexao passthrough=yes comment="CONTROLE P2P" disabled=no
    add chain=prerouting protocol=tcp tcp-flags=syn p2p=all-p2p connection-limit=15,24 action=mark-connection new-connection-mark=P2P-Conexao-Limite \
    passthrough=yes comment="" disabled=no
    add chain=prerouting connection-mark=P2P-Conexao action=mark-packet new-packet-mark=P2P-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting connection-mark=P2P-Conexao-Limite action=mark-packet new-packet-mark=P2P-Pacotes passthrough=no comment="" disabled=no


    /ip firewall nat

    / ip firewall nat
    add chain=srcnat src-address=192.168.20.0/30 action=masquerade comment="Compartilha conex o com Debian" disabled=no
    add chain=srcnat src-address=192.168.10.0/24 action=masquerade comment="Compartilha conex o com Clientes" disabled=no
    add chain=pre-hotspot in-interface=EthClientes src-address=192.168.10.0/24 dst-address=!192.168.20.2 protocol=tcp dst-port=80 hotspot=auth action=redirect \
    to-ports=3128 comment="REDIRECIONAMENTO WEBPROXY" disabled=no
    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" transparent-proxy=yes parent-proxy=192.168.20.2:5128 cache-administrator="CAMPELO-NET" \
    max-object-size=1KiB cache-drive=system max-cache-size=unlimited max-ram-cache-size=unlimited

    / ip web-proxy access
    add src-address=192.168.10.0/24 action=allow comment="Passando Clientes para Squid" disabled=no
    add action=deny comment="" disabled=no
    add url="http://www.speedyzone/wsc/" action=deny comment="" disabled=no
    add url="http://speedyzone/wsc/" action=deny comment="" disabled=no
    add url="http://www.speedy.zone/wsc/" action=deny comment="" disabled=no
    add url="speedy.zone/wsc/" action=deny comment="" disabled=no
    add url="http://200.171.222.97/wsc/" action=deny comment="" disabled=no
    add dst-port=23-25 action=deny comment="" disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no
    add url="https://" action=deny comment="don't cache dynamic https pages" disabled=no

    / queue tree
    add name="P2P" parent=QOS packet-mark=P2P-Pacotes limit-at=128000 queue=default priority=5 max-limit=128000 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no
    add name="Cache Full Squid-Debian" parent=global-out packet-mark=squid-packet-HIT limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no

    Essa eh minha configuração que fiz no mikrotik... tudo esta minando certinho ele controla p2p, os jogos. Mais cache full de alguns programas naum esta funcionando. em seguida vo posta o a configuração de debian

  2. no debian a conf eh a seguinte...
    Um ibm x3200 2gb de memoria hd 160gb sata 2 xeon 1.8ghz
    eu instalo o debian aparti de um dvd baixado no site do debian

    assim que instalado o debian eu mudo os repositor deles no sources.list

    e a a seguir do o comando
    #apt-get update
    depois
    #apt-get install ssh
    depois
    #apt-get install squid

    depois eu do as permições

    chmod 777 /var/spool/squid
    chmod 777 /var/log/squid
    chown proxy.proxy /var/spool/squid
    chown proxy.proxy /var/log/squid

    depois digito
    #gedit /etc/squid/squid.conf

    e coloco o seguinte squid

    # Squid primeira versão gerada por Jean Frank de A. Lima 12/11/2008 16:31
    # Colaborou Adriano Jorge V. M. Junior
    # Squid segunda versão gerada por Jean Frank de A. Lima 22/12/2008 08:08
    # Squid terceira versão gerada por Jean Frank de A. Lima 05/02/2009 09:07
    # Primenet - www.primenetmtv.com.br
    # Regras de segurança, iptables realizados pelo Mikrotik
    http_port 5128
    visible_hostname proxy
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563 # msn
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 70 # protocolo gopher
    acl Safe_ports port 210 # whais
    acl Safe_ports port 1024-65535 # portas altas
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multi http
    acl Safe_ports port 901 # acesso swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safe_ports
    http_access deny CONNECT !SSL_PORTS
    # Permissão de acesso ao proxy - rede Mikrotik
    # Classe de rede ou classes separadas por espaço
    acl redelocal src 192.168.20.1
    http_access allow localhost
    http_access allow redelocal
    # Regras novas liberar temp
    always_direct allow all
    # Bloquear todos os outros acessos
    http_access deny all
    # Access Log
    cache_access_log /var/log/squid/access.log
    # Cache log
    cache_log /var/log/squid/cache.log
    # Memoria reservada para o cache total de 40% do disponivel
    cache_mem 128 MB
    # Maximo tamanho dos arquivos cache na memoria
    maximum_object_size_in_memory 96 KB
    # Regras novas monitoramento
    ipcache_size 1024
    ipcache_low 90
    ipcache_high 93
    # Maximo tamanho dos arquivos cache no HD
    maximum_object_size 102400 KB
    minimum_object_size 0 KB
    # Regra que começa a esvaziar/substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90
    # Regras novas policiamento memoria
    memory_replacement_policy lru
    # Regras novas adicionais policiamento memoria
    # memory_replacement_policy heap GDSF
    # cache_replacement_policy heap LFUDA
    # Indicação de localização da pasta de arquivos cache em sequencia valor
    # total em MB de espaço no HD a ser usado pelo cache/numero de pastas/ lor
    # e subpastas.
    cache_dir ufs /var/spool/squid 1500048 16 256
    # Intervalo de tempo que o proxy verifica os arquivos do site acessados
    # conferem com o do cache. O valor 2280 significa a cada 2 dias
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280
    # Mantendo objetos recentes e pequenos na memoria
    # Pools em 32 MB
    memory_pools off
    memory_pools_limit 0
    ########################-FIM-########################################

    Entuam vim aki pedir a ajuda e vc´s....
    c voces poder me ajuda fikaria muito grato.
    obrigado a todos..



  3. mktguaruja

    Aconselharia ao amigo em adquirir uma licença do mk, antes até o ano passado eu usava esta versão crackeada e funcionava relativamente bem mas quando comecei a trabalhar balanceamento, umas regras de firewall mais elaboradas etc começou a dar problema, intabilidade etc comprei um licença level 4 e nunca digo nunca mais tive os problemas indicados isto no mesmo micro, esta semana estou trocando de pc e comprei desta vez a level 5 paguei R$ 285,00 e esta show aqui.

    ps: claro que pode ser algum problema com suas regras ai teria que analizar mas de qualquer forma seria um bom começo a troca pela versão original

    abraços

  4. Citação Postado originalmente por jeanfrank Ver Post
    mktguaruja

    Aconselharia ao amigo em adquirir uma licença do mk, antes até o ano passado eu usava esta versão crackeada e funcionava relativamente bem mas quando comecei a trabalhar balanceamento, umas regras de firewall mais elaboradas etc começou a dar problema, intabilidade etc comprei um licença level 4 e nunca digo nunca mais tive os problemas indicados isto no mesmo micro, esta semana estou trocando de pc e comprei desta vez a level 5 paguei R$ 285,00 e esta show aqui.

    ps: claro que pode ser algum problema com suas regras ai teria que analizar mas de qualquer forma seria um bom começo a troca pela versão original

    abraços
    Qual seria uma versao boa para comprar.. continuar com a 2.9.27 ? ou 2.9.51 ??
    qual q seria um micro ideal para rodar o mikrotik ?
    teria como vc da uma analisada nas minhas regras..

    Obrigado.. por tudo



  5. Opa, mktguaruja

    Eu tbm uso MK+Squid paralelo, vamos ver se consigo te ajudar
    ja tive muitos problemas com isso e tem muitos outros topicos com esse mesmo problema aqui no forum, mas so pra confirmar, dura quanto tempo ate ele travar? dependendo do tempo ..

    # Access Log
    cache_access_log /var/log/squid/access.log
    # Cache log
    cache_log /var/log/squid/cache.log


    tente desativar essas regras ou fazer um rotate nos arquivos logs pois com tempo ele pode começar tomar o desempenho do servidor.
    percebi q vc usa parent proxy
    e ainda usando memoria Unlimited

    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" transparent-proxy=yes parent-proxy=192.168.20.2:5128 cache-administrator="CAMPELO-NET" \
    max-object-size=1KiB cache-drive=system max-cache-size=unlimited max-ram-cache-size=unlimited

    Tente estipular um menor valor para o uso da memoria, dependendo de qunto vc tem disponivel.. 512Mb, eu usaria 128mb, MAS, como não uso mais parent proxy e sim DST-NAT, faço o controle de memoria todo pelo squid mesmo, pois foi aii q tive problemas nessa area..
    hoje uso dst-nat..
    se o cache-full estiver ativado nao é uma boa ideia liberar toda a banda para os pacotes que saem a full, as vzes podem sufocar os seus radios

    como é muita coisa vamos por partes, rsrs altera essas configurações que as proximas vamos ver se o squid ta consumindo memoria (usando o comando free -k ou free -m), o seu tipo de placa ethernet pode não estar suportando o trafego entre outros pontos.. é tudo muito relativo e dificil de dizer sem analizar bem... ainda não vou arriscar palpite do que possa ser o problema

    valeu posta ai os resultados..
    espero ter ajudado
    Última edição por Squire; 24-04-2009 às 15:12.






Tópicos Similares

  1. PTP com maior capacidade - Ajuda por favor
    Por brunobelas no fórum Redes
    Respostas: 7
    Último Post: 02-08-2015, 11:45
  2. Respostas: 2
    Último Post: 08-10-2008, 16:54
  3. Cash Full no Mikrotik - Ajuda por favor!!!
    Por masterduvida no fórum Redes
    Respostas: 3
    Último Post: 01-07-2008, 06:08
  4. Respostas: 6
    Último Post: 24-01-2008, 15:59
  5. redirecionamento com iptables, preciso de ajuda por favor
    Por valdirscarin@yahoo.com.br no fórum Servidores de Rede
    Respostas: 2
    Último Post: 28-11-2005, 13:18

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L