Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Problema com PPPoE

    Bom dia Pessoal,

    Estou tendo muito problema com pppoe, alguns clientes conectam mas nao navega e em outros funciona normal, mesmo com sinal exelente acontece esse problema, alguem ja passou por isso sabe o que pode ser feito para resolver esse problema.

  2. #2
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Servidor PPPoE (no próprio Mikrotik) mal configurado.

    Crie um perfil (em PPP/Profiles) com as seguintes ítens configurados (clique no + para adicionar):
    . Use compression: No
    . Use VJ compression: No
    . Use Encription: No
    . Change TCP MSS: Yes.

    Provavelmente corrigirá.



  3. #3

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Servidor PPPoE (no próprio Mikrotik) mal configurado.

    Crie um perfil (em PPP/Profiles) com as seguintes ítens configurados (clique no + para adicionar):
    . Use compression: No
    . Use VJ compression: No
    . Use Encription: No
    . Change TCP MSS: Yes.

    Provavelmente corrigirá.
    MarceloGOIAS,

    Muito obrigado por sua resposta agil, irei modifica essa configuraçãoes e postarei os resultatos, atualmente estava usando assim.
    . Use compression: default
    . Use VJ compression: default
    . Use Encription: Yes
    . Change TCP MSS: Yes.

  4. #4

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Servidor PPPoE (no próprio Mikrotik) mal configurado.

    Crie um perfil (em PPP/Profiles) com as seguintes ítens configurados (clique no + para adicionar):
    . Use compression: No
    . Use VJ compression: No
    . Use Encription: No
    . Change TCP MSS: Yes.

    Provavelmente corrigirá.
    Boa tarde Marcelo,

    Aprovetei a abertura desse tópico, mesmo eu não encontrando esse tipo de problema em minha rede, fui verificar a configuração que vc citou e fiz alterações confirme vc mencionou.
    Agora eu verifico que é criada uma chain em Mangle (in e out), para cada usuario que conecta no pppoe, é isso mesmo?

    Abraços



  5. #5
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Sim, é verdade. Tinha problemas com MSN?

  6. #6

    Padrão

    MarceloGOIAS,

    realmente diminuiu, mas ainda continua em uma minuria de cliente, andei pesquizando aki no forum tenho visto que muitas pessoas tiveram esse mesmo problema são post antigos nao sei se consequiram resolve, olha so tenho um cliente que esta com sinal em -64 dBm ack em 30 ele conctar bunitim no pppoe navega nos primeiros segundos ai para de navegar tento o ping com o servidor e nd. pq será isso.



  7. #7
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Ponha a MTU no PPPoE Server em 1452.

  8. #8

    Padrão

    Amigo
    de uma olhada nas configs das sua velocidades
    na aba /Limites do /ppp profile


    rate limit rx/tx 45k/150k
    rx -- upload
    tx -- download

    quem sabe ta trocado ai



  9. #9

    Padrão

    Citação Postado originalmente por iceboxrj Ver Post
    Amigo
    de uma olhada nas configs das sua velocidades
    na aba /Limites do /ppp profile


    rate limit rx/tx 45k/150k
    rx -- upload
    tx -- download

    quem sabe ta trocado ai
    Obrigado pelo enterece no assunto, o gerenciamento de banda e clientes é feito via radius.

    Estou quase ciente que PPPoE em rede Wireless não é uma boa alternativa, estive lendo aki mesmo no forum muitos relatos de outros colegas com problemas similares, MarceloGOIAS mudei o MTU como vc indicou, mas continua com o mesmo problema nesse cliente, irei posta aki algumas conf que estou usando aki.

    name="PPPoE-Srv" local-address=Local-1 remote-address=Remoto-1 use-compression=no use-vj-compression=no
    use-encryption=no only-one=default change-tcp-mss=yes dns-server=200.200.200.200

    /interface pppoe-server server
    add authentication=chap,mschap1,mschap2 default-profile=PPPoE-Srv disabled=no interface=wlan1 keepalive-timeout=60 \
    max-mru=1492 max-mtu=1452 max-sessions=0 mrru=disabled one-session-per-host=yes service-name=NOMEAMIGAVEL

  10. #10
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Amigo,

    sempre uso o PPPoE no Mikrotik e não tenho problemas. Mude o MRU também para 1452. Reinicie o servidor, desconecte e reinicie o computador do cliente e verifique se não é algum problema no computador dele.

    E o Radius está bem configurado? Não adianta pôr a culpa no Mikrotik se o problema estiver em outro lugar...rs



  11. #11

    Padrão

    derrepente e alguma config do seu radius
    uso pppoe em mk faz 3 anos
    funciona perfeito

    faca uma revisao no seu radius
    com lupa

    tente fazer autenticacao apenas com chap

  12. #12

    Padrão

    Amigo faça o seguinte, altere o MTU e o MRU teste com os seguintes valores:

    Max MTU 1480
    Max MRU 1492

    Abraços

    Clecio Rodrigo



  13. #13

    Padrão

    Citação Postado originalmente por cleciorodrigo Ver Post
    Amigo faça o seguinte, altere o MTU e o MRU teste com os seguintes valores:

    Max MTU 1480
    Max MRU 1492

    Abraços

    Clecio Rodrigo
    Pessoal muito obrigado pela atenção de todos, isso que diferencia o esse forum dos outros, mas vamus lá.

    Depois de muito pesquizar, lento o manual (infelismente so tem do 2.9), uso o MK 3.23 acabei encontranto um dados inportante.

    "max-mru (integer; default: 1480) - Maximum Receive Unit. The optimal value is the MTU of the interface the tunnel is working over decreased by 20 (so, for 1500-byte Ethernet link, set the MTU to 1480 to avoid fragmentation of packets)
    max-mtu (integer; default: 1480) - Maximum Transmission Unit. The optimal value is the MTU of the interface the tunnel is working over decreased by 20 (so, for 1500-byte Ethernet link, set the MTU to 1480 to avoid fragmentation of packets)"

    Ele pede para mudar o valor de 20 em 20 é isso mesmo?

    mais na frente em soluçoes de problemas tem,


    • I can get through the PPPoE link only small packets (eg. pings)
      You need to change mss of all the packets passing through the PPPoE link to the value of PPPoE link's MTU-40 at least on one of the peers. So for PPPoE link with MTU of 1480:
      [[email protected]] interface pppoe-server server> set 0 max-mtu=1440 max-mru=1440
      [[email protected]] interface pppoe-server server> print
      Flags: X - disabled
      0 service-name="mt" interface=wlan1 max-mtu=1440 max-mru=1440
      authentication=pap,chap,mschap1,mschap2 keepalive-timeout=10
      one-session-per-host=yes max-sessions=0 default-profile=default
      [[email protected]] interface pppoe-server server>

    no meu caso não passa nada.

    enthaum resolvi mudar os valor mtu e mru para 1440, aparentemente resolveu o problema so falta verificar em um cliente, que nao esta no momento.

    Quaquer coisa me avisem ai.

  14. #14
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    1440 é muito baixo. Provavelmente continuará a ter problemas. 1452 (MTU e MRU) é o ideal para quem usa links ruins, especialmente ADSL.



  15. #15

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    1440 é muito baixo. Provavelmente continuará a ter problemas. 1452 (MTU e MRU) é o ideal para quem usa links ruins, especialmente ADSL.
    .

    Marcelão, ja que tocou no assunto, explica ai a questão do MTU e MRU, aqui uso em 1488, mais tento faz por 1452, 1500, 1480. Fica super estavel... Mais mesmo assim, eu não sei o que isso faz, gostaria de uma opinão de quem entende do assunto ai. O que é o MTU e MRU, e como utilizar em diferentes ocasioes.

  16. #16

    Padrão

    recomendo criar uma regra de MSS GERAL pra todos... ocupa menos recurso do servidor... (recomendacoes no manual do mikrotik)



  17. #17

    Padrão

    Alexandre no caso o mikrotik cria duas regras pra cada conexão pppoe, cada uma com um valor diferente, como as do print do meu mikrotik

    D chain=forward in-interface=<pppoe-luciacristina> protocol=tcp tcp-flags=syn action=change-mss new-mss=1440
    D chain=forward out-interface=<pppoe-luciacristina> protocol=tcp tcp-flags=syn action=change-mss new-mss=1452

    Como vc faz ae, usa somente um valor???

    Abraços

    Clecio

    Citação Postado originalmente por alexandrecorrea Ver Post
    recomendo criar uma regra de MSS GERAL pra todos... ocupa menos recurso do servidor... (recomendacoes no manual do mikrotik)

  18. #18

    Padrão

    / ip firewall mangle
    add action=change-mss chain=forward comment="Regra GERAL - Altera MSS para 1440" disabled=no new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535



  19. #19

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    / ip firewall mangle
    add action=change-mss chain=forward comment="Regra GERAL - Altera MSS para 1440" disabled=no new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
    Opa alexandre, aqui o MSS das regras dinamicas estão em 1412.. devo mudar para 1440? o que vai alterar? e sobre a questão do MTU/MRU que fiz la em cima.. sera que dava pra vc responder? abração...

  20. #20

    Padrão

    quanto maior melhor.. pois diminui o overhead.. por causa dos cabeçalhos..

    MTU significa que, quando for maior que o MTU/MSS especificado, sofrera uma fragmentacao... entao o ideal eh trabalhar 1492 ... e usar o mss (regra acima) .. em alguns casos eh necessario colocar esse MSS em 1440 por problemas de conexao (msn, ssl) ...