Visite: BR-Linux ·  VivaOLinux ·  LinuxSecurity ·  Dicas-L ·  NoticiasLinux ·  SoftwareLivre.org

+ Responder ao Tópico

  1. #1
    vmh0909
    Ola.

    estou usando o MK com hotspot em um hotel de 52Aptos, funciona muito bem, gostaria de saber se é possivel gerar algum log do trafego de rede, como por exemplo: horario, paginas acessadas, endereço mac do cliente, e usuario logado.

    se alguem puder me ajudar agradeço.


  2.    Publicidade


  3. #2
    Usando seu hotspot com radius seria uma opção.

    Poderá também ativar o web-proxy e o sistema de loging do mesmo. Existe um projeto, já detalhado aqui mesmo no Under sobre o proxylizer, ferramenta desenvolvida pela Mikrotik.

    Abaixo o link do Proxylizer:

    Proxylizer - MikroTik Wiki

  4. #3
    vmh0909
    Obrigado pela dica Sergio, alias Mikrotik voce é o cara, tive o prazer de participr do ultimo curso de voces aqui em floripa, muito proveitoso mesmo parabens.

    mas o que eu tava querendo mesmo é algo bem mais dificil,,, hehehehe, estou com uma RB450G e com cartão SD e gostaria de alguma coisa tipo um arquivinho neste cartão sem necesstar utilizar outro servidor com linux, mas se voce não conhece é melhor eu desistir,, .

    Obrigado mais uma vez e Sucesso.

  5. #4
    Citação Postado originalmente por vmh0909 Ver Post
    Obrigado pela dica Sergio, alias Mikrotik voce é o cara, tive o prazer de participr do ultimo curso de voces aqui em floripa, muito proveitoso mesmo parabens.

    mas o que eu tava querendo mesmo é algo bem mais dificil,,, hehehehe, estou com uma RB450G e com cartão SD e gostaria de alguma coisa tipo um arquivinho neste cartão sem necesstar utilizar outro servidor com linux, mas se voce não conhece é melhor eu desistir,, .

    Obrigado mais uma vez e Sucesso.
    hummm... Usando apenas o web-proxy poderá ter esses registros, com o sistema de log do mesmo. Estou apenas pensando é o espaço... esses logs, dependendo do volume do trafego, ficam enormes. Outra coisa, o usuário sempre usa o mesmo IP? Porque este sistema de log do web-proxy armazena sempre o src-address, desta forma o usuário deverá sempre possuir o mesmo IP. Configura o web-proxy e depois em system/loging ativa o log do web-proxy e dê uma analisada e verifique se atende.

    Outra ferramenta do Mikrotik que poderia utilizar seria o Calea ou Snnifer, mas eles só armazenariam os dados dos IPs de origem e destino. Estas 2 ferramentas armazenam o log de todas as conexões e não apenas acesso web.

    Qualquer dúvida manda aqui.

  6. #5
    vmh0909
    Respondendo a sua pergunta, o IP vai mudar sempre, pois como é um hotel, varios hospedes poderam utilizar o mesmo IP em um determinado periodo, mas vou testar todas as opções que voce me passou.
    Atualmente estou testando o proxylzer, com o vmware, que me pareceu bem interesante por eu poder utilizar uma maquina ja existente, sem a necessidade de ter um servidor linux só para isso, pois a ideia é diminuir custos ao maximo.

    vou fazer os testes e posto os resultados aqui.

    Um grande abraço.

  7. #6
    Citação Postado originalmente por vmh0909 Ver Post
    Respondendo a sua pergunta, o IP vai mudar sempre, pois como é um hotel, varios hospedes poderam utilizar o mesmo IP em um determinado periodo, mas vou testar todas as opções que voce me passou.
    Atualmente estou testando o proxylzer, com o vmware, que me pareceu bem interesante por eu poder utilizar uma maquina ja existente, sem a necessidade de ter um servidor linux só para isso, pois a ideia é diminuir custos ao maximo.

    vou fazer os testes e posto os resultados aqui.

    Um grande abraço.
    Blz. Já que está usando o vmware...hehehehe... implementa logo o radius. Outra coisa, você não mencionou, mas usando o hotspot poderá usar o user-manager do Mikrotik. Dá uma conferida.

  8. #7
    vmh0909
    bom com relaçao ao manager da mikrotik não gostei muito dele por isso fiz meu proprio em delphi.

    agora com ralaçao ao log's segu sua sugestão, só que no meio do caminho acabei descobrindo que eu posso gerar estes log's no proprio disco com o comando:

    /system logging add disk-file-count=5 disk-file-name=trafego disk-lines-per-file=100 disk-stop-on-full=no name=trafego target=disk
    /system loggingadd action=trafego disabled=no prefix="" topics=account

    desta forma o log gera umas linhas com o seguinte conteudo:

    MSN Brasil - Hotmail, Messenger, Entretenimento, Notícias, Esportes e Vídeo action=allow cache=MISS
    Jan/01/1970 00:25:22 web-proxy,account 10.5.50.254 GET

    bom ele me traz quase tudo o que eu preciso, apenas fica faltando o usuario do hotspot e o endereço mac

    bom seguindo o raciocinio ele ira gerar um arquivo chamado trafego.0.txt com 100 linhas e depois disso renomeia ele para trafego.1.txt e começa tudo de novo com o trafego.0.txt, ele gera até cinco arquivos.

    bom agora ficou mais facil, o meu aplicativo le tudo que for maior que trafego.0.txt salva em um banco de dados ja com todos os dados filtrados e organizados e em seguida apaga estes arquivos para que não sejam lidos novamente.

    minha pergunta é, sera que existe a possibilidade de eu gerar um log onde eu possa ter tambem a informação de qual usuario e endereço mac, ai sim a solução seria completa.

  9. Citação Postado originalmente por vmh0909 Ver Post
    Ola.

    estou usando o MK com hotspot em um hotel de 52Aptos, funciona muito bem, gostaria de saber se é possivel gerar algum log do trafego de rede, como por exemplo: horario, paginas acessadas, endereço mac do cliente, e usuario logado.

    se alguem puder me ajudar agradeço.
    Amigo gostaria de saber mais sobre o seu projeto no hotel, minha empresa esta atendendo varios hoteis em minha cidade e estou interessado nesse sistema.

    Obrigado pela atenção

  10. Olá, conseguiu algo com MAC, e o seu sistema em Delphi? Poste um log dele para nós vermos.

  11. #10
    vmh0909
    Ola consegui sim, porem tive que gerar 2 arquivos e depois fazer com que o sistema interprete os dois para gerar o histórico da conexão do usuario, mas funcionou.

    abaixo as linhas de comando utilizadas:

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=2048KiB \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=\
    no src-address=0.0.0.0
    /ip firewall nat
    add action=redirect chain=dstnat comment="redirecionar trafego Web proxy para gerar log" disabled=no dst-port=80 \
    in-interface=ether2 protocol=tcp to-ports=8080
    /ip firewall filter
    add action=drop chain=input comment="" disabled=no dst-port=8080 \
    in-interface=ether1 protocol=tcp
    /system logging action
    add disk-file-count=5 disk-file-name=acessos disk-lines-per-file=10000 \
    disk-stop-on-full=no name=acesso target=disk
    add disk-file-count=5 disk-file-name=usuarios disk-lines-per-file=100 \
    disk-stop-on-full=no name=usuario target=disk
    /system logging
    add action=acesso disabled=no prefix=<<<acesso>>> topics=web-proxy,!debug
    add action=usuario disabled=no prefix=<<<usuario>>> topics=hotspot


    O log do usuario ficara mais ou menos assim :

    May/10/2009 21:03:27 hotspot,debug <<<usuario>>>: hotspot1: dynamic host 10.5.49.150 removed: idle timeout
    May/10/2009 21:03:50 hotspot,debug <<<usuario>>>: hotspot1: dhcp host 10.5.49.156 removed: idle timeout
    May/10/2009 21:04:10 hotspot,info,debug <<<usuario>>>: 502 (10.5.49.149): logged out: keepalive timeout
    May/10/2009 21:04:10 hotspot,account <<<usuario>>>: 502 (10.5.49.149): 1779 503855 11142184 6303 8739 (keepalive timeout)
    May/10/2009 21:04:10 hotspot,debug <<<usuario>>>: 502 (10.5.49.149): removing queue
    May/10/2009 21:04:10 hotspot,debug <<<usuario>>>: 502 (10.5.49.149): removing ip->user binding
    May/10/2009 21:04:10 hotspot,debug <<<usuario>>>: hotspot1: dhcp host 10.5.49.149 removed: keepalive timeout
    May/10/2009 21:05:49 hotspot,debug <<<usuario>>>: hotspot1: new host detected 00:1A:73:38:05:FF/10.5.49.156 by ARP reply to 10.5.50.1
    May/10/2009 21:05:49 hotspot,debug <<<usuario>>>: hotspot1: dhcp host 00:1A:73:38:05:FF/10.5.49.156 added, ip 10.5.49.156
    May/10/2009 21:10:49 hotspot,debug <<<usuario>>>: hotspot1: dhcp host 10.5.49.156 removed: idle timeout
    May/10/2009 21:13:54 hotspot,debug <<<usuario>>>: hotspot1: new host detected 00:1C:BF:BB:96:F0/10.5.49.145 by UDP :63327 -> 200.247.141.11:53
    May/10/2009 21:13:54 hotspot,debug <<<usuario>>>: hotspot1: dhcp host 00:1C:BF:BB:96:F0/10.5.49.145 added, ip 10.5.49.145
    May/10/2009 21:17:52 hotspot,info,debug <<<usuario>>>: 411 (10.5.49.145): trying to log in by http-chap
    May/10/2009 21:17:52 hotspot,debug <<<usuario>>>: 411 (10.5.49.145): using profile <apto>


    e o log das conexões assim:
    May/19/2009 17:16:27 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/swf/l.swf?swf...jpg&sk=CVm5b47 action=allow cache=MISS
    May/19/2009 17:16:27 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/swf/l.swf?swf...jpg&sk=CVm5b47 action=allow cache=MISS
    May/19/2009 17:16:28 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/swf/l.swf?swf...jpg&sk=CVm5b47 action=allow cache=MISS
    May/19/2009 17:16:38 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.barbixas.com.br/blog/wp-c...3/foto_sbc.jpg action=allow cache=MISS
    May/19/2009 17:16:47 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/v/OgziBK4U0bo...olor2=0xfebd01 action=allow cache=MISS
    May/19/2009 17:16:47 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/v/nzqPiPdHSx4...olor2=0xfebd01 action=allow cache=MISS
    May/19/2009 17:16:47 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/v/-H9MZF0o_wU...olor2=0xfebd01 action=allow cache=MISS
    May/19/2009 17:16:47 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/v/ClCNZbzjX1U...olor2=0xfebd01 action=allow cache=MISS
    May/19/2009 17:16:47 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/v/0kmJjBXfszI...olor2=0xfebd01 action=allow cache=MISS
    May/19/2009 17:16:47 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.youtube.com/v/wn02sym_alU...olor2=0xfebd01 action=allow cache=MISS
    May/19/2009 17:16:56 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://csm51.url.trendmicro.com/PT/1...94553C1027A943 action=allow cache=MISS
    May/19/2009 17:16:57 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://andyatoa.blogspot.com/www.imp...br/agenda.html action=allow cache=MISS
    May/19/2009 17:16:57 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.blogger.com/static/v1/v-c...ad_content.css action=allow cache=MISS
    May/19/2009 17:16:58 web-proxy,account <<<acesso>>>: 10.5.49.249 GET http://www.blogger.com/img/sides_body.png action=allow cache=MISS


    Tive que fazer a associar a daa hora ip e mac para saber exatamente que esta utilizando, mas deu certo.

    se precisar de mais alguma coisa é só mandar.


  12.    Publicidade




Tópicos Similares

  1. Log de paginas acessadas
    Por guibarretos no fórum Serviços
    Respostas: 1
    Último Post: 18-06-2009, 09:26
  2. Respostas: 6
    Último Post: 31-08-2007, 19:38
  3. Respostas: 3
    Último Post: 29-05-2007, 09:38
  4. Rastrear origem de um IP
    Por thelast no fórum Serviços
    Respostas: 4
    Último Post: 08-10-2005, 04:08
  5. logsss ond rastrear
    Por ederamboni no fórum Redes
    Respostas: 1
    Último Post: 18-05-2005, 14:43