Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal

    tenho um squid paralelo (sem usar o proxy do mk) assim:

    link --> mk --> clientes
    ............|
    ............|
    ............V
    .........squid

    no mk so uso a regra de redir pro squid :

    ;;; PROXYCLIENTES
    chain=dstnat action=dst-nat to-addresses=172.16.2.2 to-ports=5128 src-address=192.168.0.0/16
    src-address-list=!hotspotgateway dst-address-list=!semproxy in-interface=Rede_Eth4_CLIENTES dst-port=80 protocol=tcp

    nos logs do meu squid, so aparece o ip do mk 172.16.2.1

    como faço pra logar os ips da rede 192.168.0.0/16???

    tem q habilitar algo na arp da interface???

    tks

  2. Citação Postado originalmente por ThunderBRZ Ver Post
    Pessoal

    tenho um squid paralelo (sem usar o proxy do mk) assim:

    link --> mk --> clientes
    ............|
    ............|
    ............V
    .........squid

    no mk so uso a regra de redir pro squid :

    ;;; PROXYCLIENTES
    chain=dstnat action=dst-nat to-addresses=172.16.2.2 to-ports=5128 src-address=192.168.0.0/16
    src-address-list=!hotspotgateway dst-address-list=!semproxy in-interface=Rede_Eth4_CLIENTES dst-port=80 protocol=tcp

    nos logs do meu squid, so aparece o ip do mk 172.16.2.1

    como faço pra logar os ips da rede 192.168.0.0/16???

    tem q habilitar algo na arp da interface???

    tks

    Olá amigo,


    para resolver isto é necessário que vc faça duas coisas:

    a primeira é criar um novo gateway no seu mk com a faixa de ip do seu squid e dá nome a essa rota;

    add dst-address=0.0.0.0/0 gateway=10.100.100.1 scope=255 target-scope=10 \
    routing-mark=nova comment="" disabled=no

    a segunda é em firewal mangle desviar as conexões da página as conexões a porta 80 para a rota específicada

    add chain=prerouting protocol=tcp dst-port=80 src-address-list=!desmarcar \
    action=mark-routing new-routing-mark=nova passthrough=no comment="regra do \


    a regra em vermelho poderá ser utilizada para excluir determinado endereço de entrada de forma que não passe pelo proxy e será util se o gateway do linux for seu MK, pois terá que deixar o ip de retorno do linux fora do proxy para não criar reduntância;


    Feito isso vc precisa entrar na maquina linux que está com o squid e configurar a rota de retorno para os ips dos cliente, por exemplo:

    imagine que vc criou a sua rede com esse ip que citei no exemplo de forma que o servidor linux se interaja com o mikrotik pelo ip 10.100.100.2 com gateway 10.100.100.1 e que a faixa do seu clientes é 192.168.0.0/24

    vc precisar criar no linux uma rota que diga que rota de saida para esses ips é através da interface 10.100.100.2 com gw 10.100.100.1, pois caso contrário o linux não saberá a quem devolver as requisicoes;

    para resolver o problema acima em azul de uma forma mais fácil vc pode fazer com que o gateway do linux também seja o MK de forma que todas as requisicoes seriam devolvidas para gateway



  3. amigo vc tambem precisa desativar o nat para a interface que esta o seu squid

  4. se vc adicionar uma rota.. e tirar a rede de destino do mascaramento...



  5. No seu squid.conf você tem que liberar a faixa de rede dos clientes também.
    Código :
    acl redeC src 192.168.0.0/24
    http_access allow redeC






Tópicos Similares

  1. Problema note positivo z85, nao recebe ip do mk!
    Por alanvictorjp no fórum Redes
    Respostas: 5
    Último Post: 20-11-2008, 16:08
  2. Squid sem mascarar o ip do cliente
    Por thiagotg no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-10-2008, 14:49
  3. Cliente como o mesmo IP do MK
    Por Pantanero2006 no fórum Redes
    Respostas: 7
    Último Post: 18-03-2008, 07:12
  4. log do squid não pega o ip´s clientes
    Por sando_pira no fórum Servidores de Rede
    Respostas: 3
    Último Post: 07-08-2005, 18:41
  5. Squid - autenticação pelo endereço IP do micro.
    Por andunno no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-03-2004, 12:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L