Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Talking Balanceamento entre 3 links 's

    Bom dia a todos

    Eu estava lendo o topico do usuario jeanfrank, alias parabens para ele.. otimo post.

    Balanceamento 5 links Perfeito !!!!!

    E estou rabiscando primeiramente para min ... heheh
    rabiscando no bloco de notas para depois fazer os testes, rsrs


    tem como a galera da um olhada nas anotações, pois troquei faixas de ip..fiz marcações com outros nomes praticamente tudo do zero, usei a logika demostrada pelo jeanfrank. A classe de ip 192.168.10.253/24 é o proxy paralelo do nosso amigo pcram que estou testando.
    Os meus link's são adsl de 2megas, e estou querendo colocar eles nun roteador linksys que não tem wireless, dizem que é muito bom.
    Outra coisa que eu estava pensando, o codigo abaixo eh o balanceamento com 3 links adsl. Queria saber se 1 ou 2 link cair...1 link assumiria tudo ??
    bem galera eh isso ai.. espero a ajuda de vc´s ;;;

    /ip address
    add address=172.31.110.10/24 network=172.31.110.0 broadcast=172.31.110.255 interface=EthClientes comment="" \
    disabled=no
    add address=192.168.1.254/24 network=192.168.1.0 broadcast=192.168.1.255 interface=EthWan1 comment="" \
    disabled=no
    add address=192.168.2.254/24 network=192.168.2.0 broadcast=192.168.2.255 interface=EthWan2 comment="" \
    disabled=no
    add address=192.168.3.254/24 network=192.168.3.0 broadcast=192.168.3.255 interface=EthWan3 comment="" \
    disabled=no
    add address=192.168.10.253/24 network=192.168.10.0 broadcast=192.168.10.255 interface=EthIntranet comment="" \
    disabled=no
    / ip firewall address-list
    add list=EthWan1 address=192.168.1.254 comment="" disabled=yes
    add list=EthWan2 address=192.168.2.254 comment="" disabled=yes
    add list=EthWan3 address=192.168.3.254 comment="" disabled=yes
    minha duvida aqui seria se fika desabilitado mesmo ??
    /ip firewall magle
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan1 \
    action=mark-connection new-connection-mark=connection_EthWan1 \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan1 \
    action=mark-routing new-routing-mark=routing_EthWan1 \
    passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan2 \
    action=mark-connection new-connection-mark=connection_EthWan2 \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan2 \
    action=mark-routing new-routing-mark=routing_EthWan2 \
    passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan3 \
    action=mark-connection new-connection-mark=connection_EthWan3 \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan3 \
    action=mark-routing new-routing-mark=routing_EthWan3 \
    passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=EthCliente connection-state=new nth=2,2,0 \
    action=mark-connection new-connection-mark=nth_EthWan1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=nth_EthWan1 \
    action=add-src-to-address-list address-list=EthWan1 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=nth_EthWan1 \
    action=mark-routing new-routing-mark=rout_EthWan1 passthrough=no \
    comment="" disabled=no

    add chain=prerouting in-interface=EthCliente connection-state=new nth=2,2,1 \
    action=mark-connection new-connection-mark=nth_EthWan2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=nth_EthWan1 \
    action=add-src-to-address-list address-list=EthWan2 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=nth_EthWan1 \
    action=mark-routing new-routing-mark=rout_EthWan2 passthrough=no \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-state=new nth=2,2,2 \
    action=mark-connection new-connection-mark=nth_EthWan3 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=nth_EthWan3 \
    action=add-src-to-address-list address-list=EthWan3 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=nth_EthWan3 \
    action=mark-routing new-routing-mark=rout_EthWan3 passthrough=no \
    comment="" disabled=no

    /ip firewall nat
    add chain=srcnat connection-mark=EthWan1 action=src-nat \
    to-addresses=192.168.1.253 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=EthWan2 action=src-nat \
    to-addresses=192.168.2.253 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=EthWan3 action=src-nat \
    to-addresses=192.168.3.253 to-ports=0-65535 comment="" disabled=no

    /ip route list
    Destination: 0.0.0.0/0
    gateway: 192.168.1.254
    Mark: EthWan1
    Destination: 0.0.0.0/0
    gateway: 192.168.2.254
    Mark: EthWan2
    Destination: 0.0.0.0/0
    gateway: 192.168.3.254
    Mark: EthWan3

    Aqui eh o fim xD....
    muito obrigado pela força...
    t+

  2. #2

    Padrão

    galera minha logika ta mais ou menos certa?????

    me ajudem......

    devo roteador o modem ou colocar um roteador ?????


    muitoo obrigadoo



  3. #3

    Thumbs up

    Citação Postado originalmente por mktguaruja Ver Post
    galera minha logika ta mais ou menos certa?????

    me ajudem......

    devo roteador o modem ou colocar um roteador ?????


    muitoo obrigadoo

    Este Load vai atender diretamente os clientes ? se vai passar para outro servidor e depois para os clientes recomendo que use a opção basica por NTH com modems em modo router !

    https://under-linux.org/f96456-loadbalance-wiki-com-3-adsl-4

    Abraços

  4. #4

    Thumbs up

    Teste este modo que você esta querendo utilizar,mas para min não deu certo pois depois do load vai para outros servidores ! em neste caso ficou so utilizando o primeiro link.



  5. #5

    Padrão

    Eu adaptei suas regras para min, so dei uma rabiscada ainda naum coloquei em pratica vo testa amanha tem como da uma verificada para min ve c ta tudo certinho ??

    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=EthClientes comment="" \
    disabled=no
    add address=10.0.0.138/24 network=10.0.0.0 broadcast=10.0.0.255 interface=EthWanTouch \
    comment="" disabled=no
    add address=192.168.254.254/24 network=192.168.254.0 broadcast=192.168.254.255 interface=EthWanStream \
    comment="" disabled=no
    add address=10.1.1.1/24 network=10.1.1.0 broadcast=10.1.1.255 interface=EthWanDlink \
    comment="" disabled=no

    / ip firewall mangle
    add chain=prerouting in-interface=EthClientes connection-state=new nth=2,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=EthClientes connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=EthClientes connection-state=new nth=2,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=EthClientes connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=EthClientes connection-state=new nth=2,1,2 \
    action=mark-connection new-connection-mark=ode passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=EthClientes connection-mark=ode action=mark-routing \
    new-routing-mark=ode passthrough=no comment="" disabled=no

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.0.0.138 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=192.168.254.254 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=ode action=src-nat to-addresses=
    10.1.1.1 \
    to-ports=0-65535 comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.0.138 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=ode \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 comment="" \
    disabled=no

    dns que coloquei no ip>dns>
    primario 208.67.222.222
    secundario 208.67.220.220

    eu vo testar ele.. eu tava pensando eu uso um LB604 da dlink, sera q eu consigo fazer mesa coisa q ele faz.. dividir por porcentagem igual o dlink .. cada link 30% de uso... o outro tbm e o outro 40% sera q tem como ou nuam ?


    obrigado a todos !!!

  6. #6

    Smile Coisa errada

    Citação Postado originalmente por Giovani.couto Ver Post
    Teste este modo que você esta querendo utilizar,mas para min não deu certo pois depois do load vai para outros servidores ! em neste caso ficou so utilizando o primeiro link.
    Bom dia Giovani, se vc tentou fazer o load balance que postei e mesmo assim só sai por um link vc deve ter feito algo incorreto se precisar de alguma dica é só falar

    abraços



  7. #7

    Smile Erros

    Bom dia mktguaruja

    Este bloco está errado
    ip firewall address-list
    add list=EthWan1 address=192.168.1.254 comment="" disabled=yes
    add list=EthWan2 address=192.168.2.254 comment="" disabled=yes
    add list=EthWan3 address=192.168.3.254 comment="" disabled=yes
    minha duvida aqui seria se fika desabilitado mesmo ??

    no lugar de address=192.168.1.254 vc vai colocar seu pref source aqui o meu é 192.168.1.253, mas seguinte desenvolvi uma forma melhor ainda pra fazer que elimina a criação de address list diretamente ai vc não precisa comentar a aba address list, me chama no msn mais tarde que te explico tudo, ai depois vc posta a correção e solução do problema

    abraços

  8. #8

    Padrão

    conversandu com o jean ..
    arrumei meus erros


    /ip address
    add address=172.31.110.10/24 network=172.31.110.0 broadcast=172.31.110.255 interface=EthClientes comment="" \
    disabled=no
    add address=192.168.1.253/24 network=192.168.1.0 broadcast=192.168.1.255 interface=EthWan1 comment="" \
    disabled=no
    add address=192.168.2.253/24 network=192.168.2.0 broadcast=192.168.2.255 interface=EthWan2 comment="" \
    disabled=no
    add address=192.168.3.253/24 network=192.168.3.0 broadcast=192.168.3.255 interface=EthWan3 comment="" \
    disabled=no
    add address=192.168.10.253/24 network=192.168.10.0 broadcast=192.168.10.255 interface=EthIntranet comment="" \
    disabled=no
    /ip firewall magle
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan1 \
    action=mark-connection new-connection-mark=EthWan1 \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan1 \
    action=mark-routing new-routing-mark=EthWan1 \
    passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan2 \
    action=mark-connection new-connection-mark=EthWan2 \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan2 \
    action=mark-routing new-routing-mark=EthWan2 \
    passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan3 \
    action=mark-connection new-connection-mark=EthWan3 \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting in-interface=EthClientes src-address-list=EthWan3 \
    action=mark-routing new-routing-mark=EthWan3 \
    passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=EthCliente connection-state=new nth=2,2,0 \
    action=mark-connection new-connection-mark=EthWan1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=EthWan1 \
    action=add-src-to-address-list address-list=EthWan1 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=EthWan1 \
    action=mark-routing new-routing-mark=EthWan1 passthrough=no \
    comment="" disabled=no

    add chain=prerouting in-interface=EthCliente connection-state=new nth=2,2,1 \
    action=mark-connection new-connection-mark=EthWan2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=EthWan1 \
    action=add-src-to-address-list address-list=EthWan2 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=EthWan1 \
    action=mark-routing new-routing-mark=EthWan2 passthrough=no \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-state=new nth=2,2,2 \
    action=mark-connection new-connection-mark=EthWan3 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=EthWan3 \
    action=add-src-to-address-list address-list=EthWan3 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=EthCliente connection-mark=EthWan3 \
    action=mark-routing new-routing-mark=EthWan3 passthrough=no \
    comment="" disabled=no

    /ip firewall nat
    add chain=srcnat connection-mark=EthWan1 action=src-nat \
    to-addresses=192.168.1.253 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=EthWan2 action=src-nat \
    to-addresses=192.168.2.253 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=EthWan3 action=src-nat \
    to-addresses=192.168.3.253 to-ports=0-65535 comment="" disabled=no

    /ip route list
    Destination: 0.0.0.0/0
    gateway: 192.168.1.254
    Mark: EthWan1
    Destination: 0.0.0.0/0
    gateway: 192.168.2.254
    Mark: EthWan2
    Destination: 0.0.0.0/0
    gateway: 192.168.3.254
    Mark: EthWan3


    logo logo irei testar =D



  9. #9

    Thumbs up

    Citação Postado originalmente por jeanfrank Ver Post
    Bom dia Giovani, se vc tentou fazer o load balance que postei e mesmo assim só sai por um link vc deve ter feito algo incorreto se precisar de alguma dica é só falar

    abraços
    Olá Jean !

    Fiz como ta lá, pois eu quis ver como ficava só que utilizei só 2 links então ajeitei para minha situação !

    Só que, só tenho um cliente no meu load que é meu firewall e acho que foi por isso que só saiu no primeiro link todas as requisições !


    Talvez eu tenha errado! O problema e que agora já voltei para o meu básico antigo !

    Abraços

  10. #10

    Padrão

    tava dando uma estuda.. no ip> rules seria o pref source, esse seria o broadcast ou não ??
    como eu sei o pref source... eh qndo eu declaro q eu sei qual eh o pref source.
    Eu ainda naum testei pois ainda numa chego meu 3 adsl.

    e estou estudando bastante.



    obrigado por tudo



  11. #11

    Padrão

    olhA a minha duvida queria eu colocar 5 links balanceados no mk 3,23 sendo que uso o linux para proxy paralelo, hoje tenho 2 links balanceados por rotas redondom com o linux, agora queria fazer essa mudança, um pc com 7 placas 3com, mk 3.23 cf de 2G 1GRam, Dual Core
    agora a duvida como balancear 5 links, ficaria bom? alguem tem ? meus links sao Embratel Full 8mb e 4 Pme Embratel de 4mb todos ips fixo.

    obs como ficaria msn bancos que todos falam que da problema

  12. #12

    Thumbs up

    Olá !


    Sim fica bom em uma maquina separada !


    Você faz o balance normal para os 7 links por NTH e depois cria mais uma rota estatica escolhendo um destes links onde você vai colocar o MSN, Https e qualquer outra porta ou Ip para sair por ele !

    Não dando assim problemas de msn e bancos ou qualquer outra coisa !

    Abraços



  13. #13

    Padrão

    ok, mas eu uso aqui o mk 3.13 voce teria uma ideia de como balancear, o estranho de uns exemplos que vi aqui no forum o nth no mk da error argumento, pois no nth nao da pra colocar 2,2,1 ou sempre sao pro 2.9.x
    segue minha ideia esses ips sao ficticios

    Ether link1 10.1.1.1/8
    Ether link2 10.2.2.1/8
    Ether link3 10.3.3.1/8
    Ether link4 10.4.4.1/8
    Ether link5 10.5.5.1/8
    Ether Linux paralelo 10.100.1.2/24
    Ether Clientes

    Como ficaria Nat Mangle e etc
    Última edição por powernetscm; 17-05-2009 às 12:32.

  14. #14

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    olhA a minha duvida queria eu colocar 5 links balanceados no mk 3,23 sendo que uso o linux para proxy paralelo, hoje tenho 2 links balanceados por rotas redondom com o linux, agora queria fazer essa mudança, um pc com 7 placas 3com, mk 3.23 cf de 2G 1GRam, Dual Core
    agora a duvida como balancear 5 links, ficaria bom? alguem tem ? meus links sao Embratel Full 8mb e 4 Pme Embratel de 4mb todos ips fixo.

    obs como ficaria msn bancos que todos falam que da problema

    qual placa mae vc esta usando ???
    ou esta usando aquele adaptador de 4 ether em 1 pci ??
    no caso seria essa
    http://produto.mercadolivre.com.br/M...l-mikrotik-_JM

    alguem ja uso essa adaptador ?? é bom ???
    naum estou axando mais placa com acima de 4 pci ...


    obrigadoa todos
    Última edição por mktguaruja; 17-05-2009 às 14:33.



  15. #15

    Padrão

    a minha é uma placa da intel com 6 slot pci e uma lan on board e as placas 3com 3c905 10/100

  16. #16

    Smile Interessante

    Citação Postado originalmente por Giovani.couto Ver Post
    Olá !


    Sim fica bom em uma maquina separada !


    Você faz o balance normal para os 7 links por NTH e depois cria mais uma rota estatica escolhendo um destes links onde você vai colocar o MSN, Https e qualquer outra porta ou Ip para sair por ele !

    Não dando assim problemas de msn e bancos ou qualquer outra coisa !

    Abraços
    Boa noite nos encontramos em outro post hem o primeiro foi este:
    https://under-linux.org/f126198-ajuda-loadbalance-youtube-error-occurred-please-try-again-later-3#post404623
    Mas diga camarada como seria esta ideia sua do balanceamento separado em outro mk ?
    Duvidas:
    1º Faço o balanceamento nth de 4 dos 5 links que tenho em um mk só pra balance ?
    2º O link que sobra jogo diretamente no outro mk dos clientes com rotas estaticas pra msn, bancos ?
    3º Como ficaria a comunicação entre os mks ? tipo qual ip coloco nos dois pra comunicar ?

    Boa ideia esta sua, ja utilizo aqui um sistema de balance usando nth + conexão permanente no mk 2.9.50 mas gostaria de testar novas ideias.

    Abraços



  17. #17

    Padrão

    galera. estou acompanhando o post.. e queria saber a diferença do adsl para adsl com ip fixo.

    obrigado
    Última edição por clodevaldo; 19-05-2009 às 07:16.

  18. #18

    Padrão

    galera o ip fixo.. o gateway dele seria diferente do adsl dinamico ??? c for eu posso fazer o mkt discando 1 ip fixo e o dinamico. a logika seria mesma mais ao invez de usar o ethwan1 e ethwan2 .... usaria pppoe-out1 e pppoe-out2 ??? seria isso ou falei coisa errada ??? hehe


    esperando resposta obrigado !



  19. #19

    Padrão Finalizando tudo.... =D

    Galera estou precisando de ajuda no load... eu consegui fazer.. com as 3 link tudo certinho...
    mais q eu to querendo agora direcionar um link adsl somente para p2p .. tem como ???

    sera que é viavel deixa um link somente para p2p ?? ou melhor deixa como q ta ... o nth com 3 links????


    espero a colaboração de vc´s... obrigado
    Última edição por mktguaruja; 30-05-2009 às 17:03.

  20. #20

    Padrão

    tem como galera.. me ajuda.. a fazer esse load ???


    obrigadoo !