+ Responder ao Tópico



  1. #1

    Padrão Saindo do squid 2.7 para o squid3

    Olá a todos,
    como disse no título do tópico, estou usando o squid 2.7 em um Ubuntu Server 8.10, HD SCSI de 73gb, 4gb de memória, processador core 2 duo, em paralelo com o mikrotik...

    Funcionando muito bem, vou mudar agora para uma placa que suporta até 16gb de memoria, no momento vou começar com apenas 8gb.

    este squid esta funcionando muito bem pois esta configurado para cachear arquivos de até 100mb e como o squid 2.7 ja tem zph marquei no mk e esta saindo full para clientes tudo que ja esta em cache.

    detalhe tendei por meio de maquina virtual instalar e configurar o squid3 mais percebi que essa versão não tem o zph fiquei sabendo pelo meu amigo ¨google¨ que a versão squid3.1 ja tem, ou que poderia aplicar o patch zph antes de instalar o squid3.0.

    finalmente chegando no ponto, depois de passar o final de semana testando de tudo quanto foi maneiras de instalar não consigo aplicar o patch nem tão pouco instalar o squid3.1.

    é ai que eu peço a colaboração da galera, pois ja se acabou minha capacidade de resolver esse problema, o ¨google¨ ja deu o que tinha de ajuda.

    pra mim é muito importante o zph pois o cache full faz uma grande diferença...
    e estou curioso se o squid3 pode funcionar melhor e/ou gerenciar melhor o consumo de memoria.

    Muito obrigado.

  2. #2



  3. #3

    Padrão Obrigado pelo entereçe

    Citação Postado originalmente por info24hs Ver Post
    Quais as mensagens de erro?
    camarada os erros são muitos, por exemplo quando baixei a versão squid3 apliquei a patch até ai normal o patch aplica sem problemas e depois de compilar mandar instalar completa tudo mais ao tentar iniciar ou configurar o squid é como se ele não estivesse sido instalado, mais se você pode ajudar eu posso repetir e colocar aqui todos os passos feitos aqui, pode ser?

    Muito obrigado.

  4. #4

    Padrão

    Posta todos os erros, pode ser em arquivo anexo.

    Procure com o comando locate a pasta onde ele foi instalado, provávelmente ele não instalou na pasta /etc/squid pode ter instalado na pasta /usr...

    Use slocate -u para atualizar o banco de dados do comando locate, caso não tenha ele instalado baixe pelo google.



  5. #5

    Padrão

    Cara, eu uma pesquisa que fiz com os amigos mais experientes, disseram que a versão 2.7 é melhor, estou usando aqui e não penso em trocar, me parece que a versão 3.0 também tem o ZPH. Dá um pesquisada aqui no Forum, que foi aqui mesmo que obtive essas informçãoes. Inclusive fiquei conhecendo um projeto, o CacheBoy, que é um complemento para Squid.

  6. #6

    Padrão

    Ola amigo, qual o distro que vc esta usando?

    pois no fedora, o squid ja vem por padrao nele...
    porem, eu sempre removi ele, e reinstalei atraves do comando yum install squid

    depois disso, so mudei a squid.conf
    funciona muito bem aqui comigo!



  7. #7

    Padrão

    Cara o patch que existe é para a vesão 3 stable 8 e o squid 3 já está na estable 15!!! e o squid 3.1 ainda está em beta! verifique se relmente é necessário utilizar as novas versões ...