Página 1 de 5 12345 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Exclamation Dica! mangle+Orkut+queue tree

    Olá pessoal.

    Como tem tempo que não contribuo com algo, vou explicar como marcar pacotes com o mangle utilizando o CONTENT, já explicado aqui no fórum, mas é mais uma idéia de como gerenciar sua banda e fazer um "agrado" aos clientes orkuteiros.

    1-) Marcar a CONEXÃO realizada a todo site com a palavra orkut.com

    /ip firewall mangle

    add action=mark-connection chain=output comment="MARCA-CONN-ORKUT" content=orkut.com disabled=no new-connection-mark=ORKUT passthrough=yes

    Observe em vermelho a utilização do "string" orkut.com

    é sabido que sites como meuorkut.com.br seuorkut.com.br também será marcado.

    2-) Marcar o PACOTE realizado ao site orkut, que esteja marcado com a CONEXÃO acima.

    add action=mark-packet chain=output comment="MARCA-PKT-ORKUT" connection-mark=ORKUT disabled=no new-packet-mark=ORKUT-PCKT passthrough=yes

    3-) Depois devemos criar uma QUEUE-TREE com limite de 1mb/s (no meu caso)

    /queue tree

    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=ORKUT packet-mark=ORKUT-PCKT parent=global-out priority=8 queue=default

    É só, lembrando que meu MK é versão 3.23

    Sei que isso já foi tratado aqui, o mangle CONTENT, mas este é mais um exemplo que pode ser usado em sites de banco, email, videos etc..

    Abraços !

  2. #2

    Padrão

    Boa Noite Alan,

    Criando esta regra no queues tree o cliente sai do controle de banda dele e passa a ter 1mb para acessar o site do orkut?

    E se 15 clientes acessarem o orkut ao mesmo tempo, os 1mb seria dividido por todo mundo? ou teria como deixar 1mb para cada um?

    Obrigado pela Contribuição

    Abraços



  3. #3

    Padrão

    Um mega para a CONEXÃO que marcamos. Eles vão dividir entre sí, o 1MB !

    Lembrando que enquanto ele navegar no site do orkut, ele vai ter 1MB de banda (que maravilha), já que lá, é só foto e vai carregar em um tiro só, ou seja cliente satisfeito !!!

    Bom para fazer em sites de video, essas coisas..

    Abraços

  4. #4

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Um mega para a CONEXÃO que marcamos. Eles vão dividir entre sí, o 1MB !

    Lembrando que enquanto ele navegar no site do orkut, ele vai ter 1MB de banda (que maravilha), já que lá, é só foto e vai carregar em um tiro só, ou seja cliente satisfeito !!!

    Bom para fazer em sites de video, essas coisas..

    Abraços
    Neste caso não seria uma liberação para não passar pelo controle de bandao vindo direto do link ou sendo controlado do link e liberado do cache (controlado pelo queue tree) no seu caso 1mb?



  5. #5

    Padrão

    gente.. não precisa ser 1mb, o que o nosso amigo alamdias nos ensinou é a marcação, falta so adaptar para nossas necessidades..
    se vc usa cache full ele ja faz outra marcação do que sai do cache..
    justamente essa minha pegunta, coloquei a regra antes da de cache full sera q pode ter algum problema nos pacotes receberm 2 tipos de marcação??

  6. #6

    Padrão

    amigo ficou xou aqui no meu servidor esses scripts, tanbem fiz para o youtube ficou bala. valeu pela iniciativa !!



  7. #7
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    Citação Postado originalmente por acesse Ver Post
    amigo ficou xou aqui no meu servidor esses scripts, tanbem fiz para o youtube ficou bala. valeu pela iniciativa !!

    Amigo não seria arriscado colocar para youtube? Sei q seria 1mb divido por todos, mas não pesaria para aquele youtuberos que abre 4 videos ao mesmo tempo?

    Desde ja agradeço a Dica

  8. #8

    Padrão duviva

    Citação Postado originalmente por alamdias Ver Post
    Olá pessoal.

    Como tem tempo que não contribuo com algo, vou explicar como marcar pacotes com o mangle utilizando o CONTENT, já explicado aqui no fórum, mas é mais uma idéia de como gerenciar sua banda e fazer um "agrado" aos clientes orkuteiros.

    1-) Marcar a CONEXÃO realizada a todo site com a palavra orkut.com

    /ip firewall mangle

    add action=mark-connection chain=output comment="MARCA-CONN-ORKUT" content=orkut.com disabled=no new-connection-mark=ORKUT passthrough=yes

    Observe em vermelho a utilização do "string" orkut.com

    é sabido que sites como meuorkut.com.br seuorkut.com.br também será marcado.

    2-) Marcar o PACOTE realizado ao site orkut, que esteja marcado com a CONEXÃO acima.

    add action=mark-packet chain=output comment="MARCA-PKT-ORKUT" connection-mark=ORKUT disabled=no new-packet-mark=ORKUT-PCKT passthrough=yes

    3-) Depois devemos criar uma QUEUE-TREE com limite de 1mb/s (no meu caso)

    /queue tree

    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=ORKUT packet-mark=ORKUT-PCKT parent=global-out priority=8 queue=default

    É só, lembrando que meu MK é versão 3.23

    Sei que isso já foi tratado aqui, o mangle CONTENT, mas este é mais um exemplo que pode ser usado em sites de banco, email, videos etc..

    Abraços !
    MUITO BOA ESSA SUA IDEIA AMIGO TO PASSANDO POR DIFICULDADES INCLUSIVE NO ORKUT MEUS CLIENTES TAO RECLAMANDO MUITO EM RELAÇAO A POSTA FOTOS NO ORKUT PQ QUANDO TENTAM COLOCAR TA DEMORANDO MUITO AI PENSEI E COLOCAR ESSAS NORMAS QUE VC SITOU SO QUE SOU LEIGO EM MK TENTEI COLOCA AQUE MAIS SEM SUSSEÇO SERA QUE NAO TERIA COMO O AMIGO COLOCAR TIPO ASIM UM PRINTE ONDE POSSO COLOCAR ESSAS REGRAS PQ VENDO POR FOTO SERIA BEM MAIS FACIO PRA MIM FICARIA MUITO GRATO AO AMIGO ESSI SI RESOLVERIA MEU POBLEMA DESDE JA AGRADEÇO.....



  9. #9

    Padrão

    Boa observação.

    Não é interessante para sites de stream ou de download, pois UM unico cliente pode consumir esse 1mega, por muito tempo.

    É interessante para orkut, pq vai dar uma rajada no carregamento de fotos e o cliente vai ficar satisfeito.
    O mesmo seria legal usando a palavra BLOG, pois tem muita foto, e as rajadas são curtas, dando um gás a mais.

    To testando no hotmail também, pois o pessoal baixa o anexo mais rápido.

    Vai da necessidade de cada um.

    Mais uma coisa. Quem tem cache-full, como eu (estou adorando), eu coloco a regra antes, pois SE cair no cache full, beleza, já tem 5MB de full liberado, se não cair, cai no 1mb, sem passar pela queue do cliente, assim espero.

    Ficou muito bom aqui, e alguns clientes que falei pelo MSN, sentiram um IMENSA melhoria na INTERNET hhehehehehe efeito cascata, melhora o que eles mais usam (orkut) e acham que tudo está 100%.

    Abraços !

  10. #10

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Boa observação.

    Não é interessante para sites de stream ou de download, pois UM unico cliente pode consumir esse 1mega, por muito tempo.

    É interessante para orkut, pq vai dar uma rajada no carregamento de fotos e o cliente vai ficar satisfeito.
    O mesmo seria legal usando a palavra BLOG, pois tem muita foto, e as rajadas são curtas, dando um gás a mais.

    To testando no hotmail também, pois o pessoal baixa o anexo mais rápido.

    Vai da necessidade de cada um.

    Mais uma coisa. Quem tem cache-full, como eu (estou adorando), eu coloco a regra antes, pois SE cair no cache full, beleza, já tem 5MB de full liberado, se não cair, cai no 1mb, sem passar pela queue do cliente, assim espero.

    Ficou muito bom aqui, e alguns clientes que falei pelo MSN, sentiram um IMENSA melhoria na INTERNET hhehehehehe efeito cascata, melhora o que eles mais usam (orkut) e acham que tudo está 100%.

    Abraços !
    AMIGO E MEU SERVIDOR TEM CACHE FULL E UM SERVIDOR MICKOTIK O CACHE FULL FUNCIONA PERFEITAMENTE QUERIA MUITO COLOCAR ESSA REGRA AI DO ORKT RESOLVERIA 100% DOSMEUS POBLEMAS



  11. #11

    Padrão

    Segue link do video no YOUTUBE

    [ame=http://www.youtube.com/watch?v=qzR2RarnGEA]YouTube - Marcando ORKUT MIKROTIK (MANGLE+QUEUE)[/ame]

    É em HD e tem a opção de normal

    Maximize para tela inteira que veras com maior definição !

    Abraços e espero que ajude !

    Alam Dias

  12. #12

    Padrão

    valew muito obrigado ai amigo agora vou fazer aque o meu com essa aula ta bem esplicadinha brigadao ai alamdias



  13. #13

    Padrão

    Boa sorte cara..

    é só clicar no botão AGRADECER que eu já fico mais feliz.

    Abraços

  14. #14
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Olá pessoal.

    Como tem tempo que não contribuo com algo, vou explicar como marcar pacotes com o mangle utilizando o CONTENT, já explicado aqui no fórum, mas é mais uma idéia de como gerenciar sua banda e fazer um "agrado" aos clientes orkuteiros.

    1-) Marcar a CONEXÃO realizada a todo site com a palavra orkut.com

    /ip firewall mangle

    add action=mark-connection chain=output comment="MARCA-CONN-ORKUT" content=orkut.com disabled=no new-connection-mark=ORKUT passthrough=yes

    Observe em vermelho a utilização do "string" orkut.com

    é sabido que sites como meuorkut.com.br seuorkut.com.br também será marcado.

    2-) Marcar o PACOTE realizado ao site orkut, que esteja marcado com a CONEXÃO acima.

    add action=mark-packet chain=output comment="MARCA-PKT-ORKUT" connection-mark=ORKUT disabled=no new-packet-mark=ORKUT-PCKT passthrough=yes

    3-) Depois devemos criar uma QUEUE-TREE com limite de 1mb/s (no meu caso)

    /queue tree

    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=ORKUT packet-mark=ORKUT-PCKT parent=global-out priority=8 queue=default

    É só, lembrando que meu MK é versão 3.23

    Sei que isso já foi tratado aqui, o mangle CONTENT, mas este é mais um exemplo que pode ser usado em sites de banco, email, videos etc..

    Abraços !

    Boa noite Alam, apliquei aqui estas regras, vou ver durante a semana o resultado, Marcando os pcts já está, agora vamos ver nos clientes.

    Obrigado pela iniciativa.

    Fique com Deus !

    Ricardo Sobrinho.



  15. #15
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Boa observação.

    Não é interessante para sites de stream ou de download, pois UM unico cliente pode consumir esse 1mega, por muito tempo.

    É interessante para orkut, pq vai dar uma rajada no carregamento de fotos e o cliente vai ficar satisfeito.
    O mesmo seria legal usando a palavra BLOG, pois tem muita foto, e as rajadas são curtas, dando um gás a mais.

    To testando no hotmail também, pois o pessoal baixa o anexo mais rápido.

    Vai da necessidade de cada um.

    Mais uma coisa. Quem tem cache-full, como eu (estou adorando), eu coloco a regra antes, pois SE cair no cache full, beleza, já tem 5MB de full liberado, se não cair, cai no 1mb, sem passar pela queue do cliente, assim espero.

    Ficou muito bom aqui, e alguns clientes que falei pelo MSN, sentiram um IMENSA melhoria na INTERNET hhehehehehe efeito cascata, melhora o que eles mais usam (orkut) e acham que tudo está 100%.

    Abraços !
    Concordo com a sitação Alam, para vídeos é complicado pois consumirá muito da banda, principalmente para aqueles que utilizam DSL, já para sites que tem muita imagem, como Orkut, Flickr e bolgs em geral, é legal montar esta marcação.

    Boa semana !

    Ricardo Sobrinho.

  16. #16

    Padrão

    ja tirei as regras para o youtube,fiz os testes nao ficou bom ( p/ o youtube ) no orkut ficou joia
    blz



  17. #17

    Padrão

    Eu uso marcação com queue tree para marcar alguns pacotes como p2p para controlar minha rede. Outros serviços tambem são legais de marcar...

  18. #18

    Padrão

    Ola Alam, eu tentei implantar suas regras, mas colocando a chain como chain=output não funciona, so conta pacotes e conexões como chain=forward, você sabe o porque deste erro?

    Outra dúvida, estou lendo muito sobre queue e queue tree, e em muitos lugares as pessoas interpretam os dois como sendo simple queue primário e queue tree como secundário, ou seja, se você limita a banda do cliente "a" em 300k no simple queue, não adiantaria liberar um mega no queue tree.
    Conforme esta interpretação, a queue tree serviria apenas para priorizar o trafego (QoS) limitando o uso máximo para cada marcação.


    Se esta interpretação estiver correta, sua regra de nada serviria, porque iria limitar o orkut para no máximo 1 Mega, e trancaria o cliente em sua velocidade do queue.

    Pessoal, desde já peço desculpas se estiver falando besteira, somente to escrevendo as coisas que encontrei sobre queues, e gostaria que alguém com mais conhecimento pudesse falar sobre o assunto, e responder a questão de qual queue eh prioritária...

    Desde já agradeço a todos..

    Tiago



  19. #19

    Padrão Funciona 100%

    Alan, as regras com output são show de bola e fiz o seguinte teste:

    1 - escolhi um site (Content) e criei o mangle para conexão e pacote
    2 - depois coloquei este site na lista de bloqueados para não entrar em cache
    3 - abaixei minha queue simple para 64k/64k
    4 - naveguei pra ver a lerdeza (e de fato é uma tristeza navegar a 64k)
    5 - fui até o site tal pra download

    resultado
    Baixou a 190k

    Isso me abriu o olho em relação ao cache thunder que tenho aqui que poderei marcar o header
    no apache e limitar o envio de videos de forma mais eficiente pelo MK.

    Muito Obrigado, testado e APROVADO.

  20. #20

    Padrão

    Alamdias

    so pra comentar, achei interessante essa sua contribuição. testei e aprovei, porei para mim so funcionou colocando chain= em forwarding.....

    :-)