Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Exclamation Dica! Script para mudar todas queues

    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"


    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"


    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"


    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços

  2. #2

    Padrão

    como fazer este script rodar na versão 4.0Beta2? pelo que vi a maneira de usar find nas versões 4 foi modificada, ou pelo menos é um bug, porque o find na versão 4 retorna todos os valores existentes e não apenas o que procuramos, no caso acima de tivesse alguns clientes com prioridade = 5 ou 6 estariam dentro da nova velocidade, poderia esclarecer?
    Última edição por sergio; 17-05-2009 às 21:52. Razão: poluição visual



  3. #3

    Padrão

    muito boa esse seu escript pq tenho poblema de banda aque nao posso librera banda de mais em determinado tempo mais quando passa da 10 horas meu link fica mais manero vou tenta coloca esse escript pq nao intendo muito de mk nao mais to fazendo o possivel pra aprender alguma coisa valew ai brigado pela dica mano...

  4. #4

    Padrão Detalhe

    Parabens Show de bola so um detalhe
    para quem usa Burts ajustar este parametro tambem....



  5. #5

    Padrão

    Citação Postado originalmente por VictorOliveira Ver Post
    como fazer este script rodar na versão 4.0Beta2? pelo que vi a maneira de usar find nas versões 4 foi modificada, ou pelo menos é um bug, porque o find na versão 4 retorna todos os valores existentes e não apenas o que procuramos, no caso acima de tivesse alguns clientes com prioridade = 5 ou 6 estariam dentro da nova velocidade, poderia esclarecer?
    Não sei como se comporta na 4beta. Lembrando que, no caso somente vai afetar queues com prioridade 8, se você tiver outros clientes com prioridades diferentes, não vai afetar.

    Citação Postado originalmente por evertonmt Ver Post
    Parabens Show de bola so um detalhe
    para quem usa Burts ajustar este parametro tambem....
    Não mexe em mais nada, ele só da SET nos campos UP/DOWN. Só que alterando o up/down, tem que mexer no burst também, por causa dos cálculos entendeu ? Podemos estudar isso também.

    Abraços

  6. #6

    Padrão

    Citação Postado originalmente por VictorOliveira Ver Post
    como fazer este script rodar na versão 4.0Beta2? pelo que vi a maneira de usar find nas versões 4 foi modificada, ou pelo menos é um bug, porque o find na versão 4 retorna todos os valores existentes e não apenas o que procuramos, no caso acima de tivesse alguns clientes com prioridade = 5 ou 6 estariam dentro da nova velocidade, poderia esclarecer?
    Pode ser por síntaxe, eles devem adicionou algo, tipo para buscar em todos os resultados e deste selecionar apenas um "where". Usada muito em mysql.



  7. #7

    Padrão Consideracoes

    Caro Victor como iremos tratar os clientes que irao conectar apos o "Run" do script,teremos que agendar de tempo em tempo ?

  8. #8

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"


    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"


    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"


    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços
    Usando hotspot com perfil cadastrado em "User Profiles" essa regra funciona?

    Depois das 00:30 quero liberar 800k para cada cliente.



  9. #9

    Padrão Positivo

    Sim funciona no meu caso todos os meus servers reenician exatamente as 06:00 e apos este horario o script nao roda ate o dia seguinte.
    Sendo assim todos que conectarem pegar o perfil do profile....

  10. #10

    Padrão

    Citação Postado originalmente por evertonmt Ver Post
    Caro Victor como iremos tratar os clientes que irao conectar apos o "Run" do script,teremos que agendar de tempo em tempo ?
    Citação Postado originalmente por NetoGO23 Ver Post
    Usando hotspot com perfil cadastrado em "User Profiles" essa regra funciona?

    Depois das 00:30 quero liberar 800k para cada cliente.
    Não uso hotspot, mas nesse caso acho que dá pra fazer 2 agendamentos com 2 scripts:

    1 com inicio ás 00:30 dando um ENABLE no outro que muda as queues.

    2 agendar o script que muda as queues para rodas de 5 em 5 minutos

    Entenderam ? assim quem for se conectando é beneficiado tbm.

    Abraços



  11. #11

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"


    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"


    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"


    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços

    Bem explicado, ficou muito boa sua DICA, poderia fazer mais algumas delas para tornar nosso fórum mais completo ?

    Esta de parabéns Alam, fico feliz em ver que além de você, esta semana ganhamos novos colaboradores, tenho lido o post de todos e notado que quem normalmente antes só agradecia agora também esta criando soluções e compartilhando com os demais, acho que este é o verdadeiro espirito do fórum.

    Grande abraço e espero que continue com este trabalho.

  12. #12

    Padrão

    Opa.

    A idéia e função do fórum deve ser sempre esta.

    Nem sempre podemos gastar 30 minutinhos, ajudando o conteúdo, adoro contribuir ! Mas nem sempre dá.

    Ás vezes fico pensando em no que criar um tópico de dicas.. mas o tempo é curto.

    Se nós não nos ajudarmos, o que será ?

    Abraços



  13. #13

    Padrão

    VALEW ALAM MUITO OBRIGADO PELO LINK DO YUTUB QUE VC COLOCOU AI DA REGRA DO ORKUT FICO MUITO AGRADECIDO POR ISSO VALEW MESMO....

  14. #14

    Padrão

    Citação Postado originalmente por VictorOliveira Ver Post
    como fazer este script rodar na versão 4.0Beta2? pelo que vi a maneira de usar find nas versões 4 foi modificada, ou pelo menos é um bug, porque o find na versão 4 retorna todos os valores existentes e não apenas o que procuramos, no caso acima de tivesse alguns clientes com prioridade = 5 ou 6 estariam dentro da nova velocidade, poderia esclarecer?
    Bom pessoal, quem estiver com este problema podem atualizar para a versão 4.0beta3 que o bug foi corrigido e funciona perfeitamente o script do colega, além disso foi incorporado o "LUA" shell para potencializar as possibilidades de tarefas agendadas com o mikrotik.



  15. #15

    Padrão

    Parabéns pelo, post

    posso postar estas regras no meu blog...


    falows...


    Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"

    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"

    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"

    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços

  16. #16

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"


    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"


    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"


    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços
    Ótima dica alamdias, mas...
    como sempre né... mas..
    se eu eu nunca trabalhei com burst antes, e agora gostaria de configurar o burst para todas as queues, e utilizando esse script como ficaria???
    Trabalho somente com ipXmac, sem hotspot nem pppoe!
    Agradeço!!!



  17. #17

  18. #18

    Padrão

    Renascendo o tópico.

    Estou estudando o burst, nesse script.

    Em breve novidades

    Abraços



  19. #19

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Renascendo o tópico.

    Estou estudando o burst, nesse script.

    Em breve novidades

    Abraços
    Colega para mim que uso hotspot não deu certo.

    Acho que é porque o depois que o cliente loga a conexão criada no queue não permite alteração a não ser que ela seja excluida e refeita.

    Você sabe de algum outro jeito para liberação de banda para que usa hotspot?

    Desde já obrigado.

  20. #20

    Padrão

    Citação Postado originalmente por NetoGO23 Ver Post
    Colega para mim que uso hotspot não deu certo.

    Acho que é porque o depois que o cliente loga a conexão criada no queue não permite alteração a não ser que ela seja excluida e refeita.

    Você sabe de algum outro jeito para liberação de banda para que usa hotspot?

    Desde já obrigado.
    Vixi, em hotspot, as queues são dinamicas, não sei como agir nessa situação.

    Mas.. vamos ver os companheiros do forum.

    Abraços