Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Estou com um projeto de um provedor(já funcionando) para montar um servidor de cache com linux debian mas ele já tem um servidor mikrotik que recebe um IP valido e faz o nat para os clientes dele fazendo controle de banda + pppoe.

    Mas ele quer fazer um cache full com um server linux que ele tem separado para isso mas minha dúvida é como integrar o linux se ele tb tem que direcionar e fazer um nat por exemplo usando a porta 3128(para cache full no debian faço com squid + htb+tc)

    Porque se colocar o linux antes do mikrotilk ficariam dois Nats ai acho que o cache full do linux não passaria para a faixa de IP do mikoritk(no caso a segunda placa de rede dele)


    lá está assim:

    servidor mikrotik:

    placa 1: link embratel
    placa 2: ips da rede interna
    pppoe e etc...

    linux:
    eth0: o que colocar para não mexer na estrutura
    eth1: mesma pergunta da eth0


    OBS.: Não quero fazer em paralelo com o mikrotik quero deixar o mikrotik dele separado do meu servidor linux.

    OBS.: uma duvida:

    será que o linux não pode redeber o IP válido e passar a faixa da rede interna e o mikrotik ficar dentro da faixa de rede interna com uma placa de rede só continuar gerenciando??porque acho que a segunda placa é só para questão de NAT mesmo para rede interna.
    Última edição por lfernandosg; 26-05-2009 às 09:45.

  2. Amigo, aqui tenho um balance unindo 3 Link e um MK para os clientes IP + PPPOE e nesse mk uma interface ligada a um Ubuntu 8.10 AMD64 + Thunder + Squid, faço cachefull normal, todos meus clientes passam pelo squid de boa.

    Se quiseres detalhes me add ai no seu msn q lhe mostro como esta aqui.

    Abraço



  3. Eu aqui fiz assim, pra ficar facil, ou ja tava com o mikrotik configurado, entao eu simplesmente fui nas opçoes de web proxy do mikrotik e coloquei o linux como parente proxy, coloquei o linux do lado do mk, com uma placa de rede na net e outra mesma rede do mk, desliguei o cache on disk, no web proxy do mk, ficou file, nunguem percebeu que eu fix...

    Paulo, como vc fez? eu tentei fazer um nat-dst com o endereço do linux mais ficou estranho, eu acho que tava passando dando loop... nao sei, post como vc fez ai porfavor, so pra saber o que eu etava faznedo de errado., valeu!!!

  4. / ip firewall nat
    add chain=dstnat src-address= IPLINUX dst-address=IPLINUX protocol=tcp src-port=80 action=accept comment="CACHE" \
    disabled=no
    add chain=dstnat src-address=IPCLINTES protocol=tcp dst-port=80 action=dst-nat to-addresses=IPLINUX to-ports=PORTA PROXY \
    comment="" disabled=no
    add chain=srcnat out-interface=SAIDA NET action=masquerade comment="NAT" disabled=no

    aqui nao precisei criar acl nenhuma pra rede deu certo de boa...
    Se vc quiser pode procurar no Forum Proxy Masters • Index page tem meu squid.conf ....



  5. Paulo meu msn é: lfernandosg@hotmail.com


    me passa o seu para a gente trocar uma ideia...






Tópicos Similares

  1. Respostas: 5
    Último Post: 01-07-2014, 08:03
  2. Respostas: 14
    Último Post: 01-07-2012, 08:24
  3. Perda de pacotes com servidor Mikrotik
    Por Gigainfo no fórum Redes
    Respostas: 8
    Último Post: 30-05-2008, 07:31
  4. Respostas: 0
    Último Post: 05-06-2003, 11:07
  5. Servidor de Radio com Conectiva 8
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 11-11-2002, 02:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L