+ Responder ao Tópico



  1. #1

    Padrão squid

    Boa Pessoal

    Sou iniciantes em linux e estou precisando da ajuda os amigos experientes. É o seguinte montei um servidor ubuntu 8.04 ja configurei tudo direitinho ate o meu entender, ja instalei o squid mas nao tenho certeza que ele esteja funcionando direito. Existe alguma forma de testar, vejam bem coloquei meu notebook na placa eth1 que ja esta configurada e o configurei tambem o meu navegador para usar a porta 3128 proxy, e ja estou navegando normalmente. Mas nao sei onde posso taxar a velocidade dos clientes, por exemplo queria que tivesse uma velocidade de 128k. Alguem sabe me informar como fazer isso.

  2. #2

    Padrão

    Citação Postado originalmente por infojet Ver Post
    Boa Pessoal

    Sou iniciantes em linux e estou precisando da ajuda os amigos experientes. É o seguinte montei um servidor ubuntu 8.04 ja configurei tudo direitinho ate o meu entender, ja instalei o squid mas nao tenho certeza que ele esteja funcionando direito. Existe alguma forma de testar, vejam bem coloquei meu notebook na placa eth1 que ja esta configurada e o configurei tambem o meu navegador para usar a porta 3128 proxy, e ja estou navegando normalmente. Mas nao sei onde posso taxar a velocidade dos clientes, por exemplo queria que tivesse uma velocidade de 128k. Alguem sabe me informar como fazer isso.

    Pelo que vc mesmo disse "ja estou navegando normalmente" então ele esta funcionando... Controle de velocidade por padrão o squid não faz.. ai é necessário usar HTB.



  3. #3

    Padrão

    Certo obrigado amigo, mas alguem poderia me informar algum tutorial para que eu posso instalar esse HTB? Ja que os que encontrei na net nao serviu muito bem.

  4. #4

    Padrão

    procura por shaper, CTB... aqui na under vc acha tudo que precisa para colocar esse serviço no ar..



  5. #5

    Padrão

    Caro amigo consegui um tutorial bom aqui Limitando a banda no linux usando o shaper e CBQ e ja ate instalei tudo, mas fui fazer um teste aqui pra ver se estava funcionando normal e percebi que ele nao esta controlando ainda, porque no tutorial tem uma opcao de 64Kbit. Mas quando fui testar no velocimento do RJNET percebi que o meu notebook mesmo sendo controlado estava usando o link todo. Outra duvida tambem é que nao sei se coloco na eth0 que é a entrada do link, ou se coloco na eth1 que é a minha placa de rede de saida. Na verdade ja ate testei as 2 mais nao controlou nada.

    A configuracao do arquivo cbq-0001.-in esta assim

    ##Aqui você deve colocar a interface de rede
    ###Interface,Banda,banda dividida por 10
    DEVICE=eth0,100Mbit,10Mbit
    ###A banda que passa
    RATE=64Kbit
    ##A banda 64/10 dividida por 10, Limite de download
    WEIGHT=6Kbit
    ###prioridade
    PRIO=5
    ###Regras , você pode colocar mais de uma regra , RULE
    ###Essa regra controla a faixa de ip
    RULE=192.168.254.0/24
    ###Essa Regra não permite compartilhar banda entre os clientes
    ### se quiser compartilhar coloque ” no ” nas duas abaixo
    BOUNDED=yes
    ISOLATED=yes

    e do cbq-0001.-out esta assim

    ##Aqui você deve colocar a interface de rede
    ###Interface,Banda,banda dividida por 10
    DEVICE=eth0,100Mbit,10Mbit
    ###A banda que passa
    RATE=64Kbit
    ##A banda 64/10 dividida por 10, Limite de upload
    WEIGHT=6Kbit
    ###prioridade
    PRIO=5
    ###Regras , você pode colocar mais de uma regra , RULE
    ###Essa regra controla a faixa de ip
    RULE=192.168.254.0/24,
    ###Essa Regra não permite compartilhar banda entre os clientes
    ### se quiser compartilhar coloque ” no ” nas duas abaixo
    BOUNDED=yes
    ISOLATED=yes

    OBS: Nao sei tambem se esta configuracao serve pra o meu servidor, pretendo apenas controlar a banda de 10 ou 11 maquinas.

  6. #6

    Padrão

    # The configuration says that we will control traffic on 10Mbit ethernet
    # device eth0 and the traffic going to network 192.168.1.0 will be
    # processed with priority 5 and shaped to rate of 128Kbit.
    #
    # Note that you can control outgoing traffic only. If you want to control
    # traffic in both directions, you must set up CBQ for both interfaces.
    #
    # Consider the following example:
    #
    # +---------+ 192.168.1.1
    # BACKBONE -----eth0-| linux |-eth1------*-[client]
    # +---------+
    #
    # Imagine you want to shape traffic from backbone to the client to 28Kbit
    # and traffic in the opposite direction to 128Kbit. You need to setup CBQ
    # on both eth0 and eth1 interfaces, thus you need two config files:
    #
    # cbq-028.backbone-client
    # --------------------------------------------------------------------------
    # DEVICE=eth1,10Mbit,1Mbit
    # RATE=28Kbit
    # WEIGHT=2Kbit
    # PRIO=5
    # RULE=192.168.1.1
    # --------------------------------------------------------------------------
    #
    # cbq-128.client-backbone
    # --------------------------------------------------------------------------
    # DEVICE=eth0,10Mbit,1Mbit
    # RATE=128Kbit
    # WEIGHT=10Kbit
    # PRIO=5
    # RULE=192.168.1.1,

    Sempre após qualquer atualização nos arquivos é necessário recompilar as configurações do shaper.

    sudo /etc/init.d/shaper compile

    Faça isso com o shaper desligado.

    Obs.: Ref. http://ufpr.dl.sourceforge.net/sourc...bq.init-v0.7.3



  7. #7

    Padrão

    coloquei os comandos que voce me passou e compilei, mas continua sem controlar a banda, quando eu compilei apareceu isso aqui

    [email protected]:/home/alex# sudo /etc/init.d/shaper compile
    find: warning: you have specified the -maxdepth option after a non-option argument (, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it). Please specify options before other arguments.

    find: warning: you have specified the -maxdepth option after a non-option argument (, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it). Please specify options before other arguments.

    /sbin/tc qdisc del dev eth0 root
    /sbin/tc qdisc add dev eth0 root handle 1 cbq bandwidth 10Mbit avpkt 1000 cell 8
    /sbin/tc class change dev eth0 root cbq weight 100Mbit allot 1514

    /sbin/tc qdisc del dev eth1 root
    /sbin/tc qdisc add dev eth1 root handle 1 cbq bandwidth 10Mbit avpkt 1000 cell 8
    /sbin/tc class change dev eth1 root cbq weight 100Mbit allot 1514

    **CBQ: class ID of cbq-0001.in must be in range <0002-FFFF>!
    /sbin/tc qdisc del dev lo root
    /sbin/tc qdisc del dev eth0 root
    /sbin/tc qdisc del dev eth1 root

    Esta correto?

  8. #8

    Padrão

    que distro ta usando?

    qual o nome dos arquivos que ta usando?
    Última edição por info24hs; 26-05-2009 às 17:42.



  9. #9

    Padrão

    Ubuntu server 8.04 LTS

    Estou usando o cbq-0001.in cbq-0001.out

  10. #10

    Padrão

    Citação Postado originalmente por infojet Ver Post

    **CBQ: class ID of cbq-0001.in must be in range <0002-FFFF>!
    /sbin/tc qdisc del dev lo root
    /sbin/tc qdisc del dev eth0 root
    /sbin/tc qdisc del dev eth1 root

    Esta correto?
    Posso estar falando uma grande besteira mas se não me engano eu já li que o nome do arquivo deve começar com cbq-0002



  11. #11

    Padrão

    Caro amigo

    Ontem mesmo consegui que funcionasse, apenas mudei o nome dos arquivos, colocando os nomes que voce me passou, e tambem mudei o eth0, deixando os 2 como eth1, dai funcionou perfeitamento. Muito obrigado pela forçã amigo.