+ Responder ao Tópico



  1. #1

    Padrão ACL para redirecionar site!

    Olá galera, beleza ?
    Então, andei lendo em uns tutos com se fazia para alterar a propaganda do MSN,

    Código :
    acl ADSAdClien url_regex ADSAdClien
    http_access deny ADSAdClien
    deny_info http://192.168.0.1:8186/teste.htm ADSAdClien
    e consegui! Agora gostaria de alterar a logo do Google, para colocar um "anúncio"
    de uns serviços novos que estou prestando, para isso tentei a seguinte ACL:

    Código :
    acl GoogleLOGO url_regex http://www.google.com.br/intl/pt-BR_br/images/logo.gif
    http_access deny GoogleLOGO
    deny_info http://192.168.0.1:8186/google.htm logo.gif
    E nessa "google.htm" coloquei isso: <img height=110 src="logo.gif" width=276>, e apareceu.
    Só que quando abro o Google, a logo não aparece, nem a que eu alterei, nem a deles...
    Aparece como se o link estivesse quebrado! Dai que entendi que a ACL tá funcionando, falta só
    acertar o redirecionamento, alguem pode me ajudar?

    OBRIGADÃO ai galera,
    Grande abraço à todos.

  2. #2
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Não, você está redirecionando uma imagem, coloque a url direto para a imagem que funciona, nada de html.



  3. #3

    Padrão

    Código :
    acl GoogleLOGO url_regex http://www.google.com.br/intl/pt-BR_br/images/logo.gif
    http_access deny GoogleLOGO
    deny_info [URL]http://192.168.0.1:8186/logo.gif[/URL] GoogleLOGO

    Ficaria assim?

  4. #4
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Isso, mas se certifique que a imagem seja do mesmo tamanho do logo do google.
    Ah, somente para o google brasil (alguém usa outro google? é redirecionado automático...).



  5. #5

  6. #6



  7. #7
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Em vez de url_regex, coloca dstdom_regex para dominio por extenso (regex em ip não funciona), e por ip coloca dstdomain

    O ideal seria colocar o dominio, mas o squid consegue resolver o hostname pelo ip. (pelo menos aqui)

  8. #8

    Padrão MK 3.28?

    Olá, uso no próprio mk 3.28 e do orkut e msn funciona blz! para trocar o logo do google como seria a path no mk? coloquei *intl/pt-BR_br/images/logo.gif* só q aparece como se o link estivesse quebrado. a imagem que quero substituir, está no mesmo tamanho 276x110, mas não da certo. poderia me ajudar?



  9. #9
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    Citação Postado originalmente por bodoquenanet Ver Post
    Olá, uso no próprio mk 3.28 e do orkut e msn funciona blz! para trocar o logo do google como seria a path no mk? coloquei *intl/pt-BR_br/images/logo.gif* só q aparece como se o link estivesse quebrado. a imagem que quero substituir, está no mesmo tamanho 276x110, mas não da certo. poderia me ajudar?
    Boa tarde,
    Caro amigo gostaria de sua ajuda de seguinte forma. Como você fez para fazer funcionar no MK? Lembrado eu estou usado o MK 2.9.27, por pouco tempo.

    Abraço

  10. #10

    Padrão

    no próprio sv só funciona na 3.x, na 2.9.x somente com sv paralelo!