+ Responder ao Tópico



  1. #1

    Padrão Páginas de aviso não estão funcionando

    estou testando um hotpost na bancada...ele já autentica tudo direitinho para um usuário no profile default então criei uma pagina de avicom isso estou com dois problemas no hotspot:
    1)o usuário teste não está sendo direcionado para a pagina aviso.html e continua navegando
    2) não sei porque mas se eu sair da internet e vor entrar novamente ele não pede senha mesmo limpando o cache continuo logado com o usuario teste...tem como pedir login toda vez que o navegadoer for fechado pois por exemplo posso querer usar outro usuário com mais privilégios e etc...
    so para testes: aviso.html e joguei dentro do pasta hotspot depois fui no terminal e digitei as regras:


    /ip hotspot user profile add name="Aviso" address-pool=hs-pool-4 idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=no open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=20m advertise-timeout=15s


    ip hotspot user add name=teste profile="Aviso" server=hotspot1 password=teste

    1)o usuário teste não está sendo direcionado para a pagina aviso.html e continua navegando
    2) não sei porque mas se eu sair da internet e vor entrar novamente ele não pede senha mesmo limpando o cache continuo logado com o usuario teste...tem como pedir login toda vez que o navegadoer for fechado pois por exemplo posso querer usar outro usuário com mais privilégios e etc...

    OBS.: não marquei o proxy na regra pois uso webproxy com hotspot ..mas mesmo marcando dá na mesma o problema.

  2. #2

    Padrão

    Citação Postado originalmente por lfernandosg Ver Post
    estou testando um hotpost na bancada...ele já autentica tudo direitinho para um usuário no profile default então criei uma pagina de avicom isso estou com dois problemas no hotspot:
    1)o usuário teste não está sendo direcionado para a pagina aviso.html e continua navegando
    2) não sei porque mas se eu sair da internet e vor entrar novamente ele não pede senha mesmo limpando o cache continuo logado com o usuario teste...tem como pedir login toda vez que o navegadoer for fechado pois por exemplo posso querer usar outro usuário com mais privilégios e etc...
    so para testes: aviso.html e joguei dentro do pasta hotspot depois fui no terminal e digitei as regras:


    /ip hotspot user profile add name="Aviso" address-pool=hs-pool-4 idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=no open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=20m advertise-timeout=15s


    ip hotspot user add name=teste profile="Aviso" server=hotspot1 password=teste

    1)o usuário teste não está sendo direcionado para a pagina aviso.html e continua navegando
    2) não sei porque mas se eu sair da internet e vor entrar novamente ele não pede senha mesmo limpando o cache continuo logado com o usuario teste...tem como pedir login toda vez que o navegadoer for fechado pois por exemplo posso querer usar outro usuário com mais privilégios e etc...

    OBS.: não marquei o proxy na regra pois uso webproxy com hotspot ..mas mesmo marcando dá na mesma o problema.

    amigo para desconectar e entrar novamente no hotspot exclua o cookies depois o host do usuario desejado na aba hotspot , vc vai ser desconectado do winbox e vai ter que se logar novamente . abaixo um exemplo de pagina de aviso que eu usava . espero que ajude .

    add name="aviso-128" address-pool=pool-clientes idle-timeout=none \
    keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    rate-limit="50k/128k" transparent-proxy=yes open-status-page=always \
    advertise=yes advertise-url=wirelesscity.net/aviso.html \
    advertise-interval=30s,1h advertise-timeout=never



  3. #3

    Padrão

    mas no caso eu sou um cliente e quero logar com outro usuário...mesmo removendo o cache do navegador continuo com o mesmo usuário...isso na verdade é até ruim pois se no caso de hotel que tem um center bussiness e é dado um usuário e senha..outra pessoa chega e nao precisa mais de usuárioi...navega com o outro usuário normalmente....não tem como ficar logando toda vez que o navegador é fechado?


    sobre o aviso no hotspot:

    testei com sua regra e deu na mesma...falam que tem que mexer no radvert.html mas não sei o que,,,

  4. #4

    Padrão

    Citação Postado originalmente por lfernandosg Ver Post
    mas no caso eu sou um cliente e quero logar com outro usuário...mesmo removendo o cache do navegador continuo com o mesmo usuário...isso na verdade é até ruim pois se no caso de hotel que tem um center bussiness e é dado um usuário e senha..outra pessoa chega e nao precisa mais de usuárioi...navega com o outro usuário normalmente....não tem como ficar logando toda vez que o navegador é fechado?


    sobre o aviso no hotspot:

    testei com sua regra e deu na mesma...falam que tem que mexer no radvert.html mas não sei o que,,,
    vá em hotspor server profile e diminua o tempo dos cookies na aba login , ja vem pré configurado pra 3dias , coloque o tempo que vc desejar . agora a pagina de aviso eu faço editando o arquivo radvert.html do hotspot . tem varias paginas de login com avisos prontas aki no under , experimenta usar uma pra ver o que aconteçe
    Última edição por carlinhotocabrabo; 04-06-2009 às 11:57.



  5. #5

    Padrão

    ouvir falar que tinha que remover esse arquivo ou editar...o que devo editar?? vc teria um exmplo de do arquivo radvert.html editado para eu saber o que devo editar para adicionar o aviso.html e bloqueio.html??

  6. #6

    Padrão

    agora funcionou..sabe o que era?


    o profile do server não estava em default...coloquei ai funcionou...vou testar os cokkies agora para ver se funciona para não ficar logado...


    depois do cokkies so vai ficar faltando uma coisa: como faço para bloquear sites pelo usuário e não por IP? já tenho o webproxy instalado mas lá mostra opção por IP.



  7. #7

    Padrão

    Citação Postado originalmente por carlinhotocabrabo Ver Post
    amigo para desconectar e entrar novamente no hotspot exclua o cookies depois o host do usuario desejado na aba hotspot , vc vai ser desconectado do winbox e vai ter que se logar novamente . abaixo um exemplo de pagina de aviso que eu usava . espero que ajude .

    add name="aviso-128" address-pool=pool-clientes idle-timeout=none \
    keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    rate-limit="50k/128k" transparent-proxy=yes open-status-page=always \
    advertise=yes advertise-url=wirelesscity.net/aviso.html \
    advertise-interval=30s,1h advertise-timeout=never
    boa dica...

  8. #8

    Padrão

    Toda e qualquer dúvida sobre o assunto, até a remoção da pop-up da radvert.html está neste material, funciona qualquer tipo de aviso: