+ Responder ao Tópico



  1. #1

    Padrão upgrade Mikrotik 2.9.27 para 3.13

    Olá pessoal, acho q esse é meu primeiro post aqui, espero poder contribuir mais no futuro, pois tbem sou iniciante no mk mesmo já usando ele por mais de ano.
    Bom, vamos lá,
    Trabalho com o Mk 2.9.27 a mais de ano, versão crakeada, mas como uso o cache no mk, e o nível de processamento ta chegando a 100% em horários de pico, resolvi comprar a licença da versão 3.13 nível 5, para poder colocar mais memória e processadores mais rápidos e hds sata.
    Instalei o mk completo sem os pacotes teste, joguei o backup da outra versão pra dentro e renomeei as interfaces, tbem configurei as interfaces manualmente nos ips, queues e arp, pois ele não pega automaticamente. Ok até aqui tdo bem, funcionando, somente o cache não está funcionando, Gostaria de saber se alguém já fez esse tipo de upgrade e o que eu tenho que mudar no proxy da nova versão para que ele funcione.

    Desde já agradeço a colaboração

  2. #2

    Padrão

    Você quis dizer seu 2º post. rss.
    Olha só, a diferença para esta versão não é tão grande.
    Olha só as configurações feita na versão 3.x:
    Código :
    ip proxy print
                     enabled: yes
                 src-address: 0.0.0.0
                        port: 3127
                parent-proxy: 0.0.0.0
           parent-proxy-port: 0
                 cache-drive: system
         cache-administrator: "webmaster"
              max-cache-size: 60000000KiB
               cache-on-disk: yes
      max-client-connections: 600
      max-server-connections: 600
              max-fresh-time: 3d
       serialize-connections: no
           always-from-cache: yes
              cache-hit-dscp: 4

    Só alterar no seu.



  3. #3

    Padrão

    Caro Raniel, realmente postei duas vezes, pois ninguem respondeu,,,rsrs
    Obrigado pela resposta, mas ainda não consegui resolver o problema, a config do proxy está exatamente como vc colocou, o direcionamento da porta 80 para o proxy, porta 3126 tbem parece estar correto, mas nada acontece, o proxy parece estar morto...rsrs
    Request 0 hits 0.....
    Não sei mais o que fazer, help please....
    Obrigado....

  4. #4

    Padrão

    E o seu nat está direitinho?



  5. #5

    Padrão

    Caro mestre,,
    Dei uma olhada bem com calma hoje, vi q algumas coisas estavam diferente do outro q funciona, fiz a mudança, agora tem requests, mas hits ainda ta em 0 e não navega se abilitar o redirecionamento no nat. Ai deixei desabilitado, vou colar a regra aqui com o redir desabilitado, se puder dar uma olhadinha, agradeço..
    Obrigado pela força....

    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Rede Wds
    chain=srcnat action=masquerade src-address=10.0.0.0/8
    1 chain=dstnat action=accept dst-address=200.201.0.0/16
    2 chain=dstnat action=accept dst-address=200.221.0.0/16
    3 chain=dstnat action=accept dst-address=201.67.197.0/24
    4 chain=dstnat action=accept dst-port=443 protocol=tcp
    5 X chain=dstnat action=redirect to-ports=3126 src-address=10.0.0.0/8
    dst-port=80 protocol=tcp

    Regras proxy
    /ip proxy> print
    enabled: yes
    src-address: 0.0.0.0
    port: 3126
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-drive: system
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: yes
    cache-hit-dscp: 4

    Regra Proxy access

    0 ;;; block telnet & spam e-mail relaying
    23-25 deny

    Regra proxy cache

    # DST-PORT DST-HOST PATH METHOD ACTION HITS
    0 0-65535 :cgi-bin \? deny 0
    Última edição por csoares; 09-06-2009 às 14:17.

  6. #6

    Padrão

    Veja se não há alguma regra na aba "filter" bloqueando esta porta (3126).
    Aqui está a regra que uso e funciona perfeitamente:
    /ip firewall nat add chain=dstnat action=redirect to-ports=3127 dst-port=80 protocol=tcp
    Coloque sobre as outras, menos aquelas que pretende não deixar ir ao proxy.



  7. #7

    Padrão

    Olá Raniel, novamente valeu pela dica, mas desabilitei a regra q eu tinha e coloquei a sua, e nada, dá pagina encontrada, aguarde, mas não abre...A unica diferença entre a tua e a minha era o src address q eu tinha colocado a classe da minha rede 10.0.0.0/8 e a porta 3126 a minha e a tua 3127.
    Já não sei mais o q fazer, a rede tá um lixo na hora do pico...

    Agradeço a ajuda,,,valeu mesmo....

  8. #8

    Padrão

    Caro Raniel, se ainda tiver um tempinho e quiser ajudar...
    Estas são as unicas regras para porta 3126, uma liberando o proxy nessa porta,
    e outra bloqueando o acesso externo do proxy.
    De qualquer forma, agradeço o amigo...

    ;;; allow Web Proxy
    chain=services action=accept dst-port=3126 protocol=tcp

    X ;;; BLOQUEIO DO PROXY EXTERNO
    chain=input action=drop in-interface=Speed dst-port=3126 protocol=tcp