+ Responder ao Tópico



  1. Fala galera,
    eu to usando esse script abaixo para dizer "o que vem de 192.168.211.0, sai pela MUNDIVOX, e tudo que vem de 192.168.0.0 sai pela EMBRATEL".

    Então, só que não está fazendo essa rota... não sei porque... alguem poderia me ajudar? Ele só sai pelo default gateway....

    iptables -t nat -A POSTROUTING -o eth2 -j MASQUERADE
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    ip rule add from 192.168.211.0/24 table link1
    ip rule add from 192.168.0.0/23 table link2
    ip route add default via 200.196.54.34 dev eth2 table link1
    ip route add default via 201.73.46.34 dev eth1 table link2
    ip route flush cache

    Alguem pode me ajudar?? to desesperado ja... valeu amigos

  2. ip rule add from 192.168.211.0/24 table link1
    ip rule add from 192.168.0.0/23 table link2
    Isso aqui esta errado o link2 esta sobrepondo o link1 uma vez que sempre a rede me menor bits vai "engolir" a de maior... e alias rede de /23 é complicada nesse caso, até pq essa classe naum permite isso de forma normal... tenta assim

    ip rule add from 192.168.211.0/24 table link1 (ou seja de 192.168.211.1 - 254)
    ip rule add from 192.168.0.0/24 table link2 (ou seja 192.168.0.1 - 254)

    Mude isso que vai funcionar.



  3. Valeu amigo, amanha no trabalho vou testar...

    O que eu estou querendo é feito dessa forma mesmo amigo?

    Ah... vc poderia me dizer ou algum amigo o seguinte: eu rodei outro script lá que alterou minhas rotas todas e ficou uma zona... qual comando eu "limpo" essas rotas e deixo tudo padrão?

    Obrigadão vcs sao demais.

  4. Valeu amigo, amanha no trabalho vou testar...

    Mas então, se a regra link2 tivesse sobrepondo eu teria que sair pela Embratel, mas não, eu saio pelo default gateway que é a MUNDIVOX... sacou?

    O que eu estou querendo é feito dessa forma mesmo amigo?

    Ah... vc poderia me dizer ou algum amigo o seguinte: eu rodei outro script lá que alterou minhas rotas todas e ficou uma zona... qual comando eu "limpo" essas rotas e deixo tudo padrão?

    Obrigadão vcs sao demais.



  5. AQUI tem o comando.
    Última edição por Lord; 15-06-2009 às 15:26.






Tópicos Similares

  1. Load Balace PCC - Não ta fazendo 1 bom Balance
    Por AndersonFox no fórum Redes
    Respostas: 6
    Último Post: 31-10-2013, 22:45
  2. mikrotik nao ta fazendo o controle de banda
    Por kanazuchi no fórum Redes
    Respostas: 1
    Último Post: 04-05-2008, 10:29
  3. Respostas: 6
    Último Post: 27-09-2006, 16:54
  4. Porque não Pinga???
    Por Perdigao no fórum Servidores de Rede
    Respostas: 4
    Último Post: 02-06-2003, 13:15
  5. porque não funciona???
    Por beastie no fórum Servidores de Rede
    Respostas: 4
    Último Post: 28-02-2003, 12:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L