+ Responder ao Tópico



  1. Pessoal, peguei este post, do Alexandre Correa, mas não está funcionando com a versão 3.25 do Mikrotik, aguém tem a alteração para funcionar?

    contribuindo mais... fiz uma alteração...

    voce pode definir.. se vai apenas DROPAR o cliente, forçando uma reconexão. em alguns casos.. o cliente volta com ack baixo

    Código:
    # Defina abaixo o valor mínimo de ACK
    :global ack 30;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;

    # Defina abaixo a Interface
    :global interf "wlan1";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };

  2. Ele não está identificando clientes com ACK alto



  3. Eu tbm estou com o mesmo problema, tanto nessa versao e na 3.24 tbm.






Tópicos Similares

  1. Cliente perto com ack alto!!!!
    Por FernandodeDeus no fórum Redes
    Respostas: 9
    Último Post: 15-12-2009, 20:03
  2. Clientes com ping alto
    Por pedrokampos no fórum Redes
    Respostas: 14
    Último Post: 16-11-2009, 19:27
  3. Clientes com Ping alto depois de certo tempo.
    Por mrebeque no fórum Redes
    Respostas: 13
    Último Post: 03-03-2009, 00:18
  4. clientes com ack alto
    Por druga no fórum Redes
    Respostas: 5
    Último Post: 02-12-2008, 22:01
  5. Mikrotk: Clientes com ping alto
    Por garotof1 no fórum Redes
    Respostas: 11
    Último Post: 19-12-2007, 00:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L